[PATCH] gnu: chrony: Update to 4.5.

  • Open
  • quality assurance status badge
Details
One participant
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 28 May 23:28 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
3171a9e4edc3ed7f132527a9eaa17cb99f7a3649.1716931733.git.poptsov.artyom@gmail.com
* gnu/packages/ntp.scm (chrony): Update to 4.5.
[source]: Download from GitLab as the original site is not accessible
anymore.
[native-inputs]: Add "bison" and "ruby-asciidoctor".
[synopsis]: Fix a typo.
[description]: Improve formatting.
[home-page]: Change to "https://chrony-project.org/".

Change-Id: I33b053fff0aced37cefab9f3c5df44fe2b9abb0c
---
gnu/packages/ntp.scm | 28 +++++++++++++++++-----------
1 file changed, 17 insertions(+), 11 deletions(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 3b56580842..30f3e32beb 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,11 +30,13 @@ (define-module (gnu packages ntp)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
#:use-module (gnu packages nettle)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages tls)
#:use-module (guix build-system gnu)
#:use-module (guix download)
@@ -47,14 +50,16 @@ (define-module (gnu packages ntp)
(define-public chrony
(package
(name "chrony")
- (version "4.4")
+ (version "4.5")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://download.tuxfamily.org/chrony/"
- "chrony-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/chrony/chrony")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "123h2a9rpc6wbvnysvhl5pmckvynzrnqay7l00i18azrvbk0gyza"))))
+ (base32 "0w6wgpgvwidsfc4mmi5zb73y9lydzwgwxpj0q5r1m47gd1qxa24n"))))
(build-system gnu-build-system)
(arguments
(list
@@ -79,23 +84,24 @@ (define-public chrony
(let* ((doc (string-append #$output "/share/doc/"
#$name "-" #$version)))
(for-each (cut install-file <> doc)
- (list "README" "FAQ"))
+ (list "README"))
(copy-recursively "examples"
(string-append doc "/examples"))))))))
(native-inputs
- (list pkg-config))
+ (list bison ruby-asciidoctor pkg-config))
(inputs
(list gnutls libcap libseccomp nettle))
- (home-page "https://chrony.tuxfamily.org/")
- (synopsis "System clock synchronisation service that speaks NTP")
+ (home-page "https://chrony-project.org/")
+ (synopsis "System clock synchronization service that speaks NTP")
(description
"Chrony keeps your system time accurate. It synchronises your computer's
clock with @acronym{NTP, Network Time Protocol} servers, reference clocks such
as GPS receivers, or even manual input of the correct time from a wristwatch.
Chrony will determine the rate at which the computer gains or loses time, and
-compensate for it. It can also operate as an NTPv4 (RFC 5905) server and peer
-to tell time to other computers on the network.
+compensate for it. It can also operate as an
+NTPv4 (@url{https://www.rfc-editor.org/rfc/rfc5905, RFC 5905}) server and peer to
+tell time to other computers on the network.
It's designed to perform well even under adverse conditions: congested
networks, unreliable clocks drifting with changes in temperature, and devices

base-commit: 542b18709a46e361de8f25e3fece29860532743c
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71251@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71251
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch