(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Sent with [Proton Mail](https://proton.me/)secure email.
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 77a8ff7476..8b7d18016f 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,6 +49,7 @@ (define-module (gnu packages shellutils)
#:use-module (guix build-system python)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
#:use-module (gnu packages flex)
@@ -333,6 +335,34 @@ (define-public zsh-syntax-highlighting
particularly in catching syntax errors.")
(license license:bsd-3)))
+(define-public zsh-powerlevel10k
+ (package
+ (name "zsh-powerlevel10k")
+ (version "1.20.0")
+ (home-page "https://github.com/romkatv/powerlevel10k")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/romkatv/powerlevel10k")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ha7qb601mk97lxvcj9dmbypwx7z5v0b7mkqahzsq073f4jnybhi"))))
+(build-system copy-build-system)
+(native-inputs
+ (list bash))
+(arguments
+ `(#:install-plan `(("powerlevel10k.zsh-theme" "share/zsh/plugins/zsh-powerlevel10k/")
+ ("powerlevel9k.zsh-theme" "share/zsh/plugins/zsh-powerlevel10k/")
+ ("config" "share/zsh/plugins/zsh-powerlevel10k/")
+ ("gitstatus" "share/zsh/plugins/zsh-powerlevel10k/")
+ ("internal" "share/zsh/plugins/zsh-powerlevel10k/"))))
+(synopsis "A fast reimplementation of Powerlevel9k ZSH theme")
+(description "To make use of this derivation, use
+ \"source\" zsh-powerlevel10k \"/share/zsh/plugins/zsh-powerlevel10k/powerlevel10k.zsh-theme\"")
+(license license:expat)))
+
(define-public grml-zsh-config
(package
(name "grml-zsh-config")