gnu: home: dotfiles: Files not excluded when they should
(address . bug-guix@gnu.org)
Hello,
While attempting to setup home-dotfiles-service, I noticed that some files
were being symlinked even though they were in the variable
`%home-dotfiles-excluded', such as all the files of the .git directory.
This patch seems to fix the problem :
Toggle diff (24 lines)
diff --git a/gnu/home/services/dotfiles.scm b/gnu/home/services/dotfiles.scm
index 823bdb03fb..38f7ff83d0 100644
--- a/gnu/home/services/dotfiles.scm
+++ b/gnu/home/services/dotfiles.scm
@@ -45,7 +45,7 @@ (define-module (gnu home services dotfiles)
(define %home-dotfiles-excluded
'(".*~"
".*\\.swp"
- "\\.git"
+ "\\.git/.*"
"\\.gitignore"))
(define %home-dotfiles-layouts
@@ -138,8 +138,7 @@ (define* (directory-contents directory #:key (packages
#f))
(define (filter-files directory)
(find-files directory
(lambda (file stat)
- (not (regexp-exec exclusion-rx
- (basename file))))))
+ (not (regexp-exec exclusion-rx file)))))
(if (and stow? packages (maybe-value-set? packages))
(append-map filter-files
(map (lambda (pkg)