[PATCH 1/2] gnu: guix: Add imagemagick, perl and use full graphviz.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Zheng Junjie
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 26 May 06:26 +0200
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
570f7c8fffe33eb297ee1ff6f018aeb8e3264c54.1716697564.git.maxim.cournoyer@gmail.com
This makes it possible to run 'make distcheck' in a 'guix shell -D guix'
environment.

* gnu/packages/package-management.scm (guix)
[native-inputs]: Replace graphviz-minimal with graphviz. Add imagemagick and
perl.

Change-Id: Ie400c622d8fc77108df29c03e11f36159d6f6238
---
gnu/packages/package-management.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 862de9f942..2f1434d5be 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -490,8 +490,10 @@ (define-public guix
("automake" ,automake)
("gettext" ,gettext-minimal)
("texinfo" ,texinfo)
- ("graphviz" ,graphviz-minimal)
+ ("graphviz" ,graphviz) ;non-minimal for PDF support
("font-ghostscript" ,font-ghostscript) ;fonts for 'dot'
+ ("imagemagick" ,imagemagick) ;for 'make dist'
+ ("perl" ,perl) ;for 'make dist'
("help2man" ,help2man)
("po4a" ,po4a-minimal)))
(inputs

base-commit: 77771036f0970083c146b709d792d128f4235125
--
2.41.0
Z
Z
Zheng Junjie wrote on 26 May 09:46 +0200
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 71204@debbugs.gnu.org)
87ikz1nhga.fsf@iscas.ac.cn
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (2 lines)
> This makes it possible to run 'make distcheck' in a 'guix shell -D guix'

I think maybe should add them to manifest.scm? And just 'guix shell' or
'guix shell -m manifest.scm'?


Toggle quote (29 lines)
> environment.
>
> * gnu/packages/package-management.scm (guix)
> [native-inputs]: Replace graphviz-minimal with graphviz. Add imagemagick and
> perl.
>
> Change-Id: Ie400c622d8fc77108df29c03e11f36159d6f6238
> ---
> gnu/packages/package-management.scm | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
> index 862de9f942..2f1434d5be 100644
> --- a/gnu/packages/package-management.scm
> +++ b/gnu/packages/package-management.scm
> @@ -490,8 +490,10 @@ (define-public guix
> ("automake" ,automake)
> ("gettext" ,gettext-minimal)
> ("texinfo" ,texinfo)
> - ("graphviz" ,graphviz-minimal)
> + ("graphviz" ,graphviz) ;non-minimal for PDF support
> ("font-ghostscript" ,font-ghostscript) ;fonts for 'dot'
> + ("imagemagick" ,imagemagick) ;for 'make dist'
> + ("perl" ,perl) ;for 'make dist'
> ("help2man" ,help2man)
> ("po4a" ,po4a-minimal)))
> (inputs
>
> base-commit: 77771036f0970083c146b709d792d128f4235125
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmZS6OYACgkQO1qpk+Gi
3/A4Sw//XSeH1/RBaJDt8GYltGZqIa36dgGJtu5CL+/VyHLvfb7oSIa5fLvyJf0+
ZOT6PXx+0jRKfOrHWC3g7ykJ1/i2qEuboAiy66wcdF0oI3dXWFoV+KBwaRn39bTX
n0pKviBYTVVpSd8uT6xN/nnO5fGvbWl/cJkkZO2nIPt28GHO6SaVG6Z/2LTbUl5I
LZdiCXiTbnXF5voca60wR6vt0gSZ0OYEBTYcRMoDlU7VXNji6515illDe4ju88Cy
uJ6mT/UsPjhVc496YhwhtsARqz4epQ/NVwIqqgExK+x1P7fw/4YScvu5M1r9gT4p
FCjDuEAOYuOadelhRQO/9q6vQnb3nUY41WlrvT6eDYcOMq1O82GEC7ShbxEMQGIw
7IuVDZZTByRhn+/Lv7eooh4c2WRB4hw6yZQ7xRwdcvuv5CZZ40U5Fg/n0g5BMuFa
OHjOTPVMPW+tN1ClvZ6jlZbHfMSYGW+s911+xxEKpIgRnfn6KqtIx8De8kD33HZ9
eAZco3QhoQ6xpXR4ei+jWWnthQ4DGJA2BnuIeWKYZl/5r2eqRO43gHnpI2VfHF+Z
wlnmFy1jKoW7XkZuKxhAUs09UUX2xZEJSZ4+iIBZ13WhMA/vOCiga+YoKm6i5pJI
pGTEFCBm1SUHZHitSBJFGDHqdbRIN4rmILfEKD+jNQOJRmf5ia4=
=RHyJ
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 26 May 13:53 +0200
[PATCH 2/2] manifest: Streamline; add packages useful for patch review/submission.
(address . 71204@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
bd9394cb04f28448fe018778fc33602148f87aa5.1716724414.git.maxim.cournoyer@gmail.com
* manifest.scm: Fix alternate command line invocation (which would not
consider 'manifest.scm'). Use specifications instead of packages. Remove
perl (now in the guix package's native inputs). Add b4, git, git:send-email,
mumi, nss-certs, openssl and patman to the manifest.

Change-Id: I49d92dda059856ce217cea9054a466a1754dcf94
---

manifest.scm | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)

Toggle diff (38 lines)
diff --git a/manifest.scm b/manifest.scm
index 2bc225ead7..7e4d82c3a5 100644
--- a/manifest.scm
+++ b/manifest.scm
@@ -22,18 +22,19 @@
;;
;; or something like
;;
-;; guix shell --pure git git:send-email openssh
-
-(use-modules (guix profiles)
- (gnu packages gnupg)
- (gnu packages perl)
- (gnu packages package-management))
+;; guix shell --pure -m manifest.scm hello ...
(concatenate-manifests
- (list (package->development-manifest guix)
-
- ;; Extra packages used by make dist.
- (packages->manifest (list perl))
-
+ (list (package->development-manifest (specification->package "guix"))
;; Extra packages used by unit tests.
- (packages->manifest (list gnupg))))
+ (specifications->manifest (list "gnupg"))
+
+ ;; Useful extras for patches submission.
+ (specifications->manifest
+ (list "b4"
+ "git"
+ "git:send-email"
+ "mumi"
+ "nss-certs"
+ "openssl" ;required if using 'smtpEncryption = tls'
+ "patman"))))
--
2.41.0
M
M
Maxim Cournoyer wrote on 26 May 14:09 +0200
Re: [bug#71204] [PATCH 1/2] gnu: guix: Add imagemagick, perl and use full graphviz.
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)(address . 71204@debbugs.gnu.org)
87y17whj00.fsf@gmail.com
Hi Zheng,

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

Toggle quote (7 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> This makes it possible to run 'make distcheck' in a 'guix shell -D guix'

> I think maybe should add them to manifest.scm? And just 'guix shell' or
> 'guix shell -m manifest.scm'?

I think it's nice that 'make distcheck' works out of the box, even for
'guix shell -D guix ...'. According to 'guix size' the
new $GUIX_ENVIRONMENT produced with the added inputs do not add any
weight, so were probably already transitively referenced.

Also see PATCH 2/2 where I augment the manifest.scm file with
git:send-email and friends.

--
Thanks,
Maxim
Z
Z
Zheng Junjie wrote on 27 May 12:59 +0200
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 71204@debbugs.gnu.org)
87y17vsepc.fsf@iscas.ac.cn
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (15 lines)
> Hi Zheng,
>
> Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>
>>> This makes it possible to run 'make distcheck' in a 'guix shell -D guix'
>
>> I think maybe should add them to manifest.scm? And just 'guix shell' or
>> 'guix shell -m manifest.scm'?
>
> I think it's nice that 'make distcheck' works out of the box, even for
> 'guix shell -D guix ...'. According to 'guix size' the
> new $GUIX_ENVIRONMENT produced with the added inputs do not add any

ok, LGTM.

Toggle quote (4 lines)
> weight, so were probably already transitively referenced.
>
> Also see PATCH 2/2 where I augment the manifest.scm file with
> git:send-email and friends.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmZUZ48ACgkQO1qpk+Gi
3/DttBAAu0sWF3vnRyCWHYeDkcXKxmUT+SyjbcVctBPrgy2o56u2zKClTQ1epmst
1B7TApO5dBclQohj5zK6B+VN+nEFB5W1qo6D3+Ikwp5rK1A2MStjXeWCtI6Y2vqz
J0UgmVL8canJ9LsBQBsio/07P5Kq3qcJK0wQOMcX/rIBs9IMz2cgcMwzzdzMWHfE
pV9dq6wdlbx0bLhM8CTRdQ+zxOGc5jVF+ZbM0386Rwd7hGCZfC++mRI5LEgtYF7Z
ywI90/aZMArw2NwoRz+LOpCPJxV3xsgWgLn73RYlB2JsuGcPn1P4Lgjo5uk+vGOz
O115NzTlJ6dbX5KMOngPXwh7Q/HzBVKqTWIRHeQsPK/+fxfSoDJhVhxSf3KQzKvO
KBdbpcKzAvs8o/WLqxnY4FknwIGaXw/E5FidzH555xomE1sqkOOyjX+cEbezjMAU
QB6yiArWv7V0AcS2Wl6DVImVZrMr1ugDfZ+E9z0he7YLXI5M9kfDhxPCNLU5Fgcl
RU7J01ekaMBr/lPo1sKYjKDp0pI6+SgnHVHnCSznZCSZT1u6GcoUlgPRMMtBPsSf
mgxZwPAvBsjzEPnm00soBgsJv7VAZX2Em+WBGsC73hDN4B20T2Twg0K3CjI+ROw+
w7sS7Cv10eTu3i2LHix6WG96ljl2X69VbutWld7BJ3ihAKwAOVI=
=gaxl
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 24 Jun 04:58 +0200
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)(address . 71204-done@debbugs.gnu.org)
87cyo759n6.fsf@gmail.com
Hi,

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

Toggle quote (19 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Hi Zheng,
>>
>> Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
>>
>>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>>
>>>> This makes it possible to run 'make distcheck' in a 'guix shell -D guix'
>>
>>> I think maybe should add them to manifest.scm? And just 'guix shell' or
>>> 'guix shell -m manifest.scm'?
>>
>> I think it's nice that 'make distcheck' works out of the box, even for
>> 'guix shell -D guix ...'. According to 'guix size' the
>> new $GUIX_ENVIRONMENT produced with the added inputs do not add any
>
> ok, LGTM.

Applied, thanks for taking a look!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71204@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71204
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch