gnu: lisp.scm: add roswell package

  • Done
  • quality assurance status badge
Details
2 participants
  • not emma
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
not emma
Severity
normal
N
N
not emma wrote on 26 May 04:26 +0200
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
o_BfoeEIMHdD6lA7uO_sFkXYlzx_9fmLgtqm8F8ga6cAzhPjJS0juhArZR7Vb_3A2jSxJGuQwrAiZSIyA5Ae_zRIz2IEuB57ipZsdNZZa6o=@proton.me
I was unsure whether this would fit better under lisp.scm, or lisp-xyz.scm, but think the former is a better choice because it's independent of any specific common lisp implementation.

Sent with [Proton Mail](https://proton.me/)secure email.
Attachment: file
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm index 83ff93719e..f50284fdeb 100644 --- a/gnu/packages/lisp.scm +++ b/gnu/packages/lisp.scm @@ -27,6 +27,7 @@ ;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream> ;;; Copyright © 2023 Andrew Kravchuk <awkravchuk@gmail.com> ;;; Copyright © 2024 Andreas Enge <andreas@enge.fr> +;;; Copyright © 2024 bigbug <bigbookofbug@proton.me> ;;; ;;; This file is part of GNU Guix. ;;; @@ -62,12 +63,15 @@ (define-module (gnu packages lisp) #:use-module (guix build-system trivial) #:use-module (gnu packages admin) #:use-module (gnu packages algebra) + #:use-module (gnu packages autotools) #:use-module (gnu packages base) #:use-module (gnu packages bash) #:use-module (gnu packages bdw-gc) #:use-module (gnu packages check) #:use-module (gnu packages compression) + #:use-module (gnu packages curl) #:use-module (gnu packages dbm) + #:use-module (gnu packages elf) #:use-module (gnu packages fontutils) #:use-module (gnu packages gcc) #:use-module (gnu packages gettext) @@ -1614,3 +1618,37 @@ (define-public s7 (delete-file (string-append #$output "/bin/ffitest")))))))) (native-inputs (list s7-bootstrap)) (properties (alist-delete 'hidden? (package-properties s7-bootstrap))))) + +(define-public roswell + (package + (name "roswell") + (version "23.10.14.114") + (home-page "https://github.com/roswell/roswell") + (source + (origin + (method git-fetch) + (uri (git-reference + (url "https://github.com/roswell/roswell") + (commit (string-append "v" version)))) + (sha256 + (base32 "05w5sjh1bfy2wnblc09cb9qs8h7hxkx5hcqlbgpn7md32b0m4h7g")))) + (build-system gnu-build-system) + (arguments + `(#:configure-flags (list (string-append "--prefix=" %output)) + #:tests? #f)) + (native-inputs + (list automake autoconf intltool)) + (inputs (list curl)) + (propagated-inputs (list patchelf gnu-make)) ;;has to be propogated in order to be found during setup + (synopsis "Common Lisp implementation manager, launcher, and more") + (description + "Roswell started out as a command-line tool with the aim to make +installing and managing Common Lisp implementations really simple and easy. +Roswell has now evolved into a full-stack environment for Common Lisp +development, and has many features that makes it easy to test, share, and +distribute your Lisp applications. + +Roswell is still in beta. Despite this, the basic interfaces are stable and +not likely to change.") + (license license:expat)))
G
G
Guillaume Le Vaillant wrote on 27 May 14:03 +0200
(name . not emma)(address . bigbookofbug@proton.me)(address . 71202@debbugs.gnu.org)
877cff31ij.fsf@kitej
Hi.

I remember that in the past someone tried to make a patch for roswell.
It built fine, but there were some issues when running it. Roswell
had difficulties finding or running sbcl, I think.

So, with your patch, does everything just work fine when building and
running it?
Or are there some extra configuration steps to take? If so, maybe it
could be indicated in the 'description' field.

-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZlR2lA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+rYAD+JDn4Ggt8KYtx9NSDy3K5jML81IWIbhDfO3Vk
Qv56IqcA/1s7D6r7JqEo8vCAIoF6siffwTtentPbeFOHy8hwzMkn
=+unQ
-----END PGP SIGNATURE-----

N
N
not emma wrote on 27 May 20:44 +0200
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 71202@debbugs.gnu.org)
zKaZTTmY5Z0UykjeXL_XJSJiQuLWI7YhEx5hpxKzrupvfHjJGR25yT5xw9DmN3_8IYVhm1xnbyJBmrtx938kwMAVGgJY0iN4Pd6wA_aZ-D8=@proton.me
Hi,

I had some initial issues with sbcl and glibc32, but those were resolved by propagating patchelf and make (the former to resolve the glibc32 error, and the latter because roswell has to run a setup on initial install, and references its makefile). Based on this issue: https://github.com/roswell/roswell/issues/387, it seems like the primary difficulty was with curl, but that was resolved.




Sent with Proton Mail secure email.

On Monday, May 27th, 2024 at 12:03 PM, Guillaume Le Vaillant <glv@posteo.net> wrote:

Toggle quote (14 lines)
> Hi.
>
> I remember that in the past someone tried to make a patch for roswell.
> It built fine, but there were some issues when running it. Roswell
> had difficulties finding or running sbcl, I think.
>
> So, with your patch, does everything just work fine when building and
> running it?
> Or are there some extra configuration steps to take? If so, maybe it
> could be indicated in the 'description' field.
>
> See https://issues.guix.gnu.org/37200
>
> and https://github.com/roswell/roswell/issues/387.
G
G
Guillaume Le Vaillant wrote on 28 May 15:47 +0200
(name . not emma)(address . bigbookofbug@proton.me)(address . 71202-done@debbugs.gnu.org)
875xuynj40.fsf@kitej
Patch applied as 542b18709a46e361de8f25e3fece29860532743c with a few
modifications.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZlXgfw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8N4AD/Q30ZtPOG4LUBPLKYoeaXQPhE6BPnV1q6dkYp
k3ZY9JEA/3xX8+XorAm/PX0XgbXuPfJPfAS0gfItZjnNt/ZiFvkc
=lm2g
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71202@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71202
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch