[PATCH] doc: Replace 'specification->package+output' with 'specifications->packages'.

  • Done
  • quality assurance status badge
Details
2 participants
  • iyzsong
  • Maxim Cournoyer
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 26 May 02:23 +0200
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
4f85abaf9a60c8ce21bf7aad916fd5a8476ee88c.1716682979.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

'(map specification->package+output specs)' doesn't work due to
'specification->package+output' will return multiple values.

* doc/guix.texi (Using the Configuration System): Replace
'specification->package+output' with 'specifications->packages'.

Change-Id: I443771327a2ef5ae5e7dddd9785f1eef4200e898
---
doc/guix.texi | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (32 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 8073e3f6d4..8cb1a541eb 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -17246,10 +17246,10 @@ Using the Configuration System
%base-packages)))
@end lisp
-@findex specification->package+output
+@findex specifications->packages
When a package has more than one output it can be a challenge to refer to a
specific output instead of just to the standard @code{out} output. For these
-situations one can use the @code{specification->package+output} procedure from
+situations one can use the @code{specifications->packages} procedure from
the @code{(gnu packages)} module. For example:
@lisp
@@ -17257,8 +17257,8 @@ Using the Configuration System
(operating-system
;; ...
- (packages (append (map specification->package+output
- '("git" "git:send-email"))
+ (packages (append (specifications->packages
+ '("git" "git:send-email"))
%base-packages)))
@end lisp

base-commit: 9756d9d6345fb142944261174453ab0a597cc2e7
--
2.41.0
M
M
Maxim Cournoyer wrote on 26 May 13:57 +0200
(address . iyzsong@envs.net)
8734q4iy5c.fsf@gmail.com
iyzsong@envs.net writes:

Toggle quote (10 lines)
> From: ??? <iyzsong@member.fsf.org>
>
> '(map specification->package+output specs)' doesn't work due to
> 'specification->package+output' will return multiple values.
>
> * doc/guix.texi (Using the Configuration System): Replace
> 'specification->package+output' with 'specifications->packages'.
>
> Change-Id: I443771327a2ef5ae5e7dddd9785f1eef4200e898

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
?
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87sey4vxes.fsf@envs.net
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (14 lines)
> iyzsong@envs.net writes:
>
>> From: ??? <iyzsong@member.fsf.org>
>>
>> '(map specification->package+output specs)' doesn't work due to
>> 'specification->package+output' will return multiple values.
>>
>> * doc/guix.texi (Using the Configuration System): Replace
>> 'specification->package+output' with 'specifications->packages'.
>>
>> Change-Id: I443771327a2ef5ae5e7dddd9785f1eef4200e898
>
> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

Pushed to master as commit f119408f2f, thank you for review.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71201@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71201
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch