[PATCH 0/3] *** Update Mixxx and depdendencies ***

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • jgart
  • hapster
Owner
unassigned
Submitted by
hapster
Severity
normal
H
H
hapster wrote on 25 May 14:59 +0200
(address . guix-patches@gnu.org)(name . hapster)(address . o.rojon@posteo.net)
20240525125955.27269-1-o.rojon@posteo.net
Hej fellas,

I just updated Mixxx to the newest version (2.4.1), updating its dependencies along the way. This is the first time I upload patches yet I hope to have followed the instructions alright.

In updating Mixxx I changed some of the code necessary to get 2.3.6 to run. I tried to make those different commits, but using hunks from the command line is not yet a specialty of mine (next time I will use magit).

I hope you now have got all the information you need to review this.

Have a good day,
hapster

hapster (3):
gnu/packages/music: Update Mixxx to 2.4.1
gnu/packages/audio: Update Soundtouch to 2.3.1
gnu/packages/libusb: Update hidapi to 0.14.0

gnu/packages/audio.scm | 4 +-
gnu/packages/libusb.scm | 4 +-
gnu/packages/music.scm | 143 +++++++++++++++++++---------------------
3 files changed, 73 insertions(+), 78 deletions(-)


base-commit: 7881d6085146fefda17ed9eefa133b5b5c97af87
--
2.41.0
H
H
hapster wrote on 26 May 08:20 +0200
[PATCH 2/3] gnu/packages/audio: Update Soundtouch to 2.3.1
(address . 71196@debbugs.gnu.org)(name . hapster)(address . o.rojon@posteo.net)
20240526062039.23055-2-o.rojon@posteo.net
Change-Id: I0ca03186283d85f0ffa24c222ab2d1269fb94f63
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d30d561d2f..4ef27cadef 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4181,7 +4181,7 @@ (define-public xmp
(define-public soundtouch
(package
(name "soundtouch")
- (version "2.2")
+ (version "2.3.1")
(source
(origin
(method git-fetch)
@@ -4190,7 +4190,7 @@ (define-public soundtouch
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "12i6yg8vvqwyk412lxl2krbfby6hnxld8qxy0k4m5xp4g94jiq4p"))))
+ (base32 "10znckb8mrnmvwj7vq12732al873qhqw27fpb5f8r0bkjdpcj3vr"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake libtool file))
--
2.41.0
H
H
hapster wrote on 26 May 08:20 +0200
[PATCH 1/3] gnu/packages/music: Update Mixxx to 2.4.1
(address . 71196@debbugs.gnu.org)(name . hapster)(address . o.rojon@posteo.net)
20240526062039.23055-1-o.rojon@posteo.net
Change-Id: I2ee0f2848dba7a917598a97a295d838bc0656716
---
gnu/packages/music.scm | 143 ++++++++++++++++++++---------------------
1 file changed, 69 insertions(+), 74 deletions(-)

Toggle diff (174 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 90bfe1c891..b509e64281 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2377,7 +2377,7 @@ (define-public petri-foo
(define-public mixxx
(package
(name "mixxx")
- (version "2.3.6")
+ (version "2.4.1")
(source
(origin
(method git-fetch)
@@ -2385,90 +2385,85 @@ (define-public mixxx
(url "https://github.com/mixxxdj/mixxx")
(commit version)))
(file-name (git-file-name name version))
- (patches
- (search-patches "mixxx-link-qtscriptbytearray-qtscript.patch"
- "mixxx-system-googletest-benchmark.patch"))
(sha256
- (base32 "1v1sza75rf2q1m0bdc0j2k53qd34m12d1573jmac3g7vvyqh5n2m"))
+ (base32 "0cfdgrxfhck6cg4j9mb2rdp06n57kca1403qw92c3pmk1y05grq4"))
(modules '((guix build utils)))
(snippet
;; Delete libraries that we already have or don't need.
;; TODO: try to unbundle more (see lib/).
`(begin
- (let ((third-parties '("apple" "benchmark" "googletest" "hidapi"
- "libebur128")))
+ (let ((third-parties '("apple" "hidapi")))
(with-directory-excursion "lib"
(map (lambda (third-party)
- (delete-file-recursively third-party))
- third-parties)))
+ (delete-file-recursively third-party)) third-parties)))
#t))))
(build-system qt-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Tests need a running X server.
- (add-before 'check 'prepare-x-for-test
- (lambda _
- (system "Xvfb &")
- (setenv "DISPLAY" ":0")))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (faad2 (assoc-ref inputs "faad2")))
- (wrap-program (string-append out "/bin/mixxx")
- `("LD_LIBRARY_PATH" ":" prefix
- ,(list (string-append faad2 "/lib"))))))))))
- (native-inputs
- (list benchmark
- googletest
- python-wrapper
- qttools-5
- xorg-server-for-tests))
- (inputs
- (list bash-minimal
- chromaprint
- faad2
- ffmpeg
- fftw
- flac
- glu
- hidapi
- jack-1
- lame
- libdjinterop
- libebur128
- libid3tag
- libkeyfinder
- libmad
- libmp4v2
- libmodplug
- libsndfile
- libshout
- ;; XXX: Mixxx complains the libshout-idjc package suffers from bug
- ;; lp1833225 and refuses to use it. Use the bundle for now.
- ;; libshout-idjc
- libusb
- libvorbis
- lilv
- mp3guessenc
- openssl
- opusfile
- portaudio
- portmidi
- protobuf
- qtbase-5
- qtdeclarative-5
- qtkeychain
- qtscript
- qtsvg-5
- qtx11extras
- rubberband
- soundtouch
- sqlite
- taglib
- upower
- vamp
- wavpack))
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-bugged-test
+ ;; This test regularly fails and aborts the build process, hence it
+ ;; was disabled (no impact on functionality). It appears this is a
+ ;; problem for some upstream as well, as indicated by:
+ ;; https://github.com/mixxxdj/mixxx/issues/12887 (featuring a
+ ;; reference to another issue related to the same problem).
+ (lambda _
+ (substitute* "src/test/soundproxy_test.cpp"
+ (("TEST_F\\(SoundSourceProxyTest, firstSoundTest\\)")
+ "TEST_F(SoundSourceProxyTest, DISABLED_firstSoundTest)"))))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (faad2 (assoc-ref inputs "faad2")))
+ (wrap-program (string-append out "/bin/mixxx")
+ `("LD_LIBRARY_PATH" ":" prefix
+ ,(list (string-append faad2 "/lib"))))))))))
+ (native-inputs (list benchmark googletest python-wrapper qttools-5
+ xorg-server-for-tests))
+ (inputs (list bash-minimal
+ chromaprint
+ faad2
+ ffmpeg
+ fftw
+ flac
+ glu
+ hidapi
+ jack-1
+ lame
+ libdjinterop
+ libebur128
+ libid3tag
+ libkeyfinder
+ libmad
+ libmp4v2
+ libmodplug
+ libsndfile
+ libshout
+ ;; XXX: Mixxx complains the libshout-idjc package suffers from bug
+ ;; lp1833225 and refuses to use it. Use the bundle for now.
+ libshout-idjc
+ libusb
+ libvorbis
+ lilv
+ mp3guessenc
+ openssl
+ opusfile
+ portaudio
+ portmidi
+ protobuf
+ qtbase-5
+ qtdeclarative-5
+ qtkeychain
+ qtscript
+ qtsvg-5
+ qtx11extras
+ rubberband
+ soundtouch
+ sqlite
+ taglib
+ upower
+ vamp
+ wavpack
+ c++-gsl))
(home-page "https://mixxx.org/")
(synopsis "DJ software to perform live mixes")
(description "Mixxx is a DJ software. It integrates the tools DJs need to
--
2.41.0
H
H
hapster wrote on 26 May 08:20 +0200
[PATCH 3/3] gnu/packages/libusb: Update hidapi to 0.14.0
(address . 71196@debbugs.gnu.org)(name . hapster)(address . o.rojon@posteo.net)
20240526062039.23055-3-o.rojon@posteo.net
Change-Id: I6bb2be79dcda17029eddd643fc91e54d5a5de630
---
gnu/packages/libusb.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 948d5dbccc..9a931ebbb0 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -681,7 +681,7 @@ (define-public gmtp
(define-public hidapi
(package
(name "hidapi")
- (version "0.10.1")
+ (version "0.14.0")
(source
(origin
(method git-fetch)
@@ -690,7 +690,7 @@ (define-public hidapi
(commit (string-append "hidapi-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1nr4z4b10vpbh3ss525r7spz4i43zim2ba5qzfl15dgdxshxxivb"))))
+ (base32 "121laqsml0104d1h4hp115gp21qiqi0r9dgcaqdi9ismmq3b6yx7"))))
(build-system gnu-build-system)
(inputs
(list libusb eudev))
--
2.41.0
H
H
hapster wrote on 26 May 08:42 +0200
[PATCH 1/3] gnu/packages/music: Update Mixxx to 2.4.1
(address . 71196@debbugs.gnu.org)(name . hapster)(address . o.rojon@posteo.net)
20240526064212.24517-1-o.rojon@posteo.net
Change-Id: I2ee0f2848dba7a917598a97a295d838bc0656716
---
gnu/packages/music.scm | 143 ++++++++++++++++++++---------------------
1 file changed, 69 insertions(+), 74 deletions(-)

Toggle diff (174 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 90bfe1c891..b509e64281 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2377,7 +2377,7 @@ (define-public petri-foo
(define-public mixxx
(package
(name "mixxx")
- (version "2.3.6")
+ (version "2.4.1")
(source
(origin
(method git-fetch)
@@ -2385,90 +2385,85 @@ (define-public mixxx
(url "https://github.com/mixxxdj/mixxx")
(commit version)))
(file-name (git-file-name name version))
- (patches
- (search-patches "mixxx-link-qtscriptbytearray-qtscript.patch"
- "mixxx-system-googletest-benchmark.patch"))
(sha256
- (base32 "1v1sza75rf2q1m0bdc0j2k53qd34m12d1573jmac3g7vvyqh5n2m"))
+ (base32 "0cfdgrxfhck6cg4j9mb2rdp06n57kca1403qw92c3pmk1y05grq4"))
(modules '((guix build utils)))
(snippet
;; Delete libraries that we already have or don't need.
;; TODO: try to unbundle more (see lib/).
`(begin
- (let ((third-parties '("apple" "benchmark" "googletest" "hidapi"
- "libebur128")))
+ (let ((third-parties '("apple" "hidapi")))
(with-directory-excursion "lib"
(map (lambda (third-party)
- (delete-file-recursively third-party))
- third-parties)))
+ (delete-file-recursively third-party)) third-parties)))
#t))))
(build-system qt-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Tests need a running X server.
- (add-before 'check 'prepare-x-for-test
- (lambda _
- (system "Xvfb &")
- (setenv "DISPLAY" ":0")))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (faad2 (assoc-ref inputs "faad2")))
- (wrap-program (string-append out "/bin/mixxx")
- `("LD_LIBRARY_PATH" ":" prefix
- ,(list (string-append faad2 "/lib"))))))))))
- (native-inputs
- (list benchmark
- googletest
- python-wrapper
- qttools-5
- xorg-server-for-tests))
- (inputs
- (list bash-minimal
- chromaprint
- faad2
- ffmpeg
- fftw
- flac
- glu
- hidapi
- jack-1
- lame
- libdjinterop
- libebur128
- libid3tag
- libkeyfinder
- libmad
- libmp4v2
- libmodplug
- libsndfile
- libshout
- ;; XXX: Mixxx complains the libshout-idjc package suffers from bug
- ;; lp1833225 and refuses to use it. Use the bundle for now.
- ;; libshout-idjc
- libusb
- libvorbis
- lilv
- mp3guessenc
- openssl
- opusfile
- portaudio
- portmidi
- protobuf
- qtbase-5
- qtdeclarative-5
- qtkeychain
- qtscript
- qtsvg-5
- qtx11extras
- rubberband
- soundtouch
- sqlite
- taglib
- upower
- vamp
- wavpack))
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-bugged-test
+ ;; This test regularly fails and aborts the build process, hence it
+ ;; was disabled (no impact on functionality). It appears this is a
+ ;; problem for some upstream as well, as indicated by:
+ ;; https://github.com/mixxxdj/mixxx/issues/12887 (featuring a
+ ;; reference to another issue related to the same problem).
+ (lambda _
+ (substitute* "src/test/soundproxy_test.cpp"
+ (("TEST_F\\(SoundSourceProxyTest, firstSoundTest\\)")
+ "TEST_F(SoundSourceProxyTest, DISABLED_firstSoundTest)"))))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (faad2 (assoc-ref inputs "faad2")))
+ (wrap-program (string-append out "/bin/mixxx")
+ `("LD_LIBRARY_PATH" ":" prefix
+ ,(list (string-append faad2 "/lib"))))))))))
+ (native-inputs (list benchmark googletest python-wrapper qttools-5
+ xorg-server-for-tests))
+ (inputs (list bash-minimal
+ chromaprint
+ faad2
+ ffmpeg
+ fftw
+ flac
+ glu
+ hidapi
+ jack-1
+ lame
+ libdjinterop
+ libebur128
+ libid3tag
+ libkeyfinder
+ libmad
+ libmp4v2
+ libmodplug
+ libsndfile
+ libshout
+ ;; XXX: Mixxx complains the libshout-idjc package suffers from bug
+ ;; lp1833225 and refuses to use it. Use the bundle for now.
+ libshout-idjc
+ libusb
+ libvorbis
+ lilv
+ mp3guessenc
+ openssl
+ opusfile
+ portaudio
+ portmidi
+ protobuf
+ qtbase-5
+ qtdeclarative-5
+ qtkeychain
+ qtscript
+ qtsvg-5
+ qtx11extras
+ rubberband
+ soundtouch
+ sqlite
+ taglib
+ upower
+ vamp
+ wavpack
+ c++-gsl))
(home-page "https://mixxx.org/")
(synopsis "DJ software to perform live mixes")
(description "Mixxx is a DJ software. It integrates the tools DJs need to
--
2.41.0
H
H
hapster wrote on 26 May 08:42 +0200
[PATCH 3/3] gnu/packages/libusb: Update hidapi to 0.14.0
(address . 71196@debbugs.gnu.org)(name . hapster)(address . o.rojon@posteo.net)
20240526064212.24517-3-o.rojon@posteo.net
Change-Id: I6bb2be79dcda17029eddd643fc91e54d5a5de630
---
gnu/packages/libusb.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 948d5dbccc..9a931ebbb0 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -681,7 +681,7 @@ (define-public gmtp
(define-public hidapi
(package
(name "hidapi")
- (version "0.10.1")
+ (version "0.14.0")
(source
(origin
(method git-fetch)
@@ -690,7 +690,7 @@ (define-public hidapi
(commit (string-append "hidapi-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1nr4z4b10vpbh3ss525r7spz4i43zim2ba5qzfl15dgdxshxxivb"))))
+ (base32 "121laqsml0104d1h4hp115gp21qiqi0r9dgcaqdi9ismmq3b6yx7"))))
(build-system gnu-build-system)
(inputs
(list libusb eudev))
--
2.41.0
H
H
hapster wrote on 26 May 08:42 +0200
[PATCH 2/3] gnu/packages/audio: Update Soundtouch to 2.3.1
(address . 71196@debbugs.gnu.org)(name . hapster)(address . o.rojon@posteo.net)
20240526064212.24517-2-o.rojon@posteo.net
Change-Id: I0ca03186283d85f0ffa24c222ab2d1269fb94f63
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d30d561d2f..4ef27cadef 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4181,7 +4181,7 @@ (define-public xmp
(define-public soundtouch
(package
(name "soundtouch")
- (version "2.2")
+ (version "2.3.1")
(source
(origin
(method git-fetch)
@@ -4190,7 +4190,7 @@ (define-public soundtouch
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "12i6yg8vvqwyk412lxl2krbfby6hnxld8qxy0k4m5xp4g94jiq4p"))))
+ (base32 "10znckb8mrnmvwj7vq12732al873qhqw27fpb5f8r0bkjdpcj3vr"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake libtool file))
--
2.41.0
O
O
Olivier Rojon wrote on 30 May 08:25 +0200
Mentoring for Mixxx package update
(address . 71196@debbugs.gnu.org)
<878qzrerzj.fsf@>
Hello everyone

in case you are now notified twice (once with the patches and once with this
message), please agologize the noise. I am still learning the ins and outs of submitting
patches.

I am just writing here to make sure that mentors see the issue, because I'd love to see
these changes merged/included in Guix and get feedback on my (pretty messy IMO) process of
submitting the patch.

Have a good day and thanks for your time,
Olivier
J
b6393fad9fed103f48780c0ba737bb976f60b549@dismail.de
Hi Olivier,

Thanks for contributing to Guix! It looks like these patches will need to go to the staging branch because of the soundtouch dependency. The soundtouch package would require the building of 352 dependent packages.

Have you tried building the dependent packages yet to see if any fail after applying your changes?

You can run `./pre-inst-env guix refresh -l soundtouch` in the project repo in order to see them.

For more information on this requirement see the following section in the manual:


If you're interested, there is currently meetups being organized by Guix London that you can attend remotely to further learn about the patch review process:


all the best,

jgart

https://whereis.???/
O
O
Olivier Rojon wrote on 3 Jun 21:52 +0200
(name . jgart)(address . jgart@dismail.de)(address . 71196@debbugs.gnu.org)
<8734ptg5xn.fsf@>
Hi jgart,

thanks for the quick reply and the headsup -- I only checked `guix refresh -l` for mixxx itself, not the updated dependencies >.< Ow snap, that sure makes matters more complicated than they first seemed.

I have now moved my building to another, much more powerful machine. Nonetheless, this will take time.

I will report back when I made tangible progress.

Have a good day :)

"jgart" <jgart@dismail.de> writes:

Toggle quote (21 lines)
> Hi Olivier,
>
> Thanks for contributing to Guix! It looks like these patches will need to go to the staging branch because of the soundtouch dependency. The soundtouch package would require the building of 352 dependent packages.
>
> Have you tried building the dependent packages yet to see if any fail after applying your changes?
>
> You can run `./pre-inst-env guix refresh -l soundtouch` in the project repo in order to see them.
>
> For more information on this requirement see the following section in the manual:
>
> https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html
>
> If you're interested, there is currently meetups being organized by Guix London that you can attend remotely to further learn about the patch review process:
>
> https://libreplanet.org/wiki/Group:Guix/PatchReviewSessions2024
>
> all the best,
>
> jgart
>
> https://whereis.???/
J
(name . Olivier Rojon)(address . o.rojon@posteo.net)(address . 71196@debbugs.gnu.org)
4de7e2446f52234a6741eeac7ad6f4195dd321ad@dismail.de
Ok cool.

Keep us posted.

(Un)related, If you'd like to help with upgrading and maintaining Python packages that will be easier to merge into master faster then feel free to see what Python packages can receive small version updates with this command:

guix refresh -s 'module:(gnu packages python-xyz)'

all the best,

jgart
J
(name . Olivier Rojon)(address . o.rojon@posteo.net)(address . 71196@debbugs.gnu.org)
5bac0adb7ffef5ec0abb1f0e950339390a4d70e7@dismail.de
Toggle quote (2 lines)
> Just to be sure: if I want my changes merged sooner or later, I have to build all the package depending upon soundtouch and hidapi successfully within `guix shell -CPW` and `pre-inst-env`, correct?

Yes, that's correct.
Toggle quote (2 lines)
> Is there anything additional that I need to keep in mind when doing that?

Not that I'm aware of.

all best,

jgart
O
O
Olivier Rojon wrote on 5 Jun 16:49 +0200
(name . jgart)(address . jgart@dismail.de)(address . 71196@debbugs.gnu.org)
B9EEAC12-CDE5-4BE6-ACFC-D8CA98C3C9FE@posteo.net
Just to be sure: if I want my changes merged sooner or later, I have to build all the package depending upon soundtouch and hidapi successfully within `guix shell -CPW` and `pre-inst-env`, correct?

Is there anything additional that I need to keep in mind when doing that?

Have a good day,
Olivier

Am 3. Juni 2024 23:49:03 MESZ schrieb jgart <jgart@dismail.de>:
Toggle quote (11 lines)
>Ok cool.
>
>Keep us posted.
>
>(Un)related, If you'd like to help with upgrading and maintaining Python packages that will be easier to merge into master faster then feel free to see what Python packages can receive small version updates with this command:
>
>guix refresh -s 'module:(gnu packages python-xyz)'
>
>all the best,
>
>jgart
Attachment: file
O
O
Olivier Rojon wrote on 9 Jun 10:46 +0200
(address . 71196@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
<87jziywlj8.fsf@>
"jgart" <jgart@dismail.de> writes:

Hej,

I've taken the time to build the dependencies output by `./pre-inst-env guix refresh -L
$PKG` (where $PKG was one of `hidapi` and `soundtouch`). This was my process:

1) I created a new branch to which I applied the three patches sent in over here.
Unexperienced working with git branches, I compared if, when in `master`, mixxx-2.3.6 gets
build, while in my testing branch `mixxx-update`, mixxx-2.4.1. gets built, to see how the
`mixxx-update` branch was affected by those patches while `master` isn't.

2) I created a union of the output of `./pre-inst-env guix refresh -L` for `hidapi` and
`soundtouch`.

3) I mass-built the dependencies using a `for`-loop within `guix shell -CPW` and with
`./pre-inst-env`, also these lines:
for pkg in LONG-PKG-LIST; do ./pre-inst-env guix build $PKG; done

4) I checked for built failures.

5) In case of build failures, I switched to the `master` branch, to check if building
overe there is successful.

Of the 246 dependencies in LONG-PKG-LIST, 233 built successfully. Most of the failures
also failed on the `master`-branch, while some dependencies were discarded as "unknown
package". Find the list of packages where the build failed below:
- gnome-meta-core-utilities (unknown package)
- gnome-essential-extras (unknown package)
- gnome-meta-core-shell (unknown package)
- ledger-agent (also fails on master)
- giara (also fails on master)
- sequeler (also fails on master)
- eog-plugins (also fails on master)
- nomad (also fails on master)
- chatty (also fails on master)
- memphis (also fails on master)
- emacsy (also fails on master)
- dvdstyler (also fails on master)
- mate (also fails on master)

How to proceed?

Have a good day :)

Toggle quote (13 lines)
>> Just to be sure: if I want my changes merged sooner or later, I have to build all the
>> package depending upon soundtouch and hidapi successfully within `guix shell -CPW` and
>> `pre-inst-env`, correct?
>
> Yes, that's correct.
>
>> Is there anything additional that I need to keep in mind when doing that?
>
> Not that I'm aware of.
>
> all best,
>
> jgart
A
A
Andreas Enge wrote on 30 Jun 12:41 +0200
Pushed
(address . 71196-done@debbugs.gnu.org)
ZoE2XmfvWxNLLa77@jurong
Hello Olivier,

congratulations to your first contribution to Guix!

In the meantime QA has processed the patches, built its dependent packages
and given the green light (I think the threshold has been increased from
300 to 600).

I prefer to add the commits in the reverse order (first the dependencies,
then the leaves). I have added copyright lines for you and adapted the
commit log messages to our conventions. Finally I saw that you had dropped
a few patches, which need to be removed also from the git repository and
deregistered in the list of patches.

Pushed, and I am closing this issue.

Thanks,

Andreas
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71196@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71196
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch