Shepherd fails to start a system when given an incorrect form to the start field of any service

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Picnoir
Owner
unassigned
Submitted by
Picnoir
Severity
normal
P
P
Picnoir wrote on 25 May 09:33 +0200
(address . bug-guix@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
87fru6uyzg.fsf@alternativebit.fr
Hey Guix,

I'm facing a pretty annoying Shepherd 0.10.4 bug.

If a service start script gets provided an incorrect form, such as an
empty quoted list, Shepherd hangs during its early startup and bricks
the overall Guix system.

I think the following snippet is a good minimal reproducer for this. Add
this service to a guix system configuration:

Toggle snippet (28 lines)
(simple-service
'shepherd-bug-repro
shepherd-root-service-type
(list (shepherd-service
(documentation "shepherd hang minimal repro")
(provision '(shepherd-bug-repro))
(requirement '())
(start #~('())))))
u--8<---------------cut here---------------end--------------->8---

? DO NOT BOOT ON A CRITICAL SYSTEM WITH THIS SERVICE, IT'LL BRICK IT ?

You can create a VM for this system and start it. The VM hangs after the
log line "creating /etc/machine-id...", before any shepherd service gets
started.

You get the same behaviour if you end up booting by misfortune a "real"
system having this service.

Instead of having the whole system to freeze, I'd expect shepherd to
fail the particular service having an incorrect start form.

I'm not sure what's happening here. I did not manage to diagnose this further,
the shepherd does not seem to be super chatty at this stage of the boot.

Tested on Shepherd 0.10.4 with the Guix revision
c5e63e19ac672f9e63fc8ee98fa9a16f978ce19c.
L
L
Ludovic Courtès wrote on 26 Jun 15:47 +0200
(name . Picnoir)(address . picnoir@alternativebit.fr)(address . 71193@debbugs.gnu.org)
87msn7byt3.fsf@gnu.org
Hi Picnoir,

"Picnoir" <picnoir@alternativebit.fr> skribis:

Toggle quote (20 lines)
> I think the following snippet is a good minimal reproducer for this. Add
> this service to a guix system configuration:
>
> --8<---------------cut here---------------start------------->8---
> (simple-service
> 'shepherd-bug-repro
> shepherd-root-service-type
> (list (shepherd-service
> (documentation "shepherd hang minimal repro")
> (provision '(shepherd-bug-repro))
> (requirement '())
> (start #~('())))))
> u--8<---------------cut here---------------end--------------->8---
>
> ? DO NOT BOOT ON A CRITICAL SYSTEM WITH THIS SERVICE, IT'LL BRICK IT ?
>
> You can create a VM for this system and start it. The VM hangs after the
> log line "creating /etc/machine-id...", before any shepherd service gets
> started.

[...]

Toggle quote (3 lines)
> Tested on Shepherd 0.10.4 with the Guix revision
> c5e63e19ac672f9e63fc8ee98fa9a16f978ce19c.

This sounds very much like https://issues.guix.gnu.org/71144, which
was fixed in Guix commit cca25a67693bb68a1884a081b415a43fad1e8641,
shortly after the commit you mention.

I tested the reproducer you posted in a VM and it boots fine. The
problem simply leads to an error message in /var/log/messages:

Toggle snippet (6 lines)
Jun 26 15:43:09 localhost vmunix: [ 3.574026] shepherd[1]: Exception caught while loading '/gnu/store/c44hd3gfksalrbsgc3a0ax4v9jmnkzb4-shepherd-shepherd-bug-repro.go': #<&compound-exception components: (#<&assertion-failure> #<&origin origin: #f> #<&message message: "Wrong type to apply: ~S"> #<&i
Jun 26 15:43:09 localhost vmunix: [ 3.574132] rritants irritants: (())> #<&exception-with-kind-and-args kind: wrong-type-arg args: (#f "Wrong type to apply: ~S" (()) (()))>)>
Jun 26 15:43:09 localhost vmunix: [ 3.583838] shepherd[1]: starting services...
Jun 26 15:43:09 localhost vmunix: [ 3.585444] shepherd[1]: Configuration successfully loaded from '/gnu/store/8cch4dv5ca1v0hsgyr6d8jay513x7d8g-shepherd.conf'.

… and of course the faulty service doesn’t show up at all in ‘herd
status’.

Could you confirm it’s fine for you?

Thanks,
Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71193@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71193
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch