[PATCH] gnu: avrdude: Update to 7.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 25 May 09:28 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
af2f420415cbd11505db55ac99ec4d9ed9087eba.1716622087.git.poptsov.artyom@gmail.com
* gnu/packages/flashing-tools.scm (avrdude): Update to 7.3.
[source]: Set to "https://github.com/avrdudes/avrdude/"as the project
repository moved to GitHub.
[build-system]: Use "cmake-build-system".
[arguments]: Disable tests as there are none.
[description]: Improve formatting.

Change-Id: I835563a6301d01089a9bfc2b1c3eb5050c4adb8f
---
gnu/packages/flashing-tools.scm | 22 +++++++++++++---------
1 file changed, 13 insertions(+), 9 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 2629bafbe4..457f575c92 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -149,15 +149,19 @@ (define-public 0xffff
(define-public avrdude
(package
(name "avrdude")
- (version "6.3")
+ (version "7.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://savannah/avrdude/avrdude-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/avrdudes/avrdude/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "15m1w1qad3dj7r8n5ng1qqcaiyx1gyd6hnc3p2apgjllccdp77qg"))))
- (build-system gnu-build-system)
+ (base32 "0g7c30baaxav43rlfj0cdbl40p2swamp44glz0rgf096wc0bg996"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ; no tests
(inputs
(list libelf libusb-compat libftdi))
(native-inputs
@@ -165,9 +169,9 @@ (define-public avrdude
(home-page "https://www.nongnu.org/avrdude/")
(synopsis "AVR downloader and uploader")
(description
- "AVRDUDE is a utility to download/upload/manipulate the ROM and
-EEPROM contents of AVR microcontrollers using the @acronym{ISP, in-system
-programming} technique.")
+ "@code{AVRDUDE} is a utility to download/upload/manipulate the ROM and EEPROM
+contents of AVR microcontrollers using the @acronym{ISP, in-system programming}
+technique.")
(license license:gpl2+)))
(define-public dfu-programmer

base-commit: c5e63e19ac672f9e63fc8ee98fa9a16f978ce19c
--
2.41.0
L
L
Ludovic Courtès wrote on 31 May 13:51 +0200
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 71192-done@debbugs.gnu.org)
87zfs6rygr.fsf@gnu.org
Hi Artyom,

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

Toggle quote (7 lines)
> * gnu/packages/flashing-tools.scm (avrdude): Update to 7.3.
> [source]: Set to "https://github.com/avrdudes/avrdude/" as the project
> repository moved to GitHub.
> [build-system]: Use "cmake-build-system".
> [arguments]: Disable tests as there are none.
> [description]: Improve formatting.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71192@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71192
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch