[PATCH] gnu: Add ruby-appraisal.

  • Open
  • quality assurance status badge
Details
2 participants
  • Adam Quandour
  • Nicolas Graves
Owner
unassigned
Submitted by
Adam Quandour
Severity
normal
A
A
Adam Quandour wrote on 24 May 23:38 +0200
(address . guix-patches@gnu.org)(name . Adam Quandour)(address . adam.quandour@gmail.com)
20240524213807.10537-1-adam.quandour@gmail.com
* gnu/packages/ruby.scm (ruby-appraisal): New variable.
---
gnu/packages/ruby.scm | 50 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5c1e666..53b411b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1495,6 +1495,33 @@ (define-public ruby-atoulme-saikuro
;; of the Expat license.
(license license:bsd-3)))
+(define-public ruby-appraisal
+ (package
+ (name "ruby-appraisal")
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "appraisal" version))
+ (sha256
+ (base32
+ "1knkxrjagaqf418lkgd7xvfb5rh143d19ld8vfq16y8jpqhr561n"))))
+ (build-system ruby-build-system)
+ ;; tests need Internet access.
+ (arguments '(#:tests? #f))
+ (native-inputs
+ (list ruby-activesupport
+ ruby-rspec
+ ruby-thor-0.14.6))
+ (synopsis "A Ruby library for testing your library against different versions of dependencies")
+ (description "Appraisal integrates with bundler and rake to test
+your library against different versions of dependencies in repeatable
+scenarios called \"appraisals\". Appraisal is designed to make it
+easy to check for regressions in your library without interfering
+ with day-to-day development using Bundler.")
+ (home-page "https://github.com/thoughtbot/appraisal")
+ (license license:expat)))
+
(define-public ruby-awesome-print
(package
(name "ruby-awesome-print")
@@ -3383,6 +3410,29 @@ (define-public ruby-thor
(home-page "http://whatisthor.com/")
(license license:expat)))
+(define-public ruby-thor-0.14.6
+ ;; needed for ruby-appraisal
+ (package
+ (name "ruby-thor")
+ (version "0.14.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "thor" version))
+ (sha256
+ (base32
+ "18qmgv38gfw9clhq6szyw5kcxkkk8xr7c0klp3pk3cyznzbapif7"))))
+ (build-system ruby-build-system)
+ ;; couldn't run tests
+ ;; "No Rakefile found"
+ (arguments `(#:tests? #f))
+ (native-inputs (list ruby-rspec ruby-simplecov ruby-webmock))
+ (synopsis "Ruby toolkit for building command-line interfaces")
+ (description "Thor is a toolkit for building powerful command-line
+interfaces.")
+ (home-page "http://whatisthor.com/")
+ (license license:expat)))
+
(define-public ruby-lumberjack
(package
(name "ruby-lumberjack")
--
2.41.0
N
N
Nicolas Graves wrote on 30 Jun 23:02 +0200
(name . Adam Quandour)(address . adam.quandour@gmail.com)
87ed8ejg9x.fsf@ngraves.fr
Hi,

I notice two different packages, can you split the commit please?

Also notice the lint warning on https://qa.guix.gnu.org/issue/71184:

gnu/packages/ruby.scm:1530:0: ruby-appraisal@2.5.0: line 1530 is way too long (99 characters)
gnu/packages/ruby.scm:1530:14: ruby-appraisal@2.5.0: no article allowed at the beginning of the synopsis
gnu/packages/ruby.scm:1530:14: ruby-appraisal@2.5.0: synopsis should be
less than 80 characters long

Otherwise: built reproducibly, package definitions themselves LGTM.

--
Best regards,
Nicolas Graves
A
(name . Nicolas Graves)(address . ngraves@ngraves.fr)(address . 71184@debbugs.gnu.org)
CA+jnL0NPQqQgfRy3z5zAyHt2Gej4hm8tWDu+VJ1obMhCyh_cMg@mail.gmail.com
Hi,
Yeah, I will prepare new patches.


On Mon, Jul 1, 2024 at 12:02?AM Nicolas Graves <ngraves@ngraves.fr> wrote:
Toggle quote (18 lines)
>
>
> Hi,
>
> I notice two different packages, can you split the commit please?
>
> Also notice the lint warning on https://qa.guix.gnu.org/issue/71184 :
>
> gnu/packages/ruby.scm:1530:0: ruby-appraisal@2.5.0: line 1530 is way too long (99 characters)
> gnu/packages/ruby.scm:1530:14: ruby-appraisal@2.5.0: no article allowed at the beginning of the synopsis
> gnu/packages/ruby.scm:1530:14: ruby-appraisal@2.5.0: synopsis should be
> less than 80 characters long
>
> Otherwise: built reproducibly, package definitions themselves LGTM.
>
> --
> Best regards,
> Nicolas Graves
A
A
Adam Quandour wrote on 2 Jul 15:35 +0200
[PATCH 2/2] gnu: Add ruby-appraisal.
(name . Adam Quandour)(address . adam.quandour@gmail.com)
20240702133559.6250-2-adam.quandour@gmail.com
* gnu/packages/ruby.scm (ruby-appraisal): New variable.
---
gnu/packages/ruby.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 59d5446..e7f25ac 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -14627,6 +14627,33 @@ (define-public ruby-m
(home-page "https://github.com/qrush/m")
(license license:expat)))
+(define-public ruby-appraisal
+ (package
+ (name "ruby-appraisal")
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "appraisal" version))
+ (sha256
+ (base32
+ "1knkxrjagaqf418lkgd7xvfb5rh143d19ld8vfq16y8jpqhr561n"))))
+ (build-system ruby-build-system)
+ ;; tests need Internet access.
+ (arguments '(#:tests? #f))
+ (native-inputs
+ (list ruby-activesupport
+ ruby-rspec
+ ruby-thor-0.14.6))
+ (synopsis "Library for testing your library against dependencies")
+ (description "Appraisal integrates with bundler and rake to test
+your library against different versions of dependencies in repeatable
+scenarios called \"appraisals\". Appraisal is designed to make it
+easy to check for regressions in your library without interfering
+ with day-to-day development using Bundler.")
+ (home-page "https://github.com/thoughtbot/appraisal")
+ (license license:expat)))
+
(define-public ruby-mercenary
(package
(name "ruby-mercenary")
--
2.45.2
A
A
Adam Quandour wrote on 2 Jul 15:35 +0200
[PATCH 1/2] gnu: Add ruby-thor-0.14.6.
(name . Adam Quandour)(address . adam.quandour@gmail.com)
20240702133559.6250-1-adam.quandour@gmail.com
* gnu/packages/ruby.scm (ruby-thor-0.14.6): New variable.
---
gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9547481..59d5446 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3397,6 +3397,31 @@ (define-public ruby-thor
(home-page "http://whatisthor.com/")
(license license:expat)))
+(define-public ruby-thor-0.14.6
+ ;; this package is needed for packaging ruby-appraisal
+ ;; for some reason ruby-appraisal depends on this exact
+ ;; version of this package
+ (package
+ (name "ruby-thor")
+ (version "0.14.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "thor" version))
+ (sha256
+ (base32
+ "18qmgv38gfw9clhq6szyw5kcxkkk8xr7c0klp3pk3cyznzbapif7"))))
+ (build-system ruby-build-system)
+ ;; couldn't run tests
+ ;; "No Rakefile found"
+ (arguments `(#:tests? #f))
+ (native-inputs (list ruby-rspec ruby-simplecov ruby-webmock))
+ (synopsis "Ruby toolkit for building command-line interfaces")
+ (description "Thor is a toolkit for building powerful command-line
+interfaces.")
+ (home-page "http://whatisthor.com/")
+ (license license:expat)))
+
(define-public ruby-lumberjack
(package
(name "ruby-lumberjack")
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71184@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71184
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch