[PATCH] gnu: tr7: Correct library path.

  • Open
  • quality assurance status badge
Details
One participant
  • Antero Mejr
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 24 May 02:40 +0200
(address . bug-guix@gnu.org)
87ttio6o0f.fsf@antr.me
* gnu/packages/scheme.scm (tr7)[arguments]: Update configure phase.

Change-Id: I543bb960b52a996912a2e820c83746866902bbb4
---
gnu/packages/scheme.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index a91a2d693d..b357529d7c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -882,7 +882,10 @@ (define-public tr7
(("PREFIX = /usr/local")
(string-append "PREFIX=" #$output))
(("ALL = \\$\\(LIBSTA\\) \\$\\(TR7I\\) tags")
- "ALL = $(LIBSTA) $(TR7I)"))))
+ "ALL = $(LIBSTA) $(TR7I)")
+ (("-DDEFLIBPATH='\"\\$\\(PWD\\)/tr7libs\"'")
+ (string-append "-DDEFLIBPATH='\""
+ #$output "/share/tr7/libs" "\"'")))))
(replace 'build
(lambda _
(setenv "CC" #$(cc-for-target))

base-commit: 9901416233867233192b63fde7f616751127b189
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71158@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71158
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch