[PATCH 1/1] services: home: Use pairs instead of lists.

  • Done
  • quality assurance status badge
Details
One participant
  • Andrew Tropin
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 22 May 12:02 +0200
(address . guix-patches@gnu.org)(name . Andrew Tropin)(address . andrew@trop.in)
2917af36dcf4b76410200be5e3eb877dae526a76.1716372146.git.andrew@trop.in
* gnu/services/guix.scm: Use pairs instead of lists.
* doc/guix.texi: Update accordingly.
* gnu/tests/guix.scm: Update accordingly.

Change-Id: I0b8d3fa5b214add89bdb84a11fa20d1b319435f0
---
doc/guix.texi | 4 ++--
gnu/services/guix.scm | 2 +-
gnu/tests/guix.scm | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)

Toggle diff (50 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 8073e3f6d4..8cc5edc805 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -39576,7 +39576,7 @@ Guix Services
(operating-system
(services (append (list (service guix-home-service-type
- `(("alice" ,my-home))))
+ `(("alice" . ,my-home))))
%base-services)))
@end lisp
@@ -39585,7 +39585,7 @@ Guix Services
@lisp
(simple-service 'my-extra-home home-service-type
- `(("bob" ,my-extra-home))))
+ `(("bob" . ,my-extra-home))))
@end lisp
@end defvar
diff --git a/gnu/services/guix.scm b/gnu/services/guix.scm
index 96f5ecaac0..1f0e2a310d 100644
--- a/gnu/services/guix.scm
+++ b/gnu/services/guix.scm
@@ -696,7 +696,7 @@ (define guix-data-service-type
(define (guix-home-shepherd-service config)
(map (match-lambda
- ((user he)
+ ((user . he)
(shepherd-service
(documentation "Activate Guix Home.")
(requirement '(user-processes))
diff --git a/gnu/tests/guix.scm b/gnu/tests/guix.scm
index 12ad1bf255..6071cb018e 100644
--- a/gnu/tests/guix.scm
+++ b/gnu/tests/guix.scm
@@ -271,7 +271,7 @@ (define %guix-home-service-he
(define %guix-home-service-os
(simple-operating-system
(service guix-home-service-type
- `(("alice" ,%guix-home-service-he)))))
+ `(("alice" . ,%guix-home-service-he)))))
(define (run-guix-home-service-test)
(define os
--
2.41.0
A
A
Andrew Tropin wrote on 22 May 13:12 +0200
(address . control@debbugs.gnu.org)
875xv6f6cj.fsf@trop.in
close 71112
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmZN0xwACgkQIgjSCVjB
3rCftA//e0/w99b0N27vrA6Uq4pks0xzkPpcdd6B3sLsNNvne1hH5M27sdeezM3j
ABt2Q8k0IWVap9o1+7a/0zhmy1qL0ucUHG9QH7QVDZYldIsobTAlKEYU1cyGg+dR
HnGNIiYQzIrLiVvC1Pk4cFTE9Cs2tYyV4QK3EMmL5NYQQz5XivVk/gZHpY/OMjTd
xdrZ3vFQDSjwU9FvQWqYQ0r3M4MWHhUyFefq6ruWu+gPuG6HmWiD1ywuHbMMYTJA
N6A5qwCTQNW5Ubk/gPzty5x4gt2DQSR4vAz3PeOxpiWpvHOtOTj7SQN6eTZKH9Oi
9gbQN4N9xrJLiaOi4vxjT6ocqD9KRe9mqwOq6s9xIGGDJt7/3sa8TNlMiBfZlnK6
0ZBLo2izBHpvDvYAOu3l0eyhNGlq35Fxfq5tPje+PDuzEMJo3WYRTlv4oGp/X7kq
CVRQLicgEXWUArlUWhtWMU+H0x/cncvvXWaM/1VoRZbbPdSDnU/ej4bSohK+649o
ULPoFSCqrSRx6oeP2DxGIXRGtSZhHWwUCOu6D990H9XVPys764NVPIycumxSt3xO
aGzSKy3IOxARheY87otvd8mmyu+BwQ+MszhfuObdh9ekczybnu4w1+F+R10Cayi6
vf2d56GrxBcufiZc5liQPvMfyEfnJdsUrzd5PVChuth/NB/57d4=
=oxM3
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 71112@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71112
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch