[PATCH] gnu: wine, wine64, wine-staging, wine64-staging: Enable wayland support.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 21 May 12:31 +0200
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
1e2dbd1d21b4a2dfa7f67b2291d1d0da5c83f023.1716287487.git.sughosha@disroot.org
* gnu/packages/wine.scm (wine)[inputs]: Add libxkbcommon, mesa, wayland and
wayland-protocols.

Change-Id: I43bcca457abc9c38941df21db64e867b13260004
---
gnu/packages/wine.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index a4a06c495a..35520ee03b 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -44,6 +44,7 @@ (define-module (gnu packages wine)
#:use-module (gnu packages cups)
#:use-module (gnu packages databases)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages flex)
#:use-module (gnu packages image)
#:use-module (gnu packages gettext)
@@ -69,6 +70,7 @@ (define-module (gnu packages wine)
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages vulkan)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (ice-9 match)
@@ -191,11 +193,13 @@ (define-public wine
libxi
libxext
libxcursor
+ libxkbcommon
libxrender
libxrandr
libxinerama
libxxf86vm
libxcomposite
+ mesa
mit-krb5
openal
pulseaudio
@@ -203,7 +207,9 @@ (define-public wine
unixodbc
v4l-utils
vkd3d
- vulkan-loader))
+ vulkan-loader
+ wayland
+ wayland-protocols))
(arguments
(substitute-keyword-arguments (package-arguments wine-minimal)
((#:phases phases)

base-commit: e9b25a6c6c626a560d28a1f732e6e5d362d584a4
--
2.41.0
M
M
Maxim Cournoyer wrote on 24 Jun 05:05 +0200
control message for bug #71091
(address . control@debbugs.gnu.org)
875xtz59bs.fsf@gmail.com
close 71091
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71091@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71091
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch