[PATCH] gnu: Add emacs-context-transient.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 21 May 08:51 +0200
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20240521065113.31627-1-ngraves@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-context-transient): New variable.

Change-Id: I53c15839bf4979464e8dd6fe2217b9fdbdee56c5
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4eadf5e2273..260e9d682ba 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -39376,6 +39376,29 @@ (define-public emacs-consult-lsp
by leveraging @code{emacs-consult} APIs.")
(license license:expat)))
+(define-public emacs-context-transient
+ (let ((commit "16b8e16645ebcdc44d2777ba16ac85e1d3ee468b")
+ (revision "0"))
+ (package
+ (name "emacs-context-transient")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/licht1stein/context-transient.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "147yv3ih9il6a4k2cw1kcqgdpls83jf7aspjf8km650ry0apycc6"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/licht1stein/context-transient.el")
+ (synopsis "Context specific transients")
+ (description "This package makes it easy to define and call
+context-specific @code{emacs-transient} menus for current project, git repo,
+buffer or any other condition.")
+ (license license:gpl3+))))
+
(define-public emacs-purs-mode
;; XXX: Upstream set no tag nor any Version keyword. Using 0 as the base
;; version.
--
2.41.0
N
N
Nicolas Graves wrote on 15 Jun 17:24 +0200
control message for bug #71090
(address . control@debbugs.gnu.org)
878qz644by.fsf@ngraves.fr
close 71090
quit

The package has been added since.

--
Best regards,
Nicolas Graves
N
N
Nicolas Goaziou wrote on 19 Jun 09:58 +0200
Re: [bug#71090] [PATCH] gnu: Add emacs-context-transient.
(name . Nicolas Graves via Guix-patches via)(address . guix-patches@gnu.org)
87plsd5ppg.fsf@nicolasgoaziou.fr
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-context-transient): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71090@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71090
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch