[PATCH] import/elpa: Add proper file-name to origin.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Graves
  • Z572
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 21 May 08:46 +0200
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20240521064654.30487-1-ngraves@ngraves.fr
This avoids the lint "the source file name should contain the package
name" with generated packages.

Change-Id: I61c81203d9f3cdd035e2b64a4c7a8d86d1f3dd50
---
guix/import/elpa.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/guix/import/elpa.scm b/guix/import/elpa.scm
index d1855b36986..46b6dc98a20 100644
--- a/guix/import/elpa.scm
+++ b/guix/import/elpa.scm
@@ -250,6 +250,7 @@ (define ref
(uri (git-reference
(url ,url)
(commit ,commit)))
+ (file-name (git-file-name name version))
(sha256
(base32
,(bytevector->nix-base32-string
--
2.41.0
Z
(name . Nicolas Graves via Guix-patches via)(address . guix-patches@gnu.org)
87a5kinv2t.fsf@iscas.ac.cn
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (21 lines)
> This avoids the lint "the source file name should contain the package
> name" with generated packages.
>
> Change-Id: I61c81203d9f3cdd035e2b64a4c7a8d86d1f3dd50
> ---
> guix/import/elpa.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/guix/import/elpa.scm b/guix/import/elpa.scm
> index d1855b36986..46b6dc98a20 100644
> --- a/guix/import/elpa.scm
> +++ b/guix/import/elpa.scm
> @@ -250,6 +250,7 @@ (define ref
> (uri (git-reference
> (url ,url)
> (commit ,commit)))
> + (file-name (git-file-name name version))
> (sha256
> (base32
> ,(bytevector->nix-base32-string

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmZNo+oACgkQO1qpk+Gi
3/CzMw//YBZBJzy5SfHmsiqeeyIcEFLt+tR25EDYl2HlL00A8X5jixmV2VLUL5O1
4qvQ70PEj2v9VVzdIeov7secjn1XzgPy0ksvVI8phM9YK11WfqwP8Kt7x0913GAZ
8nHUN5xrd9ywBm90dpa5E9fLTnjagfqIkaA/P0Fh8/Y001aiJ8WbbQGIMJCx5HVL
RLOjVtv8lojCqkaiWH0YbX2rcQ3lcAWRjyGiTcaHxNgEoKal/b2uJdhKXCZFg9t8
qpu3mvWwpURU6RP0TxT396FBdjHOYaeNj1kZEXcLZGl0DzUDxbpCcqAHlJ+A2mRB
Bf+r08tEZvUUx2o0UVUTSAGPkUWMsxkn1dDDw2LogmY8DWl30usJS0YG4pjR7tWk
ZO1AXwIIV/K/yF75G+sTUNPcvO1dA7d9K0H2MDcFBR8lxU8rsEVOr/+fHVJ2e5+E
tVF+R+Ce/t08UsjH0+T6Q4ZQOR2bXnE+idfovVR/uxxkpO0pyJJsFDd2mjtbTuYr
sTZI8jLKJtzUCAuhw8RXNw5LIABDiF/tNOLMYnqrG6N3QNJZJf0kjY0vaS5J1uE7
Dyy9G3FPUgBpf0W1evxDRf2lZOfi1RQm+FipfpFryHRHLARF92KTwzjF42cFFBqu
aRCdcfyHwF1uKygRD3iWHcqe3lzi3fTeYgorMiejmTrvmqGUZqA=
=GT5r
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 71089@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71089
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch