[PATCH] gnu: blktrace: Update to 1.3.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 20 May 21:30 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
8fba2ff868c2376fd2ee7693573594e0157363c6.1716233408.git.poptsov.artyom@gmail.com
* gnu/packages/linux.scm (blktrace): Update to 1.3.0.
[arguments]: Use gexps.

Change-Id: I4e107c8d1f99d5eb44d7f0fd67925cefac36eba9
---
gnu/packages/linux.scm | 37 ++++++++++++++++++-------------------
1 file changed, 18 insertions(+), 19 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a9b78a7986..2a85e4b7c8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -63,7 +63,7 @@
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Ryan Sundberg <ryan@arctype.co>
-;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022, 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
@@ -5921,12 +5921,12 @@ (define-public libaio
(license license:lgpl2.1+)))
(define-public blktrace
- ;; Take a newer commit to get the fix for CVE-2018-10689.
- (let ((commit "db4f6340e04716285ea56fe26d76381c3adabe58")
+ ;; Take a newer commit to get the latest patches.
+ (let ((commit "b9ea6e507e8849f01d06aa48c0c59c5cee4820be")
(revision "1"))
(package
(name "blktrace")
- (version (git-version "1.2.0" revision commit))
+ (version (git-version "1.3.0" revision commit))
(home-page
"https://git.kernel.org/pub/scm/linux/kernel/git/axboe/blktrace.git")
(source (origin
@@ -5935,24 +5935,23 @@ (define-public blktrace
(url home-page)
(commit commit)))
(sha256
- (base32 "0ah7xn4qnx09k6bm39p69av7d0c8cl6863drv6a1nf914sq1kpgp"))
+ (base32 "0a4830mlqckbhchar1xcn2w4f24bzb75bigdig5wpm2axl0zc8cq"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list ,(string-append "CC=" (cc-for-target))
- (string-append "prefix=" %output))
- #:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-after 'unpack 'fix-gnuplot-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((gnuplot (assoc-ref inputs "gnuplot")))
- (substitute* "btt/bno_plot.py"
- (("gnuplot %s")
- (string-append gnuplot "/bin/gnuplot %s")))
- #t))))))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output))
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-after 'unpack 'fix-gnuplot-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gnuplot (assoc-ref inputs "gnuplot")))
+ (substitute* "btt/bno_plot.py"
+ (("gnuplot %s")
+ (string-append gnuplot "/bin/gnuplot %s")))))))))
(inputs
`(("libaio" ,libaio)
("gnuplot" ,gnuplot)

base-commit: 7881d6085146fefda17ed9eefa133b5b5c97af87
--
2.41.0
L
L
Ludovic Courtès wrote on 12 Jun 00:08 +0200
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
8734pjku8v.fsf@gnu.org
Hi,

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

Toggle quote (5 lines)
> * gnu/packages/linux.scm (blktrace): Update to 1.3.0.
> [arguments]: Use gexps.
>
> Change-Id: I4e107c8d1f99d5eb44d7f0fd67925cefac36eba9

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71082@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71082
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch