[PATCH] home: services: Avoid garbling mouse cursor when used in Trisquel.

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Simon Josefsson
Owner
unassigned
Submitted by
Simon Josefsson
Severity
normal
S
S
Simon Josefsson wrote on 20 May 12:28 +0200
(address . guix-patches@gnu.org)
87o790vktk.fsf@kaka.sjd.se
Hi! If you install Trisquel 11 and then install guix with 'sudo apt
install guix' and then do 'guix home reconfigure foo' it will create a
.profile file that sets XCURSOR_PATH which disables system paths. The
end result is that your mouse cursor is garbled on next login.

This thread seems related, but I think it has to be fixed in guix home

/Simon
From 46c63f80ae061b830b8e82903c016461d0bb0f1b Mon Sep 17 00:00:00 2001
From: Simon Josefsson <simon@josefsson.org>
Date: Mon, 20 May 2024 12:23:39 +0200
Subject: [PATCH] home: services: Avoid garbling mouse cursor when used in
Trisquel.

* gnu/home/services.scm (environment-variables->setup-environment-script): Add
common system directories when setting XCURSOR_PATH.
---
gnu/home/services.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/home/services.scm b/gnu/home/services.scm
index b69cd91203..b7413408f0 100644
--- a/gnu/home/services.scm
+++ b/gnu/home/services.scm
@@ -298,7 +298,7 @@ (define (warn-about-duplicate-definitions)
esac
case $XCURSOR_PATH in
*$HOME_ENVIRONMENT/profile/share/icons*) ;;
- *) export XCURSOR_PATH=$HOME_ENVIRONMENT/profile/share/icons:$XCURSOR_PATH ;;
+ *) export XCURSOR_PATH=$HOME_ENVIRONMENT/profile/share/icons:${XCURSOR_PATH:-/usr/local/share/icons:/usr/share/icons} ;;
esac
" port)
--
2.41.0
-----BEGIN PGP SIGNATURE-----

iIoEARYIADIWIQSjzJyHC50xCrrUzy9RcisI/kdFogUCZksl1xQcc2ltb25Aam9z
ZWZzc29uLm9yZwAKCRBRcisI/kdFord/AQCQ/Y/tc9prVRNJaQmPIiVx6j4j+REi
sOi/dveZBhbEEgEA0z3b/m12Dl22df0L+M9SCnI1xNy2vMTx79LOrz8IzA4=
=y755
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 24 Jun 05:08 +0200
(name . Simon Josefsson)(address . simon@josefsson.org)(address . 71077@debbugs.gnu.org)
871q4n596u.fsf@gmail.com
Simon Josefsson <simon@josefsson.org> writes:

Toggle quote (19 lines)
> Hi! If you install Trisquel 11 and then install guix with 'sudo apt
> install guix' and then do 'guix home reconfigure foo' it will create a
> .profile file that sets XCURSOR_PATH which disables system paths. The
> end result is that your mouse cursor is garbled on next login.
>
> This thread seems related, but I think it has to be fixed in guix home
> too: https://lists.gnu.org/r/guix-patches/2022-07/msg00096.html
>
> /Simon
>
> From 46c63f80ae061b830b8e82903c016461d0bb0f1b Mon Sep 17 00:00:00 2001
> From: Simon Josefsson <simon@josefsson.org>
> Date: Mon, 20 May 2024 12:23:39 +0200
> Subject: [PATCH] home: services: Avoid garbling mouse cursor when used in
> Trisquel.
>
> * gnu/home/services.scm (environment-variables->setup-environment-script): Add
> common system directories when setting XCURSOR_PATH.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71077@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71077
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch