[PATCH rust-team 2/3] gnu: tree-sitter: Update to 0.22.6.

  • Done
  • quality assurance status badge
Details
One participant
  • Solomon Victorino
Owner
unassigned
Submitted by
Solomon Victorino
Severity
normal
S
S
Solomon Victorino wrote on 18 May 21:51 +0200
(address . guix-patches@gnu.org)(name . Solomon Victorino)(address . git@solomonvictorino.com)
20240518195148.335969-3-git@solomonvictorino.com
* gnu/packages/tree-sitter.scm (tree-sitter): Update to 0.22.6.
* gnu/packages/tree-sitter.scm (tree-sitter-cli)[cargo-inputs]: Add rust-ctrlc-3.
---
gnu/packages/tree-sitter.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 7515461993..f8df49757b 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -99,16 +99,16 @@ (define-public python-tree-sitter
(define-public tree-sitter
(package
(name "tree-sitter")
- (version "0.20.10") ;untagged
+ (version "0.22.6")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tree-sitter/tree-sitter")
- (commit "0e4ff0bb27edf37b76fc7d35aa768b02cf4392ad")))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1bai4gdhf8w5p1i9np2kl2ms0jq6rgq98qpiipipzayb9jjjlxcy"))
+ "0nx3kmvbhjf6nq1pv6x85z67dkk5kagh90w1cwxh0pvg7608l44c"))
(modules '((guix build utils)))
(snippet #~(begin
;; Remove bundled ICU parts
@@ -194,6 +194,7 @@ (define-public tree-sitter-cli
("rust-anyhow" ,rust-anyhow-1)
("rust-atty" ,rust-atty-0.2)
("rust-clap" ,rust-clap-2)
+ ("rust-ctrlc" ,rust-ctrlc-3)
("rust-difference" ,rust-difference-2)
("rust-dirs" ,rust-dirs-3)
("rust-html-escape" ,rust-html-escape-0.2)
--
2.45.1
S
S
Solomon wrote on 21 May 18:29 +0200
(address . 71062-close@debbugs.gnu.org)
14d819a0-ad1c-4fc0-b6cc-86712e4a4641@solomonvictorino.com
My bad, this is not a complete patch for tree-sitter;
the CLI and grammars aren't building.

Closing as a duplicate of #70146, which was much further along.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71062@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71062
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch