[PATCH 8/9] Added rust-winsafe

  • Done
  • quality assurance status badge
Details
One participant
  • Julian Flake
Owner
unassigned
Submitted by
Julian Flake
Severity
normal
J
J
Julian Flake wrote on 19 May 13:54 +0200
(address . guix-patches@gnu.org)(name . Julian Flake)(address . flake@uni-koblenz.de)
f9904e76b69ce46c45485d8d6b6cb5f2bb7cce51.1716119149.git.flake@uni-koblenz.de
Change-Id: Iba8c0af1ffec1d29d2442b09518a8a35e86a14e0
---
gnu/packages/crates-io.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3a07c11996..8efbaa67a4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -80027,6 +80027,23 @@ (define-public rust-zvariant-utils-1
(description "Various utilities used internally by the zvariant crate.")
(license license:expat)))
+(define-public rust-winsafe-0.0.19
+ (package
+ (name "rust-winsafe")
+ (version "0.0.19")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "winsafe" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0169xy9mjma8dys4m8v4x0xhw2gkbhv2v1wsbvcjl9bhnxxd2dfi"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/rodrigocfd/winsafe")
+ (synopsis "Windows API and GUI in safe, idiomatic Rust.")
+ (description "Windows API and GUI in safe, idiomatic Rust containing low-level Win32 API constants, functions, structs and high-level structs to build native Win32 GUI application.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.41.0
J
J
Julian Flake wrote on 19 May 14:39 +0200
close false issues
878r06ht68.fsf@uni-koblenz.de
should've been part of the series 71052
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71055@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71055
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch