[PATCH 6/9] Update rust-strum(-macros)

  • Done
  • quality assurance status badge
Details
One participant
  • Julian Flake
Owner
unassigned
Submitted by
Julian Flake
Severity
normal
J
J
Julian Flake wrote on 19 May 13:54 +0200
(address . guix-patches@gnu.org)(name . Julian Flake)(address . flake@uni-koblenz.de)
a9fd44b04fe4e14603eeac69c7ac03e3edc15292.1716119149.git.flake@uni-koblenz.de
Change-Id: I9db32d170db7c59d6fdbc3aa46aea310297c7151
---
gnu/packages/crates-io.scm | 40 +++++++++++++++++++++++++++++++-------
1 file changed, 33 insertions(+), 7 deletions(-)

Toggle diff (95 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9e729a7e5b..50684530a2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65606,23 +65606,23 @@ (define-public rust-structopt-derive-0.2
"Parse command line argument by defining a struct, derive crate.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-strum-0.25
+(define-public rust-strum-0.26
(package
(name "rust-strum")
- (version "0.25.0")
+ (version "0.26.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "strum" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "09g1q55ms8vax1z0mxlbva3vm8n2r1179kfvbccnkjcidzm58399"))))
+ (base32 "03kfgifxi4gh8bdq83kzzxp427ilg93k56ckfg3ikk56r0x42z0i"))))
(build-system cargo-build-system)
(arguments
`(#:tests? #f ; unresolved import `strum::EnumIter`
#:cargo-inputs
(("rust-phf" ,rust-phf-0.10)
- ("rust-strum-macros" ,rust-strum-macros-0.25))
+ ("rust-strum-macros" ,rust-strum-macros-0.26))
#:cargo-development-inputs
(("rust-strum-macros" ,rust-strum-macros-0.25))))
(home-page "https://github.com/Peternator7/strum")
@@ -65632,6 +65632,19 @@ (define-public rust-strum-0.25
easier in Rust.")
(license license:expat)))
+(define-public rust-strum-0.25
+ (package
+ (inherit rust-strum-0.26)
+ (name "rust-strum")
+ (version "0.25.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "strum" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "09g1q55ms8vax1z0mxlbva3vm8n2r1179kfvbccnkjcidzm58399"))))))
+
(define-public rust-strum-0.24
(package
(inherit rust-strum-0.25)
@@ -65720,17 +65733,17 @@ (define-public rust-strum-0.18
`(#:cargo-inputs
(("rust-strum-macros" ,rust-strum-macros-0.18))))))
-(define-public rust-strum-macros-0.25
+(define-public rust-strum-macros-0.26
(package
(name "rust-strum-macros")
- (version "0.25.3")
+ (version "0.26.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "strum_macros" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "184y62g474zqb2f7n16x3ghvlyjbh50viw32p9w9l5lwmjlizp13"))))
+ (base32 "0in9jvbb3g16x8fj7lf91vwzj98319hj3z8lpaaa9h42ybd5kky6"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-heck" ,rust-heck-0.4)
@@ -65745,6 +65758,19 @@ (define-public rust-strum-macros-0.25
"This crate provides helpful macros for working with enums and strings.")
(license license:expat)))
+(define-public rust-strum-macros-0.25
+ (package
+ (inherit rust-strum-macros-0.26)
+ (name "rust-strum-macros")
+ (version "0.25.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "strum_macros" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "184y62g474zqb2f7n16x3ghvlyjbh50viw32p9w9l5lwmjlizp13"))))))
+
(define-public rust-strum-macros-0.24
(package
(inherit rust-strum-macros-0.25)
--
2.41.0
J
J
Julian Flake wrote on 19 May 14:39 +0200
close false issues
878r06ht68.fsf@uni-koblenz.de
should've been part of the series 71052
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71054@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71054
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch