[PATCH 0/2] Update opensc

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Timotej Lazar
Owner
unassigned
Submitted by
Timotej Lazar
Severity
normal
T
T
Timotej Lazar wrote on 18 May 13:34 +0200
(address . guix-patches@gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
cover.1716031956.git.timotej.lazar@araneo.si
This updates opensc to latest version and switches it to new package
style. All dependents still build (at least) on aarch64 except hw-probe,
which is not supported on that platform. Thanks!

Timotej Lazar (2):
gnu: opensc: Update to 0.25.1.
gnu: opensc: Switch to new package style.

gnu/packages/security-token.scm | 31 +++++++++++++++----------------
1 file changed, 15 insertions(+), 16 deletions(-)


base-commit: e9b25a6c6c626a560d28a1f732e6e5d362d584a4
--
2.41.0
T
T
Timotej Lazar wrote on 18 May 13:39 +0200
[PATCH 1/2] gnu: opensc: Update to 0.25.1.
(address . 71035@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
93137932e552dfcc4a8ebba0da535c8ba3df2e92.1716031956.git.timotej.lazar@araneo.si
* gnu/packages/security-token.scm (opensc): Update to 0.25.1.

Change-Id: I16dbf047671115274a25c3b1fba0285952f9f41d
---
gnu/packages/security-token.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 35a8d4e216..a376db3bc0 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -355,7 +355,7 @@ (define-public ykclient
(define-public opensc
(package
(name "opensc")
- (version "0.25.0")
+ (version "0.25.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -363,7 +363,7 @@ (define-public opensc
version "/opensc-" version ".tar.gz"))
(sha256
(base32
- "0bv2sq3k8bl712yi1gi7f8km8g2x09is8ynnr5x3g2jh59pbdmz6"))))
+ "0yxk97aj29pybvya6r9ix9xh00hdzcfrc2lcns4vb3kwpplamjr3"))))
(build-system gnu-build-system)
(arguments
`(#:phases
--
2.41.0
T
T
Timotej Lazar wrote on 18 May 13:39 +0200
[PATCH 2/2] gnu: opensc: Switch to new package style.
(address . 71035@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
b5ddc960fd678ce1d5cfcd10e503333ff5d43f5a.1716031956.git.timotej.lazar@araneo.si
* gnu/packages/security-token.scm (opensc)[arguments]: Use g-exps.

Change-Id: I3e59323deb804ba98669d51771ccfa05a92723e3
---
gnu/packages/security-token.scm | 27 +++++++++++++--------------
1 file changed, 13 insertions(+), 14 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index a376db3bc0..00426d6d99 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -366,20 +366,19 @@ (define-public opensc
"0yxk97aj29pybvya6r9ix9xh00hdzcfrc2lcns4vb3kwpplamjr3"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; By setting an absolute path here, we arrange for OpenSC to
- ;; successfully dlopen libpcsclite.so.1 by default. The user can
- ;; still override this if they want to, by specifying a custom OpenSC
- ;; configuration file at runtime.
- (add-after 'unpack 'set-default-libpcsclite.so.1-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libpcsclite (search-input-file inputs
- "/lib/libpcsclite.so.1")))
- (substitute* "configure"
- (("DEFAULT_PCSC_PROVIDER=\"libpcsclite\\.so\\.1\"")
- (string-append
- "DEFAULT_PCSC_PROVIDER=\"" libpcsclite "\"")))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; By setting an absolute path here, we arrange for OpenSC to
+ ;; successfully dlopen libpcsclite.so.1 by default. The user can
+ ;; still override this if they want to, by specifying a custom OpenSC
+ ;; configuration file at runtime.
+ (add-after 'unpack 'set-default-libpcsclite.so.1-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libpcsclite (search-input-file inputs "/lib/libpcsclite.so.1")))
+ (substitute* "configure"
+ (("DEFAULT_PCSC_PROVIDER=\"libpcsclite\\.so\\.1\"")
+ (string-append "DEFAULT_PCSC_PROVIDER=\"" libpcsclite "\"")))))))))
(inputs
(list readline openssl-1.1 pcsc-lite ccid))
(native-inputs
--
2.41.0
M
M
Maxim Cournoyer wrote on 24 Jun 05:12 +0200
Re: [bug#71035] [PATCH 0/2] Update opensc
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)(address . 71035-done@debbugs.gnu.org)
87h6dj3ufa.fsf@gmail.com
Hello,

Timotej Lazar <timotej.lazar@araneo.si> writes:

Toggle quote (8 lines)
> This updates opensc to latest version and switches it to new package
> style. All dependents still build (at least) on aarch64 except hw-probe,
> which is not supported on that platform. Thanks!
>
> Timotej Lazar (2):
> gnu: opensc: Update to 0.25.1.
> gnu: opensc: Switch to new package style.

Applied, thank you!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71035@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71035
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch