* gnu/packages/golang.scm (go-github-com-gdamore-tcell): Update to 1.4.0.
* gnu/packages/golang.scm (go-github-com-gdamore-tcell-v2): Update to 2.7.4.
* gnu/packages/golang.scm (go-github-com-rivo-uniseg): Update to 0.4.7.
* gnu/packages/golang.scm: Update go versions.
Change-Id: Ib9532428ad4d5a4d6a480a4651ee7ffc70d0b059
---
gnu/packages/golang.scm | 52 +++++++++++++++++++++++++++--------------
1 file changed, 34 insertions(+), 18 deletions(-)
Toggle diff (159 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e39da8f9ed..3a907ef6ab 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5580,29 +5580,30 @@ (define-public go-github-com-cespare-mph
(license license:expat)))
(define-public go-github-com-gdamore-tcell
- (let ((commit "aaadc574a6ed8dc3abe56036ca130dcee1ee6b6e")
- (version "1.1.2")
- (revision "1"))
(package
(name "go-github-com-gdamore-tcell")
- (version (git-version version revision commit))
+ (version "1.4.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/gdamore/tcell")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0il2nnxp2cqiy73m49215dnf9in3vd25ji8qxbmq87c5qy7i1q9d"))))
+ "178h7kj4zb8lcw84nbqanapnxrgvhq4111xw4fj6m56y46anlzwg"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/gdamore/tcell"))
+ (list
+ #:go go-1.18
+ #:import-path "github.com/gdamore/tcell"))
(inputs
(list go-github-com-mattn-go-runewidth
+ go-github-com-rivo-uniseg
go-github-com-lucasb-eyer-go-colorful
go-golang-org-x-text
+ go-golang-org-x-sys
go-github-com-gdamore-encoding))
(home-page "https://github.com/gdamore/tcell")
(synopsis "Provide a cell-based view for text terminals")
@@ -5610,13 +5611,13 @@ (define-public go-github-com-gdamore-tcell
terminfo capability strings to avoid hard-coding escape strings for
formatting. It also favors portability, and includes support for all POSIX
systems.")
- (license license:asl2.0))))
+ (license license:asl2.0)))
(define-public go-github-com-gdamore-tcell-v2
(package
(inherit go-github-com-gdamore-tcell)
(name "go-github-com-gdamore-tcell")
- (version "2.6.0")
+ (version "2.7.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5625,9 +5626,10 @@ (define-public go-github-com-gdamore-tcell-v2
(file-name (git-file-name name version))
(sha256
(base32
- "0126hi8glnfqdx4l9zlh6dhd5f5c8bws7arv9pp4n2kqcnhdc6g2"))))
+ "05b22sgyf8lnwjddxlfvlj7i8b67gnidhbnz86vvx8fddggpa5nd"))))
(arguments
(list #:import-path "github.com/gdamore/tcell/v2"
+ #:go go-1.18
#:phases
#~(modify-phases %standard-phases
(add-before 'reset-gzip-timestamps 'make-files-writable
@@ -5655,7 +5657,9 @@ (define-public go-git-sr-ht-rockorager-tcell-term
"177ladvpiiw7sb0hsjjv9p2yv5wpqpw6nqardkm8mqqlj0swa9xx"))))
(build-system go-build-system)
(arguments
- (list #:import-path "git.sr.ht/~rockorager/tcell-term"))
+ (list
+ #:go go-1.18
+ #:import-path "git.sr.ht/~rockorager/tcell-term"))
(propagated-inputs
(list go-golang-org-x-sys
go-golang-org-x-term
@@ -5687,7 +5691,9 @@ (define-public go-github-com-rivo-tview
"0gf1m3ndbc3kgxpv0ryq9a1ahijg6m896sc9k7dvwfjd8vy0q0yd"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/rivo/tview"))
+ (list
+ #:go go-1.18
+ #:import-path "github.com/rivo/tview"))
(propagated-inputs (list go-golang-org-x-term
go-golang-org-x-sys
go-github-com-rivo-uniseg
@@ -7174,7 +7180,9 @@ (define-public go-github-com-olekukonko-tablewriter
"02r0n2b9yh3x8xyf48k17dxlwj234hlgjycylbjxi6qg08hfmz2x"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/olekukonko/tablewriter"))
+ (list
+ #:go go-1.18
+ #:import-path "github.com/olekukonko/tablewriter"))
(propagated-inputs
(list go-github-com-mattn-go-runewidth))
(home-page "https://github.com/olekukonko/tablewriter/")
@@ -8804,7 +8812,7 @@ (define-public go-github-com-vmihailenco-tagparser
(define-public go-github-com-rivo-uniseg
(package
(name "go-github-com-rivo-uniseg")
- (version "0.2.0")
+ (version "0.4.7")
(source
(origin
(method git-fetch)
@@ -8813,9 +8821,12 @@ (define-public go-github-com-rivo-uniseg
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0j7h22vfmjj562vr8gpsyrkrwp1pq9ayh5fylv24skxb467g9f0q"))))
+ (base32 "0nlcqyvq4vhq3hqhk84h6fp0jbqkjj88kcpcl853yr7sh4sisdxc"))))
(build-system go-build-system)
- (arguments '(#:import-path "github.com/rivo/uniseg"))
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/rivo/uniseg"))
(home-page "https://github.com/rivo/uniseg")
(synopsis "Unicode Text Segmentation for Go")
(description
@@ -9471,6 +9482,7 @@ (define-public go-github-com-jaytaylor-html2text
(build-system go-build-system)
(arguments
(list #:import-path "github.com/jaytaylor/html2text"
+ #:go go-1.18
;; Tests are broken: <https://github.com/jaytaylor/html2text/issues/53>
#:tests? #f))
(propagated-inputs (list go-golang-org-x-net
@@ -9498,7 +9510,9 @@ (define-public go-github-com-jhillyerd-enmime
"124dqm598phbmalyx2gmxk201z9kq4ckvvdq8rc0akjlp24nxqbb"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/jhillyerd/enmime"))
+ (list
+ #:go go-1.18
+ #:import-path "github.com/jhillyerd/enmime"))
(propagated-inputs (list go-golang-org-x-text
go-golang-org-x-net
go-github-com-stretchr-testify
@@ -9533,7 +9547,9 @@ (define-public go-github-com-gatherstars-com-jwz
"1zxg2vmka80m1vnlb1v1gdlrwnkpakcmwi1hxpl8jjjiyd4z2j2i"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/gatherstars-com/jwz"))
+ (list
+ #:go go-1.18
+ #:import-path "github.com/gatherstars-com/jwz"))
(propagated-inputs (list go-github-com-rivo-tview
go-github-com-jhillyerd-enmime
go-github-com-gdamore-tcell-v2))
--
2.41.0