[PATCH] gnu: ascii: Update to 3.20.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 17 May 21:53 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
3b337c0f94f0ab0fef3247a1a81109bc6e963aeb.1715975580.git.poptsov.artyom@gmail.com
* gnu/packages/shellutils.scm (ascii): Update to 3.20.
[arguments]: Use gexps.

Change-Id: I8141a5596bf404bc93d53578e45bc78ee1b60f04
---
gnu/packages/shellutils.scm | 34 ++++++++++++++++++----------------
1 file changed, 18 insertions(+), 16 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 41da49a966..77a8ff7476 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -70,29 +71,30 @@ (define-module (gnu packages shellutils)
(define-public ascii
(package
(name "ascii")
- (version "3.18")
+ (version "3.20")
(source (origin
(method url-fetch)
(uri (string-append "http://www.catb.org/~esr/ascii/"
"ascii-" version ".tar.gz"))
(sha256
(base32
- "0b87vy06s8s3a8q70pqavsbk4m4ff034sdml2xxa6qfsykaj513j"))))
+ "0x0nq6ydm06rikayskmqcri73ysf4mk67ki4l01sh6flc3m5fvly"))))
(build-system gnu-build-system)
- (arguments `(#:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'install 'create-directories
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (man1 (string-append out "/share/man/man1")))
- (mkdir-p bin)
- (mkdir-p man1)))))
- #:tests? #f))
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'create-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man1 (string-append out "/share/man/man1")))
+ (mkdir-p bin)
+ (mkdir-p man1)))))
+ #:tests? #f))
(home-page "http://www.catb.org/~esr/ascii/")
(synopsis "ASCII name and synonym chart")
(description

base-commit: e9b25a6c6c626a560d28a1f732e6e5d362d584a4
--
2.41.0
?
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 71015-done@debbugs.gnu.org)
87jzjfwwem.fsf@envs.net
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:

Toggle quote (3 lines)
> * gnu/packages/shellutils.scm (ascii): Update to 3.20.
> [arguments]: Use gexps.

Pushed to master as commit 8c3bfb0a0b, thank you.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71015@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71015
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch