[PATCH 0/5] gnu: Add go-github-com-pion-ice.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 17 May 21:24 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1715973559.git.poptsov.artyom@gmail.com
This patch set adds "go-github-com-pion-ice" (v2, v3) that is a dependency of
Kubo (IPFS.)

Artyom V. Poptsov (5):
gnu: Add go-github-com-pion-turn-v3.
gnu: Add go-github-com-pion-turn-v2.
gnu: Add go-github-com-pion-ice-v3.
gnu: go-github-com-pion-mdns-v0: New variable.
gnu: Add go-github-com-pion-ice-v2.

gnu/packages/golang-web.scm | 18 +++++
gnu/packages/golang-xyz.scm | 135 ++++++++++++++++++++++++++++++++++++
2 files changed, 153 insertions(+)


base-commit: e4ee595999a3b0656f416d190b28ec6f1ad8a74d
--
2.41.0
A
A
Artyom V. Poptsov wrote on 17 May 21:27 +0200
[PATCH 1/5] gnu: Add go-github-com-pion-turn-v3.
(address . 71014@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
69db653386fe624f42720d146ddec53438fbbfee.1715973559.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-turn-v3): New variable.

Change-Id: I6127d3ba42268441e7b052a7a7693341ef7b7df9
---
gnu/packages/golang-xyz.scm | 45 +++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e69a65c3da..862e611e75 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3006,6 +3006,51 @@ (define-public go-github-com-pion-logging
Pion}.")
(license license:expat)))
+(define-public go-github-com-pion-turn-v3
+ (package
+ (name "go-github-com-pion-turn")
+ (version "3.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/turn/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l78m9ym0sv1zfalbv95lwblmr789fc53d957ph5mdznhjx89lyx"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:tests? #f ;Tests require network access.
+ #:unpack-path "github.com/pion/turn/v3"
+ #:import-path "github.com/pion/turn/v3"))
+ (native-inputs (list go-github-com-stretchr-testify-next))
+ (propagated-inputs (list go-github-com-pion-logging
+ go-github-com-pion-randutil
+ go-github-com-pion-stun-v2
+ go-github-com-pion-transport-v3))
+ (home-page "https://github.com/pion/turn/")
+ (synopsis "Pion TURN, an API for building TURN clients and servers")
+ (description
+ "@url{https://github.com/pion, Pion} TURN is a Go toolkit for building
+@url{https://datatracker.ietf.org/doc/html/rfc8656, TURN} servers and clients.
+
+@code{pion/turn} is an API for building STUN/TURN clients and servers, not a binary
+you deploy then configure. It may require copying the examples and making minor
+modifications to fit your need, no knowledge of Go is required however. You may be
+able to download the pre-made binaries of our examples if you wish to get started
+quickly.
+
+The advantage of this is that you don't need to deal with complicated configuration
+files, or custom APIs to modify the state of Pion TURN. After you instantiate an
+instance of a Pion TURN server or client you interact with it like any library. The
+quickest way to get started is to look at the
+@url{https://github.com/pion/turn/blob/master/examples, examples} or
+@url{https://godoc.org/github.com/pion/turn, GoDoc}.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 17 May 21:27 +0200
[PATCH 2/5] gnu: Add go-github-com-pion-turn-v2.
(address . 71014@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
c242ee0d04fe4d6a6be3cacbf64ac172b74a0ed9.1715973559.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-turn-v2): New variable.

Change-Id: I21cb07bb04d21fda94bcbf784456549f4a4816cd
---
gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 862e611e75..df4b7db15b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3051,6 +3051,31 @@ (define-public go-github-com-pion-turn-v3
@url{https://godoc.org/github.com/pion/turn, GoDoc}.")
(license license:expat)))
+(define-public go-github-com-pion-turn-v2
+ (package
+ (inherit go-github-com-pion-turn-v3)
+ (name "go-github-com-pion-turn")
+ (version "2.1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/turn/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0iw7nvqsxpqy90k5a8mq3dyask272391m59cbiy30aak1y2wwaac"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments
+ go-github-com-pion-turn-v3)
+ ((#:unpack-path flags ''())
+ "github.com/pion/turn/v2")
+ ((#:import-path flags ''())
+ "github.com/pion/turn/v2")))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs go-github-com-pion-turn-v3)
+ (replace "go-github-com-pion-stun-v2" go-github-com-pion-stun)))))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 17 May 21:27 +0200
[PATCH 3/5] gnu: Add go-github-com-pion-ice-v3.
(address . 71014@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
f9dffee25faec91fe797863229c4101d198b2736.1715973559.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-ice-v3): New variable.

Change-Id: Ia38d816c6ba8754faaf649b298cb43832c30de12
---
gnu/packages/golang-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index df4b7db15b..a8a6cd69d7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2982,6 +2982,44 @@ (define-public go-github-com-pierrec-cmdflag
on top of the standard library @code{flag} package.")
(license license:bsd-3)))
+(define-public go-github-com-pion-ice-v3
+ (package
+ (name "go-github-com-pion-ice")
+ (version "3.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/ice/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f9jy80law69zb26rkb6kl6w1c66vdghdrmifhwlmzngb644ihdb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:tests? #f ;Tests require network access.
+ #:unpack-path "github.com/pion/ice/v3"
+ #:import-path "github.com/pion/ice/v3"))
+ (native-inputs (list go-github-com-stretchr-testify-next))
+ (propagated-inputs (list go-github-com-google-uuid
+ go-github-com-pion-dtls-v2
+ go-github-com-pion-logging
+ go-github-com-pion-mdns
+ go-github-com-pion-randutil
+ go-github-com-pion-stun-v2
+ go-github-com-pion-transport-v3
+ go-github-com-pion-turn-v3
+ go-golang-org-x-net))
+ (home-page "https://github.com/pion/ice/")
+ (synopsis "Go implementation of ICE")
+ (description
+ "Go implementation of Interactive Connectivity Establishment protocol (ICE,
+@url{https://datatracker.ietf.org/doc/html/rfc8445, RFC8445}.) The library is used
+as a part of @url{https://github.com/pion, Pion} WebRTC implementation.")
+ (license license:expat)))
+
(define-public go-github-com-pion-logging
(package
(name "go-github-com-pion-logging")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 17 May 21:27 +0200
[PATCH 4/5] gnu: go-github-com-pion-mdns-v0: New variable.
(address . 71014@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
5fa2116f23bb6b9dd00764ad50eb67ade06a8e59.1715973559.git.poptsov.artyom@gmail.com
* gnu/packages/golang-web.scm (go-github-com-pion-mdns-v0): New variable.

Change-Id: I942a87bf0851f4a9a30257952192c8b60597b41e
---
gnu/packages/golang-web.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c9c360d21c..3e0d721fae 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1682,6 +1682,24 @@ (define-public go-github-com-pion-mdns
@url{https://github.com/pion, Pion}.")
(license license:expat)))
+(define-public go-github-com-pion-mdns-v0
+ (package
+ (inherit go-github-com-pion-mdns)
+ (name "go-github-com-pion-mdns")
+ (version "0.0.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/mdns/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18nz0vddxik3q11mn4z65zvrfhspxv0xymxv9w3kgk2kszwq2byy"))))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs go-github-com-pion-mdns)
+ (replace "go-github-com-pion-transport" go-github-com-pion-transport)))))
+
(define-public go-github-com-pion-rtp
(package
(name "go-github-com-pion-rtp")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 17 May 21:27 +0200
[PATCH 5/5] gnu: Add go-github-com-pion-ice-v2.
(address . 71014@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
dc3b12caad76a212a5c927a0be0c1a9bdfe17cda.1715973559.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-ice-v2): New variable.

Change-Id: I06f3e26ef7aa5e1a71319c636b4f5846c0c2eb2a
---
gnu/packages/golang-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a8a6cd69d7..12ace7a6bc 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3020,6 +3020,33 @@ (define-public go-github-com-pion-ice-v3
as a part of @url{https://github.com/pion, Pion} WebRTC implementation.")
(license license:expat)))
+(define-public go-github-com-pion-ice-v2
+ (package
+ (inherit go-github-com-pion-ice-v3)
+ (name "go-github-com-pion-ice")
+ (version "2.3.24")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/ice/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mh7l31vv15gxpl61f22jwpc77b5l9wx4hbjv4h8cgmpb9911cv8"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments
+ go-github-com-pion-ice-v3)
+ ((#:unpack-path flags ''())
+ "github.com/pion/ice/v2")
+ ((#:import-path flags ''())
+ "github.com/pion/ice/v2")))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs go-github-com-pion-ice-v3)
+ (replace "go-github-com-pion-mdns" go-github-com-pion-mdns-v0)
+ (replace "go-github-com-pion-stun-v2" go-github-com-pion-stun)
+ (replace "go-github-com-pion-turn" go-github-com-pion-turn-v2)))))
+
(define-public go-github-com-pion-logging
(package
(name "go-github-com-pion-logging")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 7 Jun 02:00 +0200
[PATCH 0/5] gnu: Add go-github-com-pion-ice.
(address . 71014-done@debbugs.gnu.org)
875xultydg.fsf@gmail.com
Hi,

Thank you for the patches.

I've shifted most of them to golang-web as they are very close to
networking manipulation. I've also adjusted inheritance and added all
versions of released modules.

Pushed as 4683afd143..fc25e039fc to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmZiTbsACgkQdtcnv/Ys
0rVXGBAAwKTMumrmzLI0mJekihV2rzPEDfaDMBGEvcWPnRapgQ1Vi8yxRAwvkUb4
+OXpHwADKoJx3QI6//yaL5MtHYrmAwvQUuKw29qD+eWK/8nMF5pUo2trkmGaA667
dgtArqxBZQ8K0MX/oVfP9Ily9yzCyjvnFXsBItSnfc4zwrqYR1Zg7Ik7JbYihwbl
BI5dkqhEh8Ka1t6phG1zZAfRiJbJUSUPrZB1n+CGIQcNjogRkN9j0ff3c8Xw7pii
FZTUe3WE7HLdZfYE2YsU9jnmp56bTSw4Z+sVrQZ8NnYvFrLZp4IB3Z4abbzHZfRU
PPPNggOHwc8cuEoS/6h/AiZ9pV7Gcm1YCG3cVa4Rt0huriSzVsjbV4Lrbdu4sGkw
kX4wQFd8nyS2SiagpVP+YSoMplHInzfmbUqAd/jtNva6/3rQ+DNrgena/kF9qAYz
BL+mhoHbg4QRs/E1PvPEiBLXFPPTnJ9EBmxd4bF+IaeMcSCanrKJUJGkbt3lkfGu
bhtOk0CsXDC9f5BkOCOh4iYgOD4BKDbjAl/F5009SuFsJdmGdkGisZWJZIS+JBjU
z0nwAi5V+/2gSNk2JDJhNLDhRETahJf61mdSbFTAdakqGueYhpphMVcXFqmSP+v/
jicU6b/1ac87TS7CSzsgDDvEk2PTbWiV2K78Y4Ak3dYGrPPVsCw=
=sH5C
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71014@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71014
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch