[PATCH] gnu: libwacom: Update to 2.11.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Dariqq
  • Christopher Baines
Owner
unassigned
Submitted by
Dariqq
Severity
normal
D
D
Dariqq wrote on 17 May 12:57 +0200
(address . guix-patches@gnu.org)(name . Dariqq)(address . dariqq@posteo.net)
2f9068a109d5c9899fcb4a8285b02951bef05428.1715943457.git.dariqq@posteo.net
With the 2.9 release the license got clarified to be hpnd.

* gnu/packages/xdisorg.scm (libwacom): Update to 2.11.0.
[#:phases]: Add a phase to wrap with GUIX_PYTHONPATH.
[native-inputs]: Remove python-evdev.
[inputs]: Add bash-minimal, python, python-libevdev, python-pyudev.
[propagated-inputs]: Add libevdev.
[license]: Correct license to hpnd.

Change-Id: Ib5276beaec2c23e74532cb157225fc3a9a2e25e7
---

Hi Guix,
This patch updates the libwacom package.
The license was wrong before and upstream now clarified that it is hpnd.
The license file does not get installed right now, I've opened #70999 as this is a general problem with meson-build-system.
The libwacom.pc file now also requires libevdev so I added that as a propagated input.
I've also added a wrapper with pythonpath for the python program.

gnu/packages/xdisorg.scm | 25 ++++++++++++++++++-------
1 file changed, 18 insertions(+), 7 deletions(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index e13b44290e..f8ef28d5fa 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1449,7 +1449,7 @@ (define-public xcape
(define-public libwacom
(package
(name "libwacom")
- (version "2.6.0")
+ (version "2.11.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1457,24 +1457,35 @@ (define-public libwacom
"libwacom-" version "/libwacom-" version ".tar.xz"))
(sha256
(base32
- "13x978gzyw28cqd985m5smiqgza0xp3znb1s0msmn8vmjjlwqxi3"))))
+ "0i0k333kfc6ai4vxqijjybj38s9j1hly2x327113lm1cr0g9jgxh"))))
(build-system meson-build-system)
(arguments
(list
- #:configure-flags #~(list "--default-library=shared")))
+ #:configure-flags #~(list "--default-library=shared")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* _
+ (wrap-program (string-append #$output "/bin/libwacom-show-stylus")
+ `("GUIX_PYTHONPATH" prefix (,(getenv "GUIX_PYTHONPATH")))))))))
(native-inputs
(list pkg-config
;; For tests.
python
- python-evdev
python-libevdev
python-pytest
python-pyudev))
(inputs
- (list gtk+ eudev libxml2))
+ (list bash-minimal ;; for wrap-program
+ gtk+
+ eudev
+ libxml2
+ python
+ python-libevdev
+ python-pyudev))
(propagated-inputs
;; libwacom.pc 'Requires' these:
- (list glib libgudev))
+ (list glib libevdev libgudev))
(home-page "https://linuxwacom.github.io/")
(synopsis "Helper library for graphics tablet settings")
(description
@@ -1482,7 +1493,7 @@ (define-public libwacom
intended to be used by client-programs that need model identification. It is
already being used by the gnome-settings-daemon and the GNOME Control Center
Wacom tablet applet.")
- (license license:x11)))
+ (license license:hpnd)))
(define-public xf86-input-wacom
(package

base-commit: 0846eaecd45783bf40e8dc67b0c16f71068524b7
--
2.41.0
D
D
Dariqq wrote on 2 Jun 18:41 +0200
[PATCH v2] gnu: libwacom: Update to 2.11.0.
(address . 71001@debbugs.gnu.org)(name . Dariqq)(address . dariqq@posteo.net)
f060556ac3bb535ceb16b7dc52ce23ea4df62882.1717346460.git.dariqq@posteo.net
With the 2.9 release the license got clarified to be hpnd.

* gnu/packages/xdisorg.scm (libwacom): Update to 2.11.0.
[native-inputs]: Remove python-evdev.
[inputs]: Add python, python-libevdev, python-pyudev.
[propagated-inputs]: Add libevdev.
[license]: Correct license to hpnd.

Change-Id: Ib5276beaec2c23e74532cb157225fc3a9a2e25e7
---
Changes in v2: Removed the PYTHONPATH wrapper becasue I don't think it is worth the extra 100MB in size and it also captures native python inputs.

gnu/packages/xdisorg.scm | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 357a868528..ccf28f3990 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1449,7 +1449,7 @@ (define-public xcape
(define-public libwacom
(package
(name "libwacom")
- (version "2.6.0")
+ (version "2.11.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1457,7 +1457,7 @@ (define-public libwacom
"libwacom-" version "/libwacom-" version ".tar.xz"))
(sha256
(base32
- "13x978gzyw28cqd985m5smiqgza0xp3znb1s0msmn8vmjjlwqxi3"))))
+ "0i0k333kfc6ai4vxqijjybj38s9j1hly2x327113lm1cr0g9jgxh"))))
(build-system meson-build-system)
(arguments
(list
@@ -1466,15 +1466,19 @@ (define-public libwacom
(list pkg-config
;; For tests.
python
- python-evdev
python-libevdev
python-pytest
python-pyudev))
(inputs
- (list gtk+ eudev libxml2))
+ (list gtk+
+ eudev
+ libxml2
+ python
+ python-libevdev
+ python-pyudev))
(propagated-inputs
;; libwacom.pc 'Requires' these:
- (list glib libgudev))
+ (list glib libevdev libgudev))
(home-page "https://linuxwacom.github.io/")
(synopsis "Helper library for graphics tablet settings")
(description
@@ -1482,7 +1486,7 @@ (define-public libwacom
intended to be used by client-programs that need model identification. It is
already being used by the gnome-settings-daemon and the GNOME Control Center
Wacom tablet applet.")
- (license license:x11)))
+ (license license:hpnd)))
(define-public xf86-input-wacom
(package

base-commit: bc06affabcf68bbe93e9afee13bef8cc8c6336a2
--
2.45.1
C
C
Christopher Baines wrote on 11 Jun 13:36 +0200
(name . Dariqq)(address . dariqq@posteo.net)(address . 71001-done@debbugs.gnu.org)
87sexjaey8.fsf@cbaines.net
Dariqq <dariqq@posteo.net> writes:

Toggle quote (15 lines)
> With the 2.9 release the license got clarified to be hpnd.
>
> * gnu/packages/xdisorg.scm (libwacom): Update to 2.11.0.
> [native-inputs]: Remove python-evdev.
> [inputs]: Add python, python-libevdev, python-pyudev.
> [propagated-inputs]: Add libevdev.
> [license]: Correct license to hpnd.
>
> Change-Id: Ib5276beaec2c23e74532cb157225fc3a9a2e25e7
> ---
> Changes in v2: Removed the PYTHONPATH wrapper becasue I don't think it is worth the extra 100MB in size and it also captures native python inputs.
>
> gnu/packages/xdisorg.scm | 16 ++++++++++------
> 1 file changed, 10 insertions(+), 6 deletions(-)

Looks good to me, I've pushed this to master as
1d5bfe45134259676e609020ac64cbc1a1a81d2b.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZoNs9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeiXw/+J1SF3kKRR+YXLGe0paCS7iS3uxmVnJXg
r6EPN7hTkmCWUuTYnNKOZT23J03SSYjRBBzMoT4vbSET8HoaWSFVKupNW4eoCiXH
3RKcuUEQPJB8vjgbR1M6SgoLwxwZEAcz5bow5LsqJvrF8xvCWj/NStKZiDhXdDLD
vmWeT9qn+T/vw+xZGvTDCzrQvjLd+wpsLLd2qmvj8GPvrnEVFlAaoTiGTnp7LugR
C0WIPDeJw3E6ruJhq+C1fiOhCkYmtvghfqv4hwCQUZo1daD3WZtTKqWM0V9sKBw9
cQSThxAMC9nXQfKovagQftbm+l4ER+D0R1d2ANW/2uWU+0OhtAFjIPefPcfAvpy7
i6Wh1a9lMx25oB2TqbFJzGM6mreyUD1QCqEDjzeLFRBGiwKvAQ5SXmlOei5577bQ
S4xzRlnnGNb7rNMOsJR5WbdjBcLGHVn8PXtwqO2+MH9xXM8Ur70b2FkK0KarF9Rq
XtjdoEk84ONLp6X92NckBMqYh+0ogpePzJ8Fx1lJtoWaq0vR5zchwDjxhpbYg/OV
BJIOxensxC5stYMrz9XU0sfnuoFyGliUOSBm3h9Ms/Mj23LB/lWfnlhtp69YVKjD
PbcKgvTsiTcsvrznoJHmq8dv3noxYU43B594DUWYVciSUvInORq1Xd3wQWV2znk/
U1vpsOrCS/o=
=m471
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71001@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71001
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch