[PATCH] gnu: python-scikit-image: Disable test_ellipse_parameter_stability.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 17 May 10:00 +0200
(address . guix-patches@gnu.org)
0161703ca0ab9849780ee2d9d6acf9f4dfd74408.1715932852.git.mail@cbaines.net

* gnu/packages/python-science.scm (python-scikit-image)[arguments]: Add 'patch
phase.

Change-Id: Ic1fc301eb0fad5330c34780ce096c446c1076824
---
gnu/packages/python-science.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 861badad2e..d1a43b23ed 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -475,6 +475,13 @@ (define-public python-scikit-image
(list
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ ;; Disable flaky test
+ (substitute* "skimage/measure/tests/test_fit.py"
+ (("def test_ellipse_parameter_stability():")
+ "@pytest.mark.xfail(reason=\"https://github.com/scikit-image/scikit-image/issues/7061\")
+def test_ellipse_parameter_stability():"))))
(add-before 'build 'change-home-dir
(lambda _
;; Change from /homeless-shelter to /tmp for write permission.

base-commit: 0846eaecd45783bf40e8dc67b0c16f71068524b7
--
2.41.0
S
S
Sharlatan Hellseher wrote on 17 May 18:00 +0200
(address . 70997@debbugs.gnu.org)
87jzjs2ztg.fsf@gmail.com
Hi Christopher


I think you may add the test to ignore list without substituting it.

Toggle snippet (3 lines)
#:test-flags #~(list "-k" "test_ellipse_parameter_stability")

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmZHfysACgkQdtcnv/Ys
0rWmJRAAttSlDI8zYG2Brr+OVuQeB0z8Emy3Mp9IUBt3DJc5enKNEYKdV9EbVi6i
rFZuLV5MroEKjuhZnA1atzfgt9Px9EB68gNhm1zdJSjDcL6ulLI4uzqmLMrlleRL
fouo1SI+rWHKwAobUj9TWw9hhQQQ3xt6qJ1rITQ5SFXJmmviEUANam83aLLlXY7i
ae4MTrQxbi8ufHkxmKR7SgRhQ+0OxPxQyh7mUFaXzwTe36waP/YGlH1F0df3onrJ
Ke6P8pyd6zkZK/XAj/KFFhexaZg+GhhAUVzKsA6JteMsx4hHAhPA8qEfpzdfpt9z
0ayaGmYYnJQr9N4D/L9ZEggTFk+NAWp6scVjTY8xpkbS6K5iB0rdHMooKakBbZ5E
owxbjwZj0Tj3O/CXrnx2jkClsXgPt9e6VujK5ZKjLcFxQaffvcpKgVItMlPL7GhD
813EwGwikAnLsXhuAJXRqBIN7J2LaoKGFKYDUc52PSHTK7A3pHgMGdwtT47jNlU4
H6PF41NvK3zn8hBK/jyQd3hL6wevCdw3B05EUbo6q5YBGnZAB0FBUzGooiIrhNmt
COPGnkfs8tTRJ/HEJVoMueGt+u2yoc920NewDe80PSDFASjZ1vCOlCUBlg+i/oH9
YhO8Qb+a9LW5Dos5Y7uXQMnTShRjAAHQ3Aw9JKYO+ft8KsMvvRo=
=aZ+Z
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 26 May 18:20 +0200
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 70997-done@debbugs.gnu.org)
87msocfstg.fsf@cbaines.net
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (6 lines)
> I think you may add the test to ignore list without substituting it.
>
> --8<---------------cut here---------------start------------->8---
> #:test-flags #~(list "-k" "test_ellipse_parameter_stability")
> --8<---------------cut here---------------end--------------->8---

Thanks for the suggestion, I think that actually selects the test to
run, but adding not to the start seems to skip the named test, so I've
pushed this as a4a45669c76f80d5126add818df22f42547bb4a2.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZTYVtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XemXw/9HfmC4UNzs1zG1jHnouX+8T7THI0iyu5O
zsQ9M+IisPTuaWvlf1NJf2yEzr61byiPG2jd54tlrgqtWc5o4TX3e+NIRoLYSG+c
cTI4ajElCIG4TxNeq4me+v2XZH2sXRAkpoD0XATo+5MbyCkfSHNG58VyEBfxSpeh
LMvgcuH78RGNfzLByRYS9W0cQne9mfNW6grDLQgFf5tpy/XbqdnyQ1f2sLQq+D1f
amcaDFQD7GNLIsn6bw9ZBXzxpMw6q7xNtJ8CxPItD4IK0eK6BeZUE+qO4Ih87u6p
q5cr+GK4eD1y0LnhZ7oMH6azgY7M0SyBb/7CaWl7/wYoYHO5xOFCLbVYnu5i567K
rEmSnueZensYAZwkRaFjDTShoCZiOS4Z3DyLEmy3j3lnE2XiHutuR0nEUWJU4Q5d
E0BLtgDIb3AupSm0oDVuHcCsmClAX8JfjI+YBdOxw8sFJysxr7piBTZTUBF/GgAm
XQ/+X3MUWtd6MguMrZpl2U95u4BkLeQkgFmgUR+KsOyPYeGq0k2JY45OO+OF08GO
6WnypfKBkg3guEdDzeBfam4zmZacdJlUukcPFiimTyOBWwDrG3ndbYTf2fP7NyQt
dUQKppwLxw9+ZlnsSH7bw7GZ7fMbuusCUnDQ7OWalEJ84HHLPTjBpXzf0bjfNUkX
44Dc52940Ao=
=xBSl
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70997@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70997
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch