[PATCH] gnu: 0xffff: Update to 0.10.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 16 May 12:10 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
850faca890728cf6296d0b35b13e9c24068de64c.1715854236.git.poptsov.artyom@gmail.com
* gnu/packages/flashing-tools.scm (0xffff): Update to 0.10.
[arguments]: Use gexps.

Change-Id: Ifb54578deb016a88e6314ecb7d16966c9294d7b3
---
gnu/packages/flashing-tools.scm | 22 +++++++++++-----------
1 file changed, 11 insertions(+), 11 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 83a4c3e3e7..2629bafbe4 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2023 B. Wilson <x@wilsonb.com>
;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -112,7 +113,7 @@ (define-public flashrom
(define-public 0xffff
(package
(name "0xffff")
- (version "0.9")
+ (version "0.10")
(source
(origin
(method git-fetch)
@@ -121,22 +122,21 @@ (define-public 0xffff
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0rl1xzbxl991pm2is98zbryac1lgjrc3zphmbd8agv07av0r6r6n"))))
+ (base32 "1nqbrr64kjr0h3h6gzhrj1vd106nni4y9mhjdr8mh2x9lcgn4fj5"))))
(build-system gnu-build-system)
(inputs
;; Building with libusb-compat will succeed but the result will be broken.
;; See <https://github.com/pali/0xFFFF/issues/3>.
(list libusb-0.1))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure)) ; no configure
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- "HOST_CC=gcc"
- "BUILD_DATE=GNU Guix"
- (string-append "PREFIX=" %output))
- #:tests? #f)) ; no 'check' target
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)) ;no configure
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target)) "HOST_CC=gcc"
+ "BUILD_DATE=GNU Guix"
+ (string-append "PREFIX=" %output))
+ #:tests? #f)) ;no 'check' target
(home-page "https://github.com/pali/0xFFFF")
(synopsis "Flash FIASCO images on Maemo devices")
(description

base-commit: 898b5f30f3d485d48275c920da172863da9524c6
--
2.41.0
J
J
Jonathan Brielmaier wrote on 17 May 21:16 +0200
(address . 70975-done@debbugs.gnu.org)
a0d1d8e3-99da-d257-bb91-5ec359a55b22@web.de
Pushed.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70975@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70975
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch