[PATCH 0/3] Update dhewm3

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • James Smith
  • Christopher Baines
Owner
unassigned
Submitted by
James Smith
Severity
normal
J
J
James Smith wrote on 16 May 02:42 +0200
(address . guix-patches@gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
cover.1715820031.git.jsubuntuxp@disroot.org
This patch series makes changes to dhewm3, such as fetching from the git
repository instead of a generated tarball, switching to G-Expressions, and
updating it to 1.5.3.

James Smith (3):
gnu: dhewm3: Use git repository.
gnu: dhewm3: Use gexps.
gnu: dhewm3: Update to 1.5.3.

gnu/packages/game-development.scm | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)


base-commit: 6cdb6cc6ef3b6d810cb26d19e23da309d63d1eaf
--
2.41.0
J
J
James Smith wrote on 16 May 02:46 +0200
[PATCH 1/3] gnu: dhewm3: Use git repository.
(address . 70971@debbugs.gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
a32e0b02753e9797c877d9b129756b964898376f.1715820031.git.jsubuntuxp@disroot.org
* gnu/packages/game-development.scm (dhewm3) [source]: Use git repository
instead of downloading a tarball from GitHub.

Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260
---
gnu/packages/game-development.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index bf0f984ec7..86d3cc0a06 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 dan <i@dan.games>
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3099,13 +3100,13 @@ (define-public dhewm3
(name "dhewm3")
(version "1.5.2")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/dhewm/dhewm3/releases/download/"
- version "/dhewm3-" version "-src.tar.xz"))
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/dhewm/dhewm3")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "10p0w1x5wx9b7d8mzvb6yqjia9prhkjwz04vbvphy8p383r33am6"))))
+ "056prmry1lag1pandcw058y5yzbah80ccmz8qlmlx9siz8zlxqyw"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; No tests.
--
2.41.0
J
J
James Smith wrote on 16 May 02:46 +0200
[PATCH 2/3] gnu: dhewm3: Use gexps.
(address . 70971@debbugs.gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
d1f7f7ba8a0a3eab745cf02a25943b9d4930b0c7.1715820031.git.jsubuntuxp@disroot.org
* gnu/packages/game-development.scm (dhewm3) [arguments]: Use gexps.

Change-Id: I0a9090a30a988adeb177f282066b1aa31ca1a483
---
gnu/packages/game-development.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 86d3cc0a06..1c0d4ec6bf 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -3109,12 +3109,12 @@ (define-public dhewm3
"056prmry1lag1pandcw058y5yzbah80ccmz8qlmlx9siz8zlxqyw"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; No tests.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'change-to-build-dir
- (lambda _
- (chdir "neo"))))))
+ (list #:tests? #f ; No tests.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'change-to-build-dir
+ (lambda _
+ (chdir "neo"))))))
(inputs
(list curl
libx11
--
2.41.0
J
J
James Smith wrote on 16 May 02:46 +0200
[PATCH 3/3] gnu: dhewm3: Update to 1.5.3.
(address . 70971@debbugs.gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
fdc0c913b53273c35e58471632661a6ce728d15f.1715820031.git.jsubuntuxp@disroot.org
* gnu/packages/game-development.scm (dhewm3): Update to 1.5.3.

Change-Id: Iaf1b29540f87043ae6ceef9f3860e5c9331dd191
---
gnu/packages/game-development.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 1c0d4ec6bf..3520a23454 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -3098,7 +3098,7 @@ (define-public warsow-qfusion
(define-public dhewm3
(package
(name "dhewm3")
- (version "1.5.2")
+ (version "1.5.3")
(source (origin
(method git-fetch)
(uri (git-reference (url "https://github.com/dhewm/dhewm3")
@@ -3106,7 +3106,7 @@ (define-public dhewm3
(file-name (git-file-name name version))
(sha256
(base32
- "056prmry1lag1pandcw058y5yzbah80ccmz8qlmlx9siz8zlxqyw"))))
+ "1zbwhrngmgb0969izmxididyx892qk7591aa9mbigakw6dvmlm84"))))
(build-system cmake-build-system)
(arguments
(list #:tests? #f ; No tests.
--
2.41.0
J
J
James Smith wrote on 7 Jun 07:45 +0200
[PATCH v2 0/3] Update dhewm3
(address . 70971@debbugs.gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
cover.1717739144.git.jsubuntuxp@disroot.org
Rebased patch series, updated existing copyright line instead of creating a
duplicate copyright line in the first patch.

James Smith (3):
gnu: dhewm3: Use git repository.
gnu: dhewm3: Use gexps.
gnu: dhewm3: Update to 1.5.3.

gnu/packages/game-development.scm | 26 +++++++++++++-------------
1 file changed, 13 insertions(+), 13 deletions(-)


base-commit: 580d77d0fb12448ef1621699cc0c56e787e2aadb
--
2.45.1
J
J
James Smith wrote on 7 Jun 07:45 +0200
[PATCH v2 1/3] gnu: dhewm3: Use git repository.
(address . 70971@debbugs.gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
5e1af945c5118711bf3d16d10eb0df91d1841cbc.1717739144.git.jsubuntuxp@disroot.org
* gnu/packages/game-development.scm (dhewm3) [source]: Use git repository
instead of downloading a tarball from GitHub.

Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260
---
gnu/packages/game-development.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5b7852c4eb..89ace2925b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
-;;; Copyright © 2020-2022 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2020-2022, 2024 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
@@ -3101,13 +3101,13 @@ (define-public dhewm3
(name "dhewm3")
(version "1.5.2")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/dhewm/dhewm3/releases/download/"
- version "/dhewm3-" version "-src.tar.xz"))
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/dhewm/dhewm3")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "10p0w1x5wx9b7d8mzvb6yqjia9prhkjwz04vbvphy8p383r33am6"))))
+ "056prmry1lag1pandcw058y5yzbah80ccmz8qlmlx9siz8zlxqyw"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; No tests.
--
2.45.1
J
J
James Smith wrote on 7 Jun 07:45 +0200
[PATCH v2 2/3] gnu: dhewm3: Use gexps.
(address . 70971@debbugs.gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
c610a204bbcf643b799d1bc5ad745e8716e0caa7.1717739144.git.jsubuntuxp@disroot.org
* gnu/packages/game-development.scm (dhewm3) [arguments]: Use gexps.

Change-Id: I0a9090a30a988adeb177f282066b1aa31ca1a483
---
gnu/packages/game-development.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 89ace2925b..45a0db95c2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -3110,12 +3110,12 @@ (define-public dhewm3
"056prmry1lag1pandcw058y5yzbah80ccmz8qlmlx9siz8zlxqyw"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; No tests.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'change-to-build-dir
- (lambda _
- (chdir "neo"))))))
+ (list #:tests? #f ; No tests.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'change-to-build-dir
+ (lambda _
+ (chdir "neo"))))))
(inputs
(list curl
libx11
--
2.45.1
J
J
James Smith wrote on 7 Jun 07:45 +0200
[PATCH v2 3/3] gnu: dhewm3: Update to 1.5.3.
(address . 70971@debbugs.gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
7e3538bdb029fd6a12d696f857db70318e5adb93.1717739144.git.jsubuntuxp@disroot.org
* gnu/packages/game-development.scm (dhewm3): Update to 1.5.3.

Change-Id: Iaf1b29540f87043ae6ceef9f3860e5c9331dd191
---
gnu/packages/game-development.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 45a0db95c2..c3a0cfbbd1 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -3099,7 +3099,7 @@ (define-public warsow-qfusion
(define-public dhewm3
(package
(name "dhewm3")
- (version "1.5.2")
+ (version "1.5.3")
(source (origin
(method git-fetch)
(uri (git-reference (url "https://github.com/dhewm/dhewm3")
@@ -3107,7 +3107,7 @@ (define-public dhewm3
(file-name (git-file-name name version))
(sha256
(base32
- "056prmry1lag1pandcw058y5yzbah80ccmz8qlmlx9siz8zlxqyw"))))
+ "1zbwhrngmgb0969izmxididyx892qk7591aa9mbigakw6dvmlm84"))))
(build-system cmake-build-system)
(arguments
(list #:tests? #f ; No tests.
--
2.45.1
J
J
James Smith wrote on 11 Jun 14:45 +0200
Re: [bug#70971] [PATCH v2 1/3] gnu: dhewm3: Use git repository.
(name . Christopher Baines)(address . mail@cbaines.net)
864j9zzm00.fsf@disroot.org
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (13 lines)
> James Smith via Guix-patches via <guix-patches@gnu.org> writes:
>
>> * gnu/packages/game-development.scm (dhewm3) [source]: Use git repository
>> instead of downloading a tarball from GitHub.
>>
>> Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260
>> ---
>> gnu/packages/game-development.scm | 12 ++++++------
>> 1 file changed, 6 insertions(+), 6 deletions(-)
>
> I'm missing why you're making this change? I don't see anything wrong
> with using these upstream release tarballs.

I noticed that the package was using a tarball from GitHub and assumed
that it was one that was autogenerated. Upon closer inspection, I see
that it's a manually pack tarball instead. I can send a new set of
patches that excludes switching to the git repository if needed.
C
C
Christopher Baines wrote on 11 Jun 12:38 +0200
(name . James Smith via Guix-patches via)(address . guix-patches@gnu.org)
87a5jrbw83.fsf@cbaines.net
James Smith via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (8 lines)
> * gnu/packages/game-development.scm (dhewm3) [source]: Use git repository
> instead of downloading a tarball from GitHub.
>
> Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260
> ---
> gnu/packages/game-development.scm | 12 ++++++------
> 1 file changed, 6 insertions(+), 6 deletions(-)

I'm missing why you're making this change? I don't see anything wrong
with using these upstream release tarballs.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZoKRxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdjUA//SqUK91UHrpL8fdfdtywSZMrkdpaGif+y
22D4vZuimqtsMxQQhn/4mbAHSGGhFfB8iANPD5kvU2SnVJg6c536kJrqIuElEWJw
s+UbCoSHTEx+P+goed691p54ygh0jpywMoJ6ch7CLWk5dnZcyIiyZU3MdWQe/Vfe
yZsDJd66CSJvaMvnlUugO9tpfObqoRDi8y2WiKBrS6dgnJqYsjSX1GoI3TCV+Rrq
7neNS6ZxJGM8o1cuYXjV9hnqZ+/iMs2a+Ay3o9BRh0Kj/Q303ekGfZSwJ/AOGp7m
TveflURAzx9lgiT8FUvrg5y25NaBp+iTxnuSPKPjn8rUIa6KvwdgchaAbdUgfbld
wjUNa9JmN7aan8ANSNc2OiI2Jx+jtE31VLnusyoKkr9WNnqALKYRvYZ5hHGryel5
FCGYwW+TIgBIR1QEudmHk4QM0OBPsz5ovhrNjfQrpOD+deLp4YCsfdtSn5bzk1jW
3Lu9T7+rbe9kRuRNajysgmmT3+KKdA7d4eCB/BCOyr/JAGWrgN5mnCczQygZIYzX
SKwgUWuQFiTXAPWnoKw5Ir9pNZuVKKip65srgrW4Tfkaa0XjQqrlKJUlCjvUNuBl
rWo+kUX9ClOmpD0Tlvy2a6NaDKHqGcmZINxJDfPNxE8yTUpwjnGEHChQw7BODtqC
N/dnqeR7UEU=
=Ypog
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 22 Jun 18:33 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
877ceh6ios.fsf@cbaines.net
James Smith <jsubuntuxp@disroot.org> writes:

Toggle quote (20 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> James Smith via Guix-patches via <guix-patches@gnu.org> writes:
>>
>>> * gnu/packages/game-development.scm (dhewm3) [source]: Use git repository
>>> instead of downloading a tarball from GitHub.
>>>
>>> Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260
>>> ---
>>> gnu/packages/game-development.scm | 12 ++++++------
>>> 1 file changed, 6 insertions(+), 6 deletions(-)
>>
>> I'm missing why you're making this change? I don't see anything wrong
>> with using these upstream release tarballs.
>
> I noticed that the package was using a tarball from GitHub and assumed
> that it was one that was autogenerated. Upon closer inspection, I see
> that it's a manually pack tarball instead. I can send a new set of
> patches that excludes switching to the git repository if needed.

I tried to apply the patches, but they look to have already been
applied.

I'll leave the issue open until it's been decided whether to keep the
switch to the Git repository or go back to using tarballs.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZ2/ONfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd3VRAAn9xihzc8Ae2cjhn4aIn8Dlmz7nivFuaS
/3qgfWohmLLayE57TfGIcJza5rTpiEHoQFnS9bHcnKps1cO3SsKXkFIIjp7ZbA5p
7xwD3C1kJvILuBtv/hK2A3OT2cKWBzjDFsFxxy5YfzgybHVZ3npnt1Nq9GjC56UY
z2wxrZLVXMFfzDkt44Yn9ScLZSFMXaZCPxu/N/nnvb8YWa7BY5HBhvuGSCh5pIJO
Qg8sk7aUxbi8/1yR6hSd4EAWNiw6LoGNjLr6n/uSsrIgfsffOA5QnkH6UhmqOzGL
pnAeYDbmtPLC+jmbyxRMIWsES67CfUpy9PWDVAs3BOTQM4W1NB4jfEYu6gKqrIC0
vieWVUIyz0wBTD62g9aKSm07rjPQJBicpl5tLjTFnklbSRiBccUr9UheuVaPscT0
oE3cJTgDIeMyot4SfHLWyS/XIXr4/hJZSrUuxfujNM8jfBiIqyKPLUgjOlxMphjD
XHW6N56ohxZTJ2mP/ncdczHyEMRUdxV4zBaNE7nr6TbRWsqw2nhfSsMzL7V35U3u
MHXElno/rhApqyZnsku14MFGD0S0uqwZ4Pqzrg1rtV6IZruMfQrZ4edHpMXxNk1r
Lvdp0ufFYdmsLyRA8FXXzaDt6mQZSVa1j4uWkEk3K7hnLYaLDP89TzZFSjE9ZCfI
QSUxhhluNXg=
=SQbZ
-----END PGP SIGNATURE-----

A
A
Andreas Enge wrote on 30 Jun 12:46 +0200
Close
(address . 70971-done@debbugs.gnu.org)
ZoE3oJnHKthgq62I@jurong
Hello,

I am closing this bug report, as I think either way, using tarballs or
git repositories, is fine. Now that the switch to git has been applied,
I do not see a compelling reason to revert it.

Andreas
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70971@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70971
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch