[PATCH 00/14] Add BTF support to kernel, sysdig and dependents, zstd-compressed modules

  • Done
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 15 May 19:20 +0200
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
cover.1715793606.git.maxim.cournoyer@gmail.com
This series adds BTF (Berkeley Type Format) support to our kernel, catching up
with other main distributions in enabling embedded BPF (Berkeley Packet
Filter) programs.

This was motivated by packaging 'sysdig', a system introspection application
that can make use of BTF. Adding BTF does incur some size increase; with
'linux-libre' package going up from 132 MiB to 164 MiB (24%). This is later
somewhat mitigated by using Zstd compressed (at maximum level, 19) kernel
modules, which brings the kernel size back down to 144 MiB, which corresponds
to a more reasonable 9% increase from before this series. The BPF kernel
variant we were carrying is removed as proper BPF support will now exists in
our main kernel.

That's it! I hope you enjoy using 'csysdig' to keep track of the syscalls and
IO usage of your process/threads.
END



Maxim Cournoyer (14):
gnu: grpc: Modernize.
gnu: grpc: Propagate abseil-cpp-cxxstd11.
gnu: Add valijson.
gnu: libbpf: Use gexps.
gnu: libbpf: Update to 1.4.1.
gnu: Add falcosecurity-libs.
gnu: Add sysdig.
gnu: Add dwarves.
gnu: make-linux-libre*: Set KBUILD_BUILD_VERSION for reproducibility.
gnu: make-linux-libre*: Run install targets in parallel.
gnu: linux: Turn %default-extra-linux-options into a procedure.
gnu: linux-libre: Enable BTF debug info.
gnu: linux-libre: Enable Zstd compression of kernel modules.
gnu: linux-libre-with-bpf: Deprecate in favor of linux-libre.

doc/guix-cookbook.texi | 17 +-
gnu/build/linux-modules.scm | 62 ++--
gnu/installer.scm | 1 +
gnu/local.mk | 7 +
gnu/packages/admin.scm | 58 +++
gnu/packages/linux.scm | 347 +++++++++++++-----
.../dwarves-threading-reproducibility.patch | 23 ++
.../falcosecurity-libs-install-pman.patch | 14 +
.../falcosecurity-libs-libscap-pc.patch | 16 +
...lcosecurity-libs-libsinsp-pkg-config.patch | 155 ++++++++
.../falcosecurity-libs-pkg-config.patch | 23 ++
...alcosecurity-libs-shared-library-fix.patch | 50 +++
.../sysdig-shared-falcosecurity-libs.patch | 71 ++++
gnu/packages/rpc.scm | 121 +++---
gnu/packages/serialization.scm | 26 +-
gnu/system/linux-initrd.scm | 6 +-
guix/profiles.scm | 7 +-
17 files changed, 812 insertions(+), 192 deletions(-)
create mode 100644 gnu/packages/patches/dwarves-threading-reproducibility.patch
create mode 100644 gnu/packages/patches/falcosecurity-libs-install-pman.patch
create mode 100644 gnu/packages/patches/falcosecurity-libs-libscap-pc.patch
create mode 100644 gnu/packages/patches/falcosecurity-libs-libsinsp-pkg-config.patch
create mode 100644 gnu/packages/patches/falcosecurity-libs-pkg-config.patch
create mode 100644 gnu/packages/patches/falcosecurity-libs-shared-library-fix.patch
create mode 100644 gnu/packages/patches/sysdig-shared-falcosecurity-libs.patch


base-commit: 029f2e970d5d14dda2dc89a4a3cc17de573ff90c
--
2.41.0
M
M
Maxim Cournoyer wrote on 15 May 20:30 +0200
control message for bug #70964
(address . control@debbugs.gnu.org)
87frujx706.fsf@gmail.com
tags 70964 notabug
close 70964
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70964@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70964
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch