[PATCH 0/2] gnu: python-pivy: Update to 0.6.8.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 15 May 10:11 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1715760488.git.poptsov.artyom@gmail.com
This patchset fixes "python-pivy" build. Also it updates "python-pivy" to
0.6.8 as it fixes Draft Workbench in FreeCAD:

Artyom V. Poptsov (2):
gnu: python-pivy: Fix build.
gnu: python-pivy: Update to 0.6.8.

gnu/packages/python-xyz.scm | 27 +++++++++++++--------------
1 file changed, 13 insertions(+), 14 deletions(-)


base-commit: 898b5f30f3d485d48275c920da172863da9524c6
--
2.41.0
A
A
Artyom V. Poptsov wrote on 15 May 10:13 +0200
[PATCH 1/2] gnu: python-pivy: Fix build.
(address . 70957@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
e60fd655944c439e86da0d9ecf3104f7b1bd19c5.1715760488.git.poptsov.artyom@gmail.com
"python-pivy" build fails when "soqt" is in the inputs (see

* gnu/packages/python-xyz.scm (python-pivy): Fix build.
[inputs]: Remove "soqt".
[arguments]: Use gexps.

Change-Id: If332ccd42b3a373e7b4118f3bcbc3646e8b59d41
---
gnu/packages/python-xyz.scm | 25 ++++++++++++-------------
1 file changed, 12 insertions(+), 13 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b295d780ab..c48d52952b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -121,7 +121,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
-;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
@@ -32935,20 +32935,20 @@ (define-public python-pivy
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0vids7sxk8w5vr73xdnf8xdci71a7syl6cd35aiisppbqyyfmykx"))))
+ (base32 "0vids7sxk8w5vr73xdnf8xdci71a7syl6cd35aiisppbqyyfmykx"))))
(build-system python-build-system)
(arguments
- `(;; The test suite fails due to an import cycle between 'pivy' and '_coin'
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
+ (list
+ ;; The test suite fails due to an import cycle between 'pivy' and '_coin'
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
(add-after 'unpack 'patch-cmake-include-dirs
- (lambda _
- ;; Patch buildsystem to respect Coin3D include directory
- (substitute* "CMakeLists.txt"
- (("\\$\\{SoQt_INCLUDE_DIRS}")
- "${Coin_INCLUDE_DIR};${SoQt_INCLUDE_DIRS}"))
- #t)))))
+ (lambda _
+ ;; Patch buildsystem to respect Coin3D include directory
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{SoQt_INCLUDE_DIRS}")
+ "${Coin_INCLUDE_DIR};${SoQt_INCLUDE_DIRS}")))))))
(native-inputs
(list cmake swig))
(inputs
@@ -32956,7 +32956,6 @@ (define-public python-pivy
qtbase-5
libxi
libice
- soqt
glew
coin3d))
(home-page "https://github.com/coin3d/pivy")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 15 May 10:13 +0200
[PATCH 2/2] gnu: python-pivy: Update to 0.6.8.
(address . 70957@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
50189d36905e74b1ce24a290a8a053879313a2e6.1715760488.git.poptsov.artyom@gmail.com
* gnu/packages/python-xyz.scm (python-pivy): Update to 0.6.8.

Change-Id: I7375a8261bd24ae1c2f54c6889e1a39d6db93468
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c48d52952b..72f232e3ac 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32926,7 +32926,7 @@ (define-public python-retry
(define-public python-pivy
(package
(name "python-pivy")
- (version "0.6.5")
+ (version "0.6.8")
(source
(origin
(method git-fetch)
@@ -32935,7 +32935,7 @@ (define-public python-pivy
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0vids7sxk8w5vr73xdnf8xdci71a7syl6cd35aiisppbqyyfmykx"))))
+ (base32 "00l4r06dwmgn8h29nrl3g3yv33cfyizyylk28x1j95qyj36sggfb"))))
(build-system python-build-system)
(arguments
(list
--
2.41.0
G
G
Guillaume Le Vaillant wrote on 15 May 14:12 +0200
Re: [bug#70957] [PATCH 0/2] gnu: python-pivy: Update to 0.6.8.
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 70957-done@debbugs.gnu.org)
87msorl1ee.fsf@kitej
Patches applied as d8d0fdd25ce3479f7ba45e1800241196b6828284 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZkSmqQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j91SAEApp0xgCKGnpn/xSdEH6DGO1MiPvCsHLQ4itVV
1b2jdfQA/Rou2O5x3MqR1ygm+q3ZWmPqeVpcM+7yTQ4HKGvWJY2f
=kcZx
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70957@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70957
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch