"python-pivy" build fails when "soqt" is in the inputs (see
* gnu/packages/python-xyz.scm (python-pivy): Fix build.
[inputs]: Remove "soqt".
[arguments]: Use gexps.
Change-Id: If332ccd42b3a373e7b4118f3bcbc3646e8b59d41
---
gnu/packages/python-xyz.scm | 25 ++++++++++++-------------
1 file changed, 12 insertions(+), 13 deletions(-)
Toggle diff (55 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b295d780ab..c48d52952b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -121,7 +121,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
-;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
@@ -32935,20 +32935,20 @@ (define-public python-pivy
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0vids7sxk8w5vr73xdnf8xdci71a7syl6cd35aiisppbqyyfmykx"))))
+ (base32 "0vids7sxk8w5vr73xdnf8xdci71a7syl6cd35aiisppbqyyfmykx"))))
(build-system python-build-system)
(arguments
- `(;; The test suite fails due to an import cycle between 'pivy' and '_coin'
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
+ (list
+ ;; The test suite fails due to an import cycle between 'pivy' and '_coin'
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
(add-after 'unpack 'patch-cmake-include-dirs
- (lambda _
- ;; Patch buildsystem to respect Coin3D include directory
- (substitute* "CMakeLists.txt"
- (("\\$\\{SoQt_INCLUDE_DIRS}")
- "${Coin_INCLUDE_DIR};${SoQt_INCLUDE_DIRS}"))
- #t)))))
+ (lambda _
+ ;; Patch buildsystem to respect Coin3D include directory
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{SoQt_INCLUDE_DIRS}")
+ "${Coin_INCLUDE_DIR};${SoQt_INCLUDE_DIRS}")))))))
(native-inputs
(list cmake swig))
(inputs
@@ -32956,7 +32956,6 @@ (define-public python-pivy
qtbase-5
libxi
libice
- soqt
glew
coin3d))
(home-page "https://github.com/coin3d/pivy")
--
2.41.0