[PATCH] gnu: julia-fixedpointnumbers: Update to 0.8.5.

  • Done
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 15 May 08:30 +0200
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
f409d4af39ff98d9aa6399e7bab6d39897066e37.1715754637.git.efraim@flashner.co.il
* gnu/packages/julia-xyz.scm (julia-fixedpointnumbers): Update to 0.8.5.
(julia-colortypes)[arguments]: Remove 'skip-failing-test phase.

Change-Id: I18cee60a90311af0a052e5d49e4f2b43b54e7e14
---
gnu/packages/julia-xyz.scm | 53 +++++++++++++++-----------------------
1 file changed, 21 insertions(+), 32 deletions(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index f8e3ac86cb..56a3c9772d 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1102,15 +1102,6 @@ (define-public julia-colortypes
(sha256
(base32 "0cp5wbi2bhnxp4h7wpzkx341d47744f4c9a8n0w0kn016qa16m86"))))
(build-system julia-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'skip-failing-test
- (lambda _
- (substitute* "test/conversions.jl"
- (("@test promote\\(RGB\\{N0f8")
- "@test_broken promote(RGB{N0f8")))))))
(propagated-inputs
(list julia-fixedpointnumbers))
(native-inputs
@@ -2337,35 +2328,33 @@ (define-public julia-fitsio
(license license:expat)))
(define-public julia-fixedpointnumbers
- (let ((commit "59ee94b93f2f1ee75544ef44187fc0e440cd8015")
- (revision "1"))
- (package
- (name "julia-fixedpointnumbers")
- (version (git-version "0.8.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaMath/FixedPointNumbers.jl")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1ghriy7p2fj7mwdx11ssjg28jmwz8pi13c3j8p1grvwb4nvc0jnq"))))
- (build-system julia-build-system)
- (arguments
- (list #:tests? #f)) ; Cycle with julia-documenter
- (propagated-inputs
- (list julia-compat))
- (home-page "https://github.com/JuliaMath/FixedPointNumbers.jl")
- (synopsis "Fixed point types for Julia")
- (description "@code{FixedPointNumbers.jl} implements fixed-point number
+ (package
+ (name "julia-fixedpointnumbers")
+ (version "0.8.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaMath/FixedPointNumbers.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cixh2acxscrgxglgbj2mlp2bk2yvqil1kjfvnp1xi0zp6px60f6"))))
+ (build-system julia-build-system)
+ (arguments
+ (list #:tests? #f)) ; Cycle with julia-documenter
+ (propagated-inputs
+ (list julia-compat))
+ (home-page "https://github.com/JuliaMath/FixedPointNumbers.jl")
+ (synopsis "Fixed point types for Julia")
+ (description "@code{FixedPointNumbers.jl} implements fixed-point number
types for Julia. A fixed-point number represents a fractional, or
non-integral, number. In contrast with the more widely known floating-point
numbers, with fixed-point numbers the decimal point doesn't \"float\":
fixed-point numbers are effectively integers that are interpreted as being
scaled by a constant factor. Consequently, they have a fixed number of
digits (bits) after the decimal (radix) point.")
- (license license:expat))))
+ (license license:expat)))
(define-public julia-formatting
(package

base-commit: 898b5f30f3d485d48275c920da172863da9524c6
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
E
E
Efraim Flashner wrote on 21 May 13:49 +0200
(address . 70956-done@debbugs.gnu.org)
ZkyKNjngf_7XbQQ-@3900XT
I tested locally that there were no new packages broken and I pushed the
patch.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmZMijEACgkQQarn3Mo9
g1En7BAAsbL0nhdDMLHt+54G6eRHPTEbEEphofBBIpcNY83m/XMbPXRwWSs2/S7a
RFF5A+ieT/0HTHSsmmK5kODIlGKYx+fD++Ptab3GnO1aneFtDNYzH3098gDEMkKm
dIWyqapGMpTMbZgffeXqIKw3sEjELREq+tPPwc+5ar6/ozLSL9Q3dtdy19oglC28
IQlgi6DooYgNZFe6gjgO8OZzE0eXHD1KRR/DzLz5kL48OmLdxbhMr6PjKx7BIf8V
Yr9gHQhNvlAENK+y2CwPE5NqdihGrKujUp5AAf5OylPudkR5koBQNYXQ6iJMKT8o
7Rv/4BKHkRwehnmQtn+cIL7L2nC6bwkOGkL8FzXXY5nEMs49YZanV+st2ibOmKE6
yUWzH4p0egIoVyXNYFu6nEl22NO745G1cj881djJYesHV7Ns3DQsKZJ9sKOwJyW0
skWGVGm+mLxhGc2sBm+3jE4Ci5TVd0zUzsxYWyYqRS8jaHlJHX0kS9Be6Ci4B+6d
o8KtHDFwUvan5z768xWfGimNuekc9A8eio/vGQKqW29bpOl32/PHsxXA8ep9QzkZ
U2xbV8lR0UeH6mDDY6A2IPuGkryFo6evX6NHHuyAn7OKK9Cjptd/ijlavsr4RmJU
5bMdCKQMsuBTjjw1mxg2EzWeQGB95yv3r3Pfbm2yJVdc7nJi6F0=
=lnfa
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70956@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70956
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch