[PATCH 0/6] gnu: Add go-github-com-pion-stun-v2 and go-github-com-pion-mdns.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 15 May 08:13 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1715753200.git.poptsov.artyom@gmail.com
This patchset adds STUN and mDNS implementation from Pion[1] project. The
patchset is related to [2] but can be applied independently.

References:

Artyom V. Poptsov (6):
gnu: Add go-github-com-pion-logging.
gnu: Add go-github-com-pion-transport-v3.
gnu: Add go-github-com-pion-transport-v2.
gnu: Add go-github-com-pion-mdns.
gnu: Add go-github-com-pion-dtls-v2.
gnu: Add go-github-com-pion-stun-v2.

gnu/packages/golang-xyz.scm | 167 ++++++++++++++++++++++++++++++++++++
1 file changed, 167 insertions(+)


base-commit: 898b5f30f3d485d48275c920da172863da9524c6
--
2.41.0
A
A
Artyom V. Poptsov wrote on 15 May 08:17 +0200
[PATCH 1/6] gnu: Add go-github-com-pion-logging.
(address . 70955@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
37d588ce30733b819c15ea39fe1f3863e80538a2.1715753200.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-logging): New variable.

Change-Id: I2da53900059251b78cad2bb56cfbc87228c91e23
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cd023da86c..4ed310e9ef 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2982,6 +2982,30 @@ (define-public go-github-com-pierrec-cmdflag
on top of the standard library @code{flag} package.")
(license license:bsd-3)))
+(define-public go-github-com-pion-logging
+ (package
+ (name "go-github-com-pion-logging")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/logging/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11ay8c15xk3pv7y9nd80szk3mci480x67yqlgb10vswrz4h4mx3v"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pion/logging"))
+ (home-page "https://github.com/pion/logging/")
+ (synopsis "Logging library used by @url{https://github.com/pion, Pion}")
+ (description
+ "he library is used as a part of @url{https://github.com/pion, Pion} WebRTC
+implementation.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 15 May 08:17 +0200
[PATCH 2/6] gnu: Add go-github-com-pion-transport-v3.
(address . 70955@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
191b5e32dd270afd3ec3440bd094372c7e0b85c9.1715753200.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-transport-v3): New variable.

Change-Id: I465da7f98a1f6c9d05c69fd5e3efd0a9de5a0b36
---
gnu/packages/golang-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4ed310e9ef..c70e62d6c7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3006,6 +3006,36 @@ (define-public go-github-com-pion-logging
implementation.")
(license license:expat)))
+(define-public go-github-com-pion-transport-v3
+ (package
+ (name "go-github-com-pion-transport")
+ (version "3.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/transport/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j7ljkbyf2qd7daxg7d1rd6c92md64agi59b69g6jyqpz5jww998"))))
+ (build-system go-build-system)
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-pion-logging
+ go-golang-org-x-net
+ go-golang-org-x-sys))
+ (arguments
+ (list
+ #:import-path "github.com/pion/transport/v3"))
+ (home-page "https://github.com/pion/transport/")
+ (synopsis "Logging library used by @url{https://github.com/pion, Pion}")
+ (description
+ "The library is used as a part of @url{https://github.com/pion, Pion} WebRTC
+implementation.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 15 May 08:17 +0200
[PATCH 3/6] gnu: Add go-github-com-pion-transport-v2.
(address . 70955@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
6c4e38391ec430acab9cc54713e91d3a8065ceb9.1715753200.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-transport-v2): New variable.

Change-Id: I5d79c066fd7c26121d3903efd02dff07f54cd670
---
gnu/packages/golang-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c70e62d6c7..192b4e7cf1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3036,6 +3036,24 @@ (define-public go-github-com-pion-transport-v3
implementation.")
(license license:expat)))
+(define-public go-github-com-pion-transport-v2
+ (package
+ (inherit go-github-com-pion-transport-v3)
+ (name "go-github-com-pion-transport")
+ (version "2.2.5")
+ (source
+ (origin
+ (inherit (package-source go-github-com-pion-transport-v3))
+ (uri (git-reference
+ (url "https://github.com/pion/transport/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00q3v37l56yr1ch25g5w70jy8y923csbvy4krvy4dv3h5f1mdpmf"))))
+ (arguments
+ (list
+ #:import-path "github.com/pion/transport/v2"))))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 15 May 08:17 +0200
[PATCH 4/6] gnu: Add go-github-com-pion-mdns.
(address . 70955@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
a1c33ddb31fe9f3bb96fa100fdec59d7caebbe7a.1715753200.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-mdns): New variable.

Change-Id: Ic141fbaa01b40e60b443a672b5e54d315a114fff
---
gnu/packages/golang-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 192b4e7cf1..ca9e88547e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3054,6 +3054,36 @@ (define-public go-github-com-pion-transport-v2
(list
#:import-path "github.com/pion/transport/v2"))))
+(define-public go-github-com-pion-mdns
+ (package
+ (name "go-github-com-pion-mdns")
+ (version "2.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/mdns/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03675hx82lx3c8akkxdbkch1z4dbq54r05jk6jgdyd7mrdh9k4lm"))))
+ (build-system go-build-system)
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-github-com-pion-logging
+ go-github-com-pion-transport-v3
+ go-golang-org-x-net))
+ (arguments
+ (list
+ #:go go-1.21
+ #:tests? #f ;Tests require network access.
+ #:import-path "github.com/pion/mdns"))
+ (home-page "https://github.com/pion/mdns/")
+ (synopsis "Pure Go implementation of Multicast DNS")
+ (description
+ "Pure Go implementation of Multicast DNS for @url{https://github.com/pion, Pion}
+WebRTC.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 15 May 08:17 +0200
[PATCH 6/6] gnu: Add go-github-com-pion-stun-v2.
(address . 70955@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
f018b66ff1f5397b1aabae1b4df652df021f9c24.1715753200.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-stun-v2): New variable.

Change-Id: I5d83caa918203c651909af667e004ab6df06498a
---
gnu/packages/golang-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b91a28c436..5f4c7c5b95 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3114,6 +3114,41 @@ (define-public go-github-com-pion-dtls-v2
implementation in the Go programming language.")
(license license:expat)))
+(define-public go-github-com-pion-stun-v2
+ (package
+ (name "go-github-com-pion-stun")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/stun/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zli55ls5izpr6cw0wj0gy44872xn9rk20i8ay9cfk7j2rb60y60"))))
+ (build-system go-build-system)
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-github-com-pion-dtls-v2
+ go-github-com-pion-logging
+ go-github-com-pion-transport-v3
+ go-golang-org-x-crypto
+ go-golang-org-x-net))
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/pion/stun/v2"))
+ (home-page "https://github.com/pion/stun/")
+ (synopsis "Go implementation of STUN")
+ (description
+ "Package @code{stun} implements Session Traversal Utilities for
+NAT (STUN) (@url{https://tools.ietf.org/html/rfc5389, RFC 5389}) protocol and
+@url{https://pkg.go.dev/github.com/pion/stun#Client, client} with no external
+dependencies and zero allocations in hot paths. Client
+@url{https://pkg.go.dev/github.com/pion/stun#WithRTO, supports} automatic
+request retransmissions.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")
--
2.41.0
A
A
Artyom V. Poptsov wrote on 15 May 08:17 +0200
[PATCH 5/6] gnu: Add go-github-com-pion-dtls-v2.
(address . 70955@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
caf5c6162a9046b23dc4f5a6a360d8f1bebe1f37.1715753200.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-pion-dtls-v2): New variable.

Change-Id: Ia3e77cda47fcb5a17a6cb7a82cd43f2beb8de1e9
---
gnu/packages/golang-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ca9e88547e..b91a28c436 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3084,6 +3084,36 @@ (define-public go-github-com-pion-mdns
WebRTC.")
(license license:expat)))
+(define-public go-github-com-pion-dtls-v2
+ (package
+ (name "go-github-com-pion-dtls")
+ (version "2.2.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/dtls/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10nn9349f7snqkzncda5m013fgnzicrcxi6pb6ghc0vb6rhqkf30"))))
+ (build-system go-build-system)
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-github-com-pion-logging
+ go-github-com-pion-transport-v3
+ go-github-com-pion-transport-v2
+ go-golang-org-x-crypto go-golang-org-x-net))
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/pion/dtls/v2"))
+ (home-page "https://github.com/pion/dtls/")
+ (synopsis "DTLS 1.2 Server/Client implementation for Go")
+ (description
+ "Native @url{https://datatracker.ietf.org/doc/html/rfc6347, DTLS 1.2}
+implementation in the Go programming language.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 17 May 00:31 +0200
[PATCH 0/6] gnu: Add go-github-com-pion-stun-v2 and go-github-com-pion-mdns.
(address . 70955-done@debbugs.gnu.org)
87ikzd8k3l.fsf@gmail.com
Hi,

I've applied some modifications and pushed as 26b324d082..08f391af78 to
master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmZGiT4ACgkQdtcnv/Ys
0rVxdg//XRiNZXVpxBiIDDAHXuIx4TpungvMVG5l9MghdWCq3O86oTTZ5ja+0tcV
C1VU4skD02nI+qZfoL2xFKsmotmO20imf9W1fnlNqOVRvHJvmI+4mRANIbgIN+7p
wzXzpt2mCmmZavLUpZtlI763BfcKG72pYX0RH3mLkITkDu30V2LUYyQreLBwMM5Q
aAWQ3uAdDBuJEnokLdWNYIKKQDRbaVUmr1hVCL0FxZw55WAKIF5MTyWtrISjI3k9
ND+R1GSRuVHcawe9zhJP34G7gM6nTKbBOgvamdKvZj8P9nTLjzNjF8k3mwy1JnDw
93o8CYhznioij4ebodJoOdgpGK1vxI8E+yRa/JejFbSJkk3205Kc7Rh5ZmnuTSJa
0vWWpttsPtWMOqsXYm5DY6RUDyc+yEzczbx9dICe2QU3au1KkEXxWxNRN6Edk8vo
uvw2c/kOE06blFZvfX+V1h6TxS0sZfvRbSHwLUGj2dLFR5GeSgrfhgeDtiUeXuTS
TZEyRZV7MWYOYRe6Aa6tyEQuBXWeX4XpwafB3QdOZsuJb11wDaPXNywU92SpOXVw
IQlDm/0Rnx7DrzIV5UVco0RviwSYhqfGkNupdcfjOTO/3H7OWnribUahPIJ7fST2
p/IIc4EYseQpI0HXZ8JWuwqHkARcysMb9SJ13eQag3WXUX97AzQ=
=2kQR
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70955@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70955
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch