[PATCH 0/3] gnu: qgis: Update to 3.34.6.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Blocked by
N
N
Nicolas Graves wrote on 14 May 21:58 +0200
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20240514195926.21459-1-ngraves@ngraves.fr
This patch series updates qgis to last LTS version 3.34.6.
It depends on 70319 v2.

Nicolas Graves (3):
gnu: qgis: Improve package style.
gnu: qgis: Improve package style.
gnu: qgis: Update to 3.34.6.

gnu/packages/geo.scm | 400 ++++++++++++++++++++++++-------------------
1 file changed, 228 insertions(+), 172 deletions(-)

--
2.41.0
N
N
Nicolas Graves wrote on 14 May 22:01 +0200
[PATCH 1/3] gnu: qgis: Improve package style.
(address . 70952@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240514200303.28321-1-ngraves@ngraves.fr
* gnu/packages/geo.scm (qgis)[arguments]: Use gexp.

Change-Id: Ib72ae48ca0895109548e676c6da2d80ac2e1eca6
---
gnu/packages/geo.scm | 57 +++++++++++++++++++-------------------------
1 file changed, 25 insertions(+), 32 deletions(-)

Toggle diff (103 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 7da0a7d7ef5..745239cf664 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2910,17 +2910,25 @@ (define-public qgis
(base32 "0mdgqyqr3nswp5qfpjrpr35lxizcrz73a1gs3ddxsd1xr9amzb5s"))))
(build-system cmake-build-system)
(arguments
- `(#:modules ((guix build cmake-build-system)
+ (list
+ #:modules '((guix build cmake-build-system)
((guix build python-build-system) #:prefix python:)
(guix build qt-utils)
(guix build utils))
- #:imported-modules (,@%cmake-build-system-modules
+ #:imported-modules `(,@%cmake-build-system-modules
(guix build python-build-system)
(guix build qt-utils))
- #:configure-flags
- '("-DWITH_QTWEBKIT=NO")
- #:phases
- (modify-phases %standard-phases
+ #:configure-flags
+ #~(list "-DWITH_QTWEBKIT=NO")
+ #:phases
+ #~(let* ((grass-version #$(package-version (this-package-input "grass")))
+ (grass-majorminor (string-join
+ (list-head
+ (string-split grass-version #\.) 2)
+ ""))
+ (grass-dir (string-append #$(this-package-input "grass")
+ "/grass" grass-majorminor)))
+ (modify-phases %standard-phases
;; Configure correct path to PyQt5 SIP directory
(add-after 'unpack 'configure-pyqt5-sip-path
(lambda* (#:key inputs #:allow-other-keys)
@@ -2942,21 +2950,14 @@ (define-public qgis
(replace 'check
(lambda* (#:key inputs outputs tests? parallel-tests?
#:allow-other-keys)
- (when tests?
+ (if tests?
+ (begin
(setenv "HOME" "/tmp")
(system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
(setenv "TRAVIS" "true")
(setenv "CTEST_OUTPUT_ON_FAILURE" "1")
- (let* ((out (assoc-ref outputs "out"))
- (grass-version ,(package-version grass))
- (grass-majorminor (string-join
- (list-head
- (string-split grass-version #\.) 2)
- ""))
- (grass (string-append (assoc-ref inputs "grass")
- "/grass" grass-majorminor)))
- (setenv "GISBASE" grass))
+ (setenv "GISBASE" grass-dir)
(invoke "ctest"
"-j" (if parallel-tests?
(number->string (parallel-job-count))
@@ -3047,31 +3048,23 @@ (define-public qgis
"qgis_sipify"
"qgis_sip_include"
"qgis_sip_uptodate")
- "|")))))
+ "|")))
+ (format #t "test suite not run~%"))))
(add-after 'install 'wrap-python
(assoc-ref python:%standard-phases 'wrap))
(add-after 'wrap-python 'wrap-qt
(lambda* (#:key outputs inputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program "qgis" #:output out #:inputs inputs))))
+ (wrap-qt-program "qgis" #:output #$output #:inputs inputs)))
(add-after 'wrap-qt 'wrap-gis
(lambda* (#:key inputs outputs #:allow-other-keys)
;; TODO: Find if there is a way to get SAGA to work.
;; Currently QGIS says "version of SAGA not supported".
;; Disable it for now.
- (let* ((out (assoc-ref outputs "out"))
- ;;(saga (string-append (assoc-ref inputs "saga") "/bin"))
- (grass-version ,(package-version grass))
- (grass-majorminor (string-join
- (list-head
- (string-split grass-version #\.) 2)
- ""))
- (grass (string-append (assoc-ref inputs "grass")
- "/grass" grass-majorminor)))
- (wrap-program (string-append out "/bin/qgis")
- ;;`("PATH" ":" prefix (,saga))
- `("QGIS_PREFIX_PATH" = (,out))
- `("GISBASE" = (,grass)))))))))
+ (wrap-program (string-append #$output "/bin/qgis")
+ ;; `("PATH" ":" prefix
+ ;; (,(dirname (search-input-file inputs "/bin/saga_cmd"))))
+ `("QGIS_PREFIX_PATH" = (,#$output))
+ `("GISBASE" = (,grass-dir)))))))))
(inputs
(list bash-minimal
exiv2
--
2.41.0
N
N
Nicolas Graves wrote on 14 May 22:01 +0200
[PATCH 2/3] gnu: qgis: Improve package style.
(address . 70952@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240514200303.28321-2-ngraves@ngraves.fr
* gnu/packages/geo.scm (qgis)[arguments]<#:phases>: Extract
ignored-tests to make them more readable. Re-indent.

Change-Id: I2373bba49b9d21ff7dfa0014cf34fafa0e1f3175
---
gnu/packages/geo.scm | 301 ++++++++++++++++++++++---------------------
1 file changed, 151 insertions(+), 150 deletions(-)

Toggle diff (328 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 745239cf664..88f92631092 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2921,7 +2921,93 @@ (define-public qgis
#:configure-flags
#~(list "-DWITH_QTWEBKIT=NO")
#:phases
- #~(let* ((grass-version #$(package-version (this-package-input "grass")))
+ #~(let* ((ignored-tests (list
+ ;; Disable tests that require network access
+ "PyQgsExternalStorageAwsS3"
+ "PyQgsExternalStorageWebDav"
+ "qgis_filedownloader"
+ "test_core_networkaccessmanager"
+ "test_core_tiledownloadmanager"
+ "test_gui_filedownloader"
+ "test_provider_wcsprovider"
+ ;; Disable tests that need OGR built with
+ ;; libspatialite support
+ "PyQgsAttributeTableModel"
+ "PyQgsOGRProviderSqlite"
+ "PyQgsWFSProvider"
+ "PyQgsOapifProvider"
+ ;; Disable tests that need Python compiled
+ ;; with loadable SQLite extensions.
+ "PyQgsFieldFormattersTest"
+ "PyQgsSpatialiteProvider"
+ "PyQgsLayerDependencies"
+ "PyQgsDBManagerGpkg"
+ "PyQgsDBManagerSpatialite"
+ ;; Disable tests that need poppler (with Cairo)
+ "PyQgsLayoutExporter"
+ "PyQgsPalLabelingLayout"
+ ;; Disable tests that need Orfeo ToolBox
+ "ProcessingOtbAlgorithmsTest"
+ ;; TODO: Find why the following tests fail
+ "ProcessingQgisAlgorithmsTestPt1"
+ "ProcessingQgisAlgorithmsTestPt3"
+ "ProcessingQgisAlgorithmsTestPt4"
+ "ProcessingGdalAlgorithmsRasterTest"
+ "ProcessingGdalAlgorithmsVectorTest"
+ "ProcessingGrass7AlgorithmsImageryTest"
+ "ProcessingGrass7AlgorithmsRasterTestPt1"
+ "ProcessingGrass7AlgorithmsRasterTestPt2"
+ "ProcessingGrass7AlgorithmsVectorTest"
+ "test_core_authconfig"
+ "test_core_authmanager"
+ "test_core_compositionconverter"
+ "test_core_expression"
+ "test_core_gdalutils"
+ "test_core_labelingengine"
+ "test_core_layoutpicture"
+ "test_core_layouttable"
+ "test_core_pointcloudlayerexporter"
+ "test_core_projectstorage"
+ "test_core_coordinatereferencesystem"
+ "test_core_overlayexpression"
+ "test_gui_queryresultwidget"
+ "test_provider_copcprovider"
+ "test_provider_eptprovider"
+ "test_analysis_processingalgspt1"
+ "test_analysis_processingalgspt2"
+ "test_analysis_processing"
+ "test_app_gpsintegration"
+ "PyQgsAnnotation"
+ "PyQgsAuthenticationSystem"
+ "PyQgsConnectionRegistry"
+ "PyQgsDatumTransform"
+ "PyQgsFileUtils"
+ "PyQgsGeometryTest"
+ "PyQgsGoogleMapsGeocoder"
+ "PyQgsGroupLayer"
+ "PyQgsHashLineSymbolLayer"
+ "PyQgsLayerMetadataProviderPython"
+ "PyQgsLayoutHtml"
+ "PyQgsLineSymbolLayers"
+ "PyQgsMapLayer"
+ "PyQgsOGRProviderGpkg"
+ "PyQgsProcessExecutablePt1"
+ "PyQgsProcessExecutablePt2"
+ "PyQgsProjectionSelectionWidgets"
+ "PyQgsProviderConnectionGpkg"
+ "PyQgsProviderConnectionSpatialite"
+ "PyQgsOGRProvider"
+ "PyQgsSettingsTreeNode"
+ "PyQgsTextRenderer"
+ "PyQgsVectorFileWriter"
+ "PyQgsVectorLayerEditBuffer"
+ "PyQgsVirtualLayerProvider"
+ "PyQgsAuxiliaryStorage"
+ "PyQgsSelectiveMasking"
+ "qgis_sipify"
+ "qgis_sip_include"
+ "qgis_sip_uptodate"))
+ (grass-version #$(package-version (this-package-input "grass")))
(grass-majorminor (string-join
(list-head
(string-split grass-version #\.) 2)
@@ -2929,142 +3015,57 @@ (define-public qgis
(grass-dir (string-append #$(this-package-input "grass")
"/grass" grass-majorminor)))
(modify-phases %standard-phases
- ;; Configure correct path to PyQt5 SIP directory
- (add-after 'unpack 'configure-pyqt5-sip-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((sip-dir (string-append
- (assoc-ref inputs "python-pyqt+qscintilla")
- "/lib/python"
- (python:python-version (assoc-ref inputs "python"))
- "/site-packages/PyQt5/bindings")))
- (substitute* "cmake/FindPyQt5.py"
- (("sip_dir = cfg.default_sip_dir")
- (string-append "sip_dir = \"" sip-dir "\"")))
- (substitute* "cmake/FindPyQt5.cmake"
- (("SET\\(PYQT5_SIP_DIR \"\\$\\{Python_SITEARCH\\}/PyQt5/bindings\"\\)")
- (string-append "SET(PYQT5_SIP_DIR \"" sip-dir "\")"))))
- (substitute* (list "tests/code_layout/test_qt_imports.sh"
- "tests/code_layout/test_qgsscrollarea.sh")
- (("\\$\\(git rev-parse --show-toplevel\\)")
- (getcwd)))))
- (replace 'check
- (lambda* (#:key inputs outputs tests? parallel-tests?
- #:allow-other-keys)
- (if tests?
- (begin
- (setenv "HOME" "/tmp")
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
- (setenv "TRAVIS" "true")
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
- (setenv "GISBASE" grass-dir)
- (invoke "ctest"
- "-j" (if parallel-tests?
- (number->string (parallel-job-count))
- "1")
- "-E" (string-join
- '(;; Disable tests that require network access
- "PyQgsExternalStorageAwsS3"
- "PyQgsExternalStorageWebDav"
- "qgis_filedownloader"
- "test_core_networkaccessmanager"
- "test_core_tiledownloadmanager"
- "test_gui_filedownloader"
- "test_provider_wcsprovider"
- ;; Disable tests that need OGR built with
- ;; libspatialite support
- "PyQgsAttributeTableModel"
- "PyQgsOGRProviderSqlite"
- "PyQgsWFSProvider"
- "PyQgsOapifProvider"
- ;; Disable tests that need Python compiled
- ;; with loadable SQLite extensions.
- "PyQgsFieldFormattersTest"
- "PyQgsSpatialiteProvider"
- "PyQgsLayerDependencies"
- "PyQgsDBManagerGpkg"
- "PyQgsDBManagerSpatialite"
- ;; Disable tests that need poppler (with Cairo)
- "PyQgsLayoutExporter"
- "PyQgsPalLabelingLayout"
- ;; Disable tests that need Orfeo ToolBox
- "ProcessingOtbAlgorithmsTest"
- ;; TODO: Find why the following tests fail
- "ProcessingQgisAlgorithmsTestPt1"
- "ProcessingQgisAlgorithmsTestPt3"
- "ProcessingQgisAlgorithmsTestPt4"
- "ProcessingGdalAlgorithmsRasterTest"
- "ProcessingGdalAlgorithmsVectorTest"
- "ProcessingGrass7AlgorithmsImageryTest"
- "ProcessingGrass7AlgorithmsRasterTestPt1"
- "ProcessingGrass7AlgorithmsRasterTestPt2"
- "ProcessingGrass7AlgorithmsVectorTest"
- "test_core_authconfig"
- "test_core_authmanager"
- "test_core_compositionconverter"
- "test_core_expression"
- "test_core_gdalutils"
- "test_core_labelingengine"
- "test_core_layoutpicture"
- "test_core_layouttable"
- "test_core_pointcloudlayerexporter"
- "test_core_projectstorage"
- "test_core_coordinatereferencesystem"
- "test_core_overlayexpression"
- "test_gui_queryresultwidget"
- "test_provider_copcprovider"
- "test_provider_eptprovider"
- "test_analysis_processingalgspt1"
- "test_analysis_processingalgspt2"
- "test_analysis_processing"
- "test_app_gpsintegration"
- "PyQgsAnnotation"
- "PyQgsAuthenticationSystem"
- "PyQgsConnectionRegistry"
- "PyQgsDatumTransform"
- "PyQgsFileUtils"
- "PyQgsGeometryTest"
- "PyQgsGoogleMapsGeocoder"
- "PyQgsGroupLayer"
- "PyQgsHashLineSymbolLayer"
- "PyQgsLayerMetadataProviderPython"
- "PyQgsLayoutHtml"
- "PyQgsLineSymbolLayers"
- "PyQgsMapLayer"
- "PyQgsOGRProviderGpkg"
- "PyQgsProcessExecutablePt1"
- "PyQgsProcessExecutablePt2"
- "PyQgsProjectionSelectionWidgets"
- "PyQgsProviderConnectionGpkg"
- "PyQgsProviderConnectionSpatialite"
- "PyQgsOGRProvider"
- "PyQgsSettingsTreeNode"
- "PyQgsTextRenderer"
- "PyQgsVectorFileWriter"
- "PyQgsVectorLayerEditBuffer"
- "PyQgsVirtualLayerProvider"
- "PyQgsAuxiliaryStorage"
- "PyQgsSelectiveMasking"
- "qgis_sipify"
- "qgis_sip_include"
- "qgis_sip_uptodate")
- "|")))
- (format #t "test suite not run~%"))))
- (add-after 'install 'wrap-python
- (assoc-ref python:%standard-phases 'wrap))
- (add-after 'wrap-python 'wrap-qt
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (wrap-qt-program "qgis" #:output #$output #:inputs inputs)))
- (add-after 'wrap-qt 'wrap-gis
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; TODO: Find if there is a way to get SAGA to work.
- ;; Currently QGIS says "version of SAGA not supported".
- ;; Disable it for now.
- (wrap-program (string-append #$output "/bin/qgis")
- ;; `("PATH" ":" prefix
- ;; (,(dirname (search-input-file inputs "/bin/saga_cmd"))))
- `("QGIS_PREFIX_PATH" = (,#$output))
- `("GISBASE" = (,grass-dir)))))))))
+ ;; Configure correct path to PyQt5 SIP directory
+ (add-after 'unpack 'configure-pyqt5-sip-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((sip-dir (string-append
+ (assoc-ref inputs "python-pyqt+qscintilla")
+ "/lib/python"
+ (python:python-version (assoc-ref inputs "python"))
+ "/site-packages/PyQt5/bindings")))
+ (substitute* "cmake/FindPyQt5.py"
+ (("sip_dir = cfg.default_sip_dir")
+ (string-append "sip_dir = \"" sip-dir "\"")))
+ (substitute* "cmake/FindPyQt5.cmake"
+ (("\
+SET\\(PYQT5_SIP_DIR \"\\$\\{Python_SITEARCH\\}/PyQt5/bindings\"\\)")
+ (string-append "SET(PYQT5_SIP_DIR \"" sip-dir "\")"))))
+ (substitute* (list "tests/code_layout/test_qt_imports.sh"
+ "tests/code_layout/test_qgsscrollarea.sh")
+ (("\\$\\(git rev-parse --show-toplevel\\)")
+ (getcwd)))))
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? parallel-tests?
+ #:allow-other-keys)
+ (if tests?
+ (begin
+ (setenv "HOME" "/tmp")
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (setenv "TRAVIS" "true")
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
+ (setenv "GISBASE" grass-dir)
+ (invoke "ctest"
+ "-j" (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")
+ "-E" (string-join ignored-tests "|")))
+ (format #t "test suite not run~%"))))
+ (add-after 'install 'wrap-python
+ (assoc-ref python:%standard-phases 'wrap))
+ (add-after 'wrap-python 'wrap-qt
+ (lambda* (#:key inputs #:allow-other-keys)
+ (wrap-qt-program "qgis" #:output #$output #:inputs inputs)))
+ (add-after 'wrap-qt 'wrap-gis
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; TODO: Find if there is a way to get SAGA to work.
+ ;; Currently QGIS says "version of SAGA not supported".
+ ;; Disable it for now.
+ (wrap-program (string-append #$output "/bin/qgis")
+ ;; `("PATH" ":" prefix
+ ;; (,(dirname (search-input-file inputs "/bin/saga_cmd"))))
+ `("QGIS_PREFIX_PATH" = (,#$output))
+ `("GISBASE" = (,grass-dir)))))))))
(inputs
(list bash-minimal
exiv2
@@ -3114,19 +3115,19 @@ (define-public qgis
(list zstd "lib")))
(native-inputs
(append
- (list bison
- flex
- perl
- perl-yaml-tiny
- pkg-config
- python-mock
- python-nose2
- python-pyqt-builder
- qttools-5)
- (if (supported-package? shellcheck)
- (list shellcheck)
- '())
- (list xorg-server-for-tests)))
+ (list bison
+ flex
+ perl
+ perl-yaml-tiny
+ pkg-config
+ python-mock
+ python-nose2
+ python-pyqt-builder
+ qttools-5)
+ (if (supported-package? shellcheck)
+ (list shellcheck)
+ '())
+ (list xorg-server-for-tests)))
(home-page "https://qgis.org")
(synopsis "Geographical information system")
(description "QGIS is an easy to use Geographical Information
--
2.41.0
N
N
Nicolas Graves wrote on 14 May 22:01 +0200
[PATCH 3/3] gnu: qgis: Update to 3.34.6.
(address . 70952@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240514200303.28321-3-ngraves@ngraves.fr
* gnu/packages/geo.scm (qgis): Update to 3.34.6.
[arguments]<#:phases>: Update failing tests list.
[inputs]: Add draco, freexl, librttopo, minizip, pdal, qt3d-5.

Change-Id: If453a6c7451a63ab7b03f3cd0f36aef844acfb15
---
gnu/packages/geo.scm | 90 +++++++++++++++++++++++++++++++++++++-------
1 file changed, 76 insertions(+), 14 deletions(-)

Toggle diff (185 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 88f92631092..134174470f0 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2900,14 +2900,14 @@ (define-public saga
(define-public qgis
(package
(name "qgis")
- (version "3.30.1")
+ (version "3.34.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://qgis.org/downloads/qgis-"
version ".tar.bz2"))
(sha256
- (base32 "0mdgqyqr3nswp5qfpjrpr35lxizcrz73a1gs3ddxsd1xr9amzb5s"))))
+ (base32 "1zqyyrbv53vrrh372g503qh8kmy2dlsxcck28khhkh2262m5qfap"))))
(build-system cmake-build-system)
(arguments
(list
@@ -2925,7 +2925,6 @@ (define-public qgis
;; Disable tests that require network access
"PyQgsExternalStorageAwsS3"
"PyQgsExternalStorageWebDav"
- "qgis_filedownloader"
"test_core_networkaccessmanager"
"test_core_tiledownloadmanager"
"test_gui_filedownloader"
@@ -2950,9 +2949,9 @@ (define-public qgis
"ProcessingOtbAlgorithmsTest"
;; TODO: Find why the following tests fail
"ProcessingQgisAlgorithmsTestPt1"
+ "ProcessingQgisAlgorithmsTestPt2"
"ProcessingQgisAlgorithmsTestPt3"
"ProcessingQgisAlgorithmsTestPt4"
- "ProcessingGdalAlgorithmsRasterTest"
"ProcessingGdalAlgorithmsVectorTest"
"ProcessingGrass7AlgorithmsImageryTest"
"ProcessingGrass7AlgorithmsRasterTestPt1"
@@ -2965,28 +2964,27 @@ (define-public qgis
"test_core_gdalutils"
"test_core_labelingengine"
"test_core_layoutpicture"
- "test_core_layouttable"
- "test_core_pointcloudlayerexporter"
- "test_core_projectstorage"
+ "test_core_project"
"test_core_coordinatereferencesystem"
"test_core_overlayexpression"
"test_gui_queryresultwidget"
- "test_provider_copcprovider"
"test_provider_eptprovider"
- "test_analysis_processingalgspt1"
"test_analysis_processingalgspt2"
+ "test_analysis_processingpdalalgs"
"test_analysis_processing"
"test_app_gpsintegration"
+ "test_3d_mesh3drendering"
"PyQgsAnnotation"
+ "PyQgsAnnotationLayer"
+ "PyQgsAnnotationLineItem"
+ "PyQgsAnnotationLineTextItem"
+ "PyQgsAnnotationPolygonItem"
"PyQgsAuthenticationSystem"
- "PyQgsConnectionRegistry"
"PyQgsDatumTransform"
"PyQgsFileUtils"
"PyQgsGeometryTest"
"PyQgsGoogleMapsGeocoder"
- "PyQgsGroupLayer"
"PyQgsHashLineSymbolLayer"
- "PyQgsLayerMetadataProviderPython"
"PyQgsLayoutHtml"
"PyQgsLineSymbolLayers"
"PyQgsMapLayer"
@@ -2997,13 +2995,71 @@ (define-public qgis
"PyQgsProviderConnectionGpkg"
"PyQgsProviderConnectionSpatialite"
"PyQgsOGRProvider"
- "PyQgsSettingsTreeNode"
"PyQgsTextRenderer"
"PyQgsVectorFileWriter"
- "PyQgsVectorLayerEditBuffer"
"PyQgsVirtualLayerProvider"
"PyQgsAuxiliaryStorage"
"PyQgsSelectiveMasking"
+ "PyPythonRepr"
+ "PyQgsAnimatedMarkerSymbolLayer"
+ "PyQgsPythonProvider"
+ "PyQgsCategorizedSymbolRenderer"
+ "PyQgsColorRampLegendNode"
+ "PyQgsEmbeddedSymbolRenderer"
+ "PyQgsFillSymbolLayers"
+ "PyQgsGeometryGeneratorSymbolLayer"
+ "PyQgsGpsLogger"
+ "PyQgsGraduatedSymbolRenderer"
+ "PyQgsHighlight"
+ "PyQgsInterpolatedLineSymbolLayer"
+ "PyQgsJsonUtils"
+ "PyQgsLayerTreeView"
+ "PyQgsLayoutAtlas"
+ "PyQgsLayoutElevationProfile"
+ "PyQgsLayoutPageCollection"
+ "PyQgsLayoutItem"
+ "PyQgsLayoutLegend"
+ "PyQgsLayoutMap"
+ "PyQgsLayoutPage"
+ "PyQgsLineburstSymbolLayer"
+ "PyQgsMapCanvas"
+ "PyQgsMapCanvasAnnotationItem"
+ "PyQgsMapHitTest"
+ "PyQgsMarkerLineSymbolLayer"
+ "PyQgsMergedFeatureRenderer"
+ "PyQgsMeshLayerProfileGenerator"
+ "PyQgsPalLabelingPlacement"
+ "PyQgsPointCloudAttributeByRampRenderer"
+ "PyQgsPointCloudExtentRenderer"
+ "PyQgsPointCloudLayerProfileGenerator"
+ "PyQgsPointClusterRenderer"
+ "PyQgsPointDisplacementRenderer"
+ "PyQgsProfileExporter"
+ "PyQgsProfileRequest"
+ "TestQgsRandomMarkerSymbolLayer"
+ "PyQgsRasterAttributeTable"
+ "PyQgsRasterFileWriterTask"
+ "PyQgsRasterLayer"
+ "PyQgsRasterLayerProfileGenerator"
+ "PyQgsRasterColorRampShader"
+ "PyQgsRasterLineSymbolLayer"
+ "PyQgsRasterPipe"
+ "PyQgsSingleSymbolRenderer"
+ "PyQgsSimpleFillSymbolLayer"
+ "PyQgsSimpleLineSymbolLayer"
+ "PyQgsSymbolLayer"
+ "PyQgsRasterRendererCreateSld"
+ "PyQgsSymbolLayerCreateSld"
+ "PyQgsArrowSymbolLayer"
+ "PyQgsSymbolExpressionVariables"
+ "PyQgsStyleModel"
+ "PyQgsSymbol"
+ "PyQgsSymbolLayerUtils"
+ "PyQgsTextFormatWidget"
+ "PyQgsVectorFieldMarkerSymbolLayer"
+ "PyQgsVectorLayer"
+ "PyQgsVectorLayerProfileGenerator"
+ "PyQgsVectorLayerRenderer"
"qgis_sipify"
"qgis_sip_include"
"qgis_sip_uptodate"))
@@ -3068,19 +3124,24 @@ (define-public qgis
`("GISBASE" = (,grass-dir)))))))))
(inputs
(list bash-minimal
+ draco
exiv2
expat
+ freexl
gdal
geos
gpsbabel
grass
gsl
hdf5
+ librttopo
libspatialindex
libspatialite
libxml2
libzip
+ minizip
netcdf
+ pdal
postgresql
proj
protobuf
@@ -3102,6 +3163,7 @@ (define-public qgis
python-urllib3
qca
qscintilla
+ qt3d-5
qtbase-5
qtdeclarative-5
qtkeychain
--
2.41.0
N
N
Nicolas Graves wrote on 14 May 22:02 +0200
control message for bug #70952
(address . control@debbugs.gnu.org)
87a5ksp3f6.fsf@ngraves.fr
block 70952 by 70319
quit


--
Best regards,
Nicolas Graves
G
G
Guillaume Le Vaillant wrote on 15 May 13:46 +0200
Re: [bug#70952] [PATCH 0/3] gnu: qgis: Update to 3.34.6.
(name . Nicolas Graves)(address . ngraves@ngraves.fr)(address . 70952-done@debbugs.gnu.org)
87r0e3l2mb.fsf@kitej
Patches applied as dcc278885c9d04809008e3053c4ca40760033f55 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZkSgfA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/oQAD/fju8FpoRI55YWoij9Yy01h5D2uOxzhItMXSE
ZEpaFNEA/0hO5JxVqEmiUywZJ1E8PBIiF/JdiCggHh7vrD61NH3H
=fKkg
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70952@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70952
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch