[PATCH] gnu: nss/fixed: Hasten test suite.

  • Done
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 14 May 20:00 +0200
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
0ab1aab81012b5250332ae018e9d25381e7c6d79.1715709627.git.maxim.cournoyer@gmail.com
This causes the test suite to run in about in nearly a third of the original
time (from 145 min to 52 minutes on a particular machine).

* gnu/packages/nss.scm (nss/fixed) [phases] {check}: Set NSS_CYCLES
environment variable to 'standard'.

Change-Id: I5dab1ed16b302af2276b0f075a790f6193edbe95
---

gnu/packages/nss.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 80bf627583..8fb8a2fc99 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -288,6 +288,11 @@ (define-public nss/fixed
(substitute* "nss/tests/dbtests/dbtests.sh"
((" -lt 5") " -lt 50"))
+ ;; Since the test suite is very lengthy, run the test
+ ;; suite once, not thrice as done by default, by
+ ;; selecting only the 'standard' cycle.
+ (setenv "NSS_CYCLES" "standard")
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To

base-commit: 898b5f30f3d485d48275c920da172863da9524c6
--
2.41.0
M
M
Maxim Cournoyer wrote on 15 May 18:40 +0200
(address . 70950@debbugs.gnu.org)(name . Christina O' Donnell)(address . cdo@mutix.org)
87msorxc46.fsf@gmail.com
Hi,

+CC Christina, who has done some work with NSS recently.

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (31 lines)
> This causes the test suite to run in about in nearly a third of the original
> time (from 145 min to 52 minutes on a particular machine).
>
> * gnu/packages/nss.scm (nss/fixed) [phases] {check}: Set NSS_CYCLES
> environment variable to 'standard'.
>
> Change-Id: I5dab1ed16b302af2276b0f075a790f6193edbe95
> ---
>
> gnu/packages/nss.scm | 5 +++++
> 1 file changed, 5 insertions(+)
>
> diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
> index 80bf627583..8fb8a2fc99 100644
> --- a/gnu/packages/nss.scm
> +++ b/gnu/packages/nss.scm
> @@ -288,6 +288,11 @@ (define-public nss/fixed
> (substitute* "nss/tests/dbtests/dbtests.sh"
> ((" -lt 5") " -lt 50"))
>
> + ;; Since the test suite is very lengthy, run the test
> + ;; suite once, not thrice as done by default, by
> + ;; selecting only the 'standard' cycle.
> + (setenv "NSS_CYCLES" "standard")
> +
> ;; The "PayPalEE.cert" certificate expires every six months,
> ;; leading to test failures:
> ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
>
> base-commit: 898b5f30f3d485d48275c920da172863da9524c6

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 22 May 18:09 +0200
[PATCH v2] gnu: nss/fixed: Hasten test suite.
(address . 70950@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
069d9c1216195e1c4a6dbe2f826d1893bc3dce9a.1716394161.git.maxim.cournoyer@gmail.com
This causes the test suite to run in about in nearly a third of the original
time (from 145 min to 52 minutes on a particular machine).

* gnu/packages/nss.scm (nss/fixed) [phases] {check}: Set NSS_CYCLES
environment variable to 'standard'.

Change-Id: I5dab1ed16b302af2276b0f075a790f6193edbe95
---

(no changes since v1)

gnu/packages/nss.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 80bf627583..8fb8a2fc99 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -288,6 +288,11 @@ (define-public nss/fixed
(substitute* "nss/tests/dbtests/dbtests.sh"
((" -lt 5") " -lt 50"))
+ ;; Since the test suite is very lengthy, run the test
+ ;; suite once, not thrice as done by default, by
+ ;; selecting only the 'standard' cycle.
+ (setenv "NSS_CYCLES" "standard")
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To

base-commit: b462cff5ee582d09a0a6b656bea3b1e77c1f57a5
--
2.41.0
M
M
Maxim Cournoyer wrote on 30 May 04:05 +0200
(address . 70950-done@debbugs.gnu.org)
874jagf3zx.fsf@gmail.com
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (33 lines)
> This causes the test suite to run in about in nearly a third of the original
> time (from 145 min to 52 minutes on a particular machine).
>
> * gnu/packages/nss.scm (nss/fixed) [phases] {check}: Set NSS_CYCLES
> environment variable to 'standard'.
>
> Change-Id: I5dab1ed16b302af2276b0f075a790f6193edbe95
> ---
>
> (no changes since v1)
>
> gnu/packages/nss.scm | 5 +++++
> 1 file changed, 5 insertions(+)
>
> diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
> index 80bf627583..8fb8a2fc99 100644
> --- a/gnu/packages/nss.scm
> +++ b/gnu/packages/nss.scm
> @@ -288,6 +288,11 @@ (define-public nss/fixed
> (substitute* "nss/tests/dbtests/dbtests.sh"
> ((" -lt 5") " -lt 50"))
>
> + ;; Since the test suite is very lengthy, run the test
> + ;; suite once, not thrice as done by default, by
> + ;; selecting only the 'standard' cycle.
> + (setenv "NSS_CYCLES" "standard")
> +
> ;; The "PayPalEE.cert" certificate expires every six months,
> ;; leading to test failures:
> ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
>
> base-commit: b462cff5ee582d09a0a6b656bea3b1e77c1f57a5

Merged with c9e3806ec1686f348f2ac5d88cf65daed74a721b.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70950@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70950
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch