[PATCH] gnu: krita: Fix build.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Nicolas Graves
  • Remco van 't Veer
Owner
unassigned
Submitted by
Remco van 't Veer
Severity
normal
R
R
Remco van 't Veer wrote on 14 May 18:01 +0200
(address . guix-patches@gnu.org)(name . Remco van 't Veer)(address . remco@remworks.net)
f763f0796e81105ecca7d004d0a772e0a3ccbc6f.1715702486.git.remco@remworks.net
* gnu/packages/kde.scm (krita): Fix build.
[source]: Apply krita-bump-sip-abi-version-to-12.8 patch.
* gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.

Change-Id: I322c32716a676af7c90e019b53a1fd5395701b49
---
gnu/local.mk | 5 ++--
gnu/packages/kde.scm | 4 ++-
.../krita-bump-sip-abi-version-to-12.8.patch | 25 +++++++++++++++++++
3 files changed, 31 insertions(+), 3 deletions(-)
create mode 100644 gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch

Toggle diff (81 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index e3389731ef..2556b2a198 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -48,7 +48,7 @@
# Copyright © 2021 Andrew Tropin <andrew@trop.in>
# Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
# Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
-# Copyright © 2022 Remco van 't Veer <remco@remworks.net>
+# Copyright © 2022, 2024 Remco van 't Veer <remco@remworks.net>
# Copyright © 2022, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
# Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
# Copyright © 2022 muradm <mail@muradm.net>
@@ -1570,8 +1570,9 @@ dist_patch_DATA = \
%D%/packages/patches/kobodeluxe-midicon-segmentation-fault.patch \
%D%/packages/patches/kobodeluxe-graphics-window-signed-char.patch \
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
- %D%/packages/patches/kwin-unwrap-executable-name-for-dot-desktop-search.patch\
%D%/packages/patches/kodi-mesa-eglchromium.patch \
+ %D%/packages/patches/krita-bump-sip-abi-version-to-12.8.patch \
+ %D%/packages/patches/kwin-unwrap-executable-name-for-dot-desktop-search.patch\
%D%/packages/patches/laby-make-install.patch \
%D%/packages/patches/laby-use-tmpdir-from-runtime.patch \
%D%/packages/patches/ldns-drill-examples.patch \
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 51c4fc2751..6d02547c4e 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Mehmet Tekman <mtekman89@gmail.com>
+;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -726,7 +727,8 @@ (define-public krita
"mirror://kde/stable/krita/" version "/krita-" version
".tar.gz"))
(sha256
- (base32 "1kzmn89b1vrasba7z8hp8izyrrskgc7ggnz82zqyyy1v5d8mnri7"))))
+ (base32 "1kzmn89b1vrasba7z8hp8izyrrskgc7ggnz82zqyyy1v5d8mnri7"))
+ (patches (search-patches "krita-bump-sip-abi-version-to-12.8.patch"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f
diff --git a/gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch b/gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch
new file mode 100644
index 0000000000..02852e0f5a
--- /dev/null
+++ b/gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch
@@ -0,0 +1,25 @@
+From 2d71c47661d43a4e3c1ab0c27803de980bdf2bb2 Mon Sep 17 00:00:00 2001
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Mon, 11 Dec 2023 20:26:13 +0100
+Subject: [PATCH] Bump SIP ABI version to 12.8
+
+Fixes build with SIP 6.8
+---
+ cmake/modules/pyproject.toml.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/modules/pyproject.toml.in b/cmake/modules/pyproject.toml.in
+index 090b2d4b0cb..085ddf41799 100644
+--- a/cmake/modules/pyproject.toml.in
++++ b/cmake/modules/pyproject.toml.in
+@@ -9,7 +9,7 @@ name = "@module_name_toml@"
+ sip-module = "@sip_name@"
+ sip-include-dirs = @sip_include_dirs@
+ sip-files-dir = "@module_srcs@"
+-abi-version = "12"
++abi-version = "12.8"
+
+ [tool.sip.bindings.@module_name_toml@]
+ tags = @module_tags@
+--
+GitLab

base-commit: 6e86089d563ccb67ae04cd941ca7b66c1777831f
--
2.41.0
N
N
Nicolas Graves wrote on 14 May 22:45 +0200
QA review for 70945
871q64p1gs.fsf@ngraves.fr
user guix
usertag 70945 + reviewed-looks-good
thanks

Guix QA review form submission:
lint warns that it can be updated to 5.2.2. litn doesn&apos;t like krita.org redirection but it works on the browser.
Builds properly.

Items marked as checked: Lint warnings, Package builds, Commit messages

--
Best regards,
Nicolas Graves
A
A
Andreas Enge wrote on 15 May 15:49 +0200
Close
(address . 70945-done@debbugs.gnu.org)
ZkS9gkUucRinMp-f@jurong
Thanks for the patch and for the review! I have just pushed.

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70945@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70945
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch