[PATCH gnome-team 0/3] Fix some broken tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 14 May 14:15 +0200
(address . guix-patches@gnu.org)
cover.1715688922.git.liliana.prikler@gmail.com
QA seems to dislike at least some major packages with our recent changes.
It's quite possible that some of them are flaky tests.

Liliana Marie Prikler (3):
gnu: gst-plugins-bad: Ignore elements_netsim test.
gnu: qtbase: Ignore tst_qsqlthread.
gnu: qemu: Disable more tests.

gnu/packages/gstreamer.scm | 4 ++++
gnu/packages/qt.scm | 3 +++
gnu/packages/virtualization.scm | 7 ++++++-
3 files changed, 13 insertions(+), 1 deletion(-)


base-commit: 9185efbc6cdaf8f7d83bf8fc90f44e25131b9f88
--
2.41.0
L
L
Liliana Marie Prikler wrote on 14 May 09:27 +0200
[PATCH gnome-team 1/3] gnu: gst-plugins-bad: Ignore elements_netsim test.
(address . 70936@debbugs.gnu.org)
0e64c4947867c1bbf12ddb12bf9f385b0530bcea.1715688922.git.liliana.prikler@gmail.com
* gnu/packages/gstreamer.scm (gst-plugins-bad)[adjust-tests]: Add
“elements/netsim.c” to the list of ignored test files.
---
gnu/packages/gstreamer.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 2705e245ea..ad08285181 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -796,6 +796,10 @@ (define-public gst-plugins-bad
;; The 'elements_curlhttpsrc' test sometimes times out.
((".*'elements/curlhttpsrc\\.c'.*") "")
+ ;; Unexpected critical/warning, see
+ ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/3000>
+ ((".*'elements/netsim\\.c'.*") "")
+
;; TODO: Figure out why this test fails on riscv64-linux.
#$@(if (target-riscv64?)
`((("'elements/viewfinderbin\\.c'\\].*],")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 14 May 09:39 +0200
[PATCH gnome-team 2/3] gnu: qtbase: Ignore tst_qsqlthread.
(address . 70936@debbugs.gnu.org)
0d47fca8246dfb4d295421faa3f87e7ab8cda586.1715688922.git.liliana.prikler@gmail.com
* gnu/packages/qt.scm (qtbase)[check]: Add “tst_qsqlthread” to the list of
ignored tests.
---
gnu/packages/qt.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 13f54fcc5d..1416c3a36c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -899,6 +899,9 @@ (define-public qtbase
;; TODO: when core-updates is merged, check again.
"tst_selftests"
+ ;; The 'tst_qsqlthread' test sometimes fails.
+ "tst_qsqlthread"
+
;; The 'tst_qsystemsemaphore' test sometimes fails.
"tst_qsystemsemaphore"
;; The 'tst_moc' test fails with "'fi.exists()' returned FALSE".
--
2.41.0
L
L
Liliana Marie Prikler wrote on 14 May 14:10 +0200
[PATCH gnome-team 3/3] gnu: qemu: Disable more tests.
(address . 70936@debbugs.gnu.org)
87ae7ec753272f84daac81b184a23679e934cb6f.1715688922.git.liliana.prikler@gmail.com
* gnu/packages/virtualization.scm (qemu)[disable-unusable-tests]: Also disable
qtest/ahci-test and qemu-iotests/copy-before-write.
---
gnu/packages/virtualization.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 34cccd6550..5389af62f0 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -305,7 +305,12 @@ (define-public qemu
(substitute* "tests/qtest/meson.build"
;; These tests fail to get the expected number of tests
;; on arm platforms.
- (("'arm-cpu-features',") ""))))
+ (("'arm-cpu-features',") "")
+ ;; XXX: Why does this (sometimes) fail?
+ (("\\['ahci-test'\\]") "[]"))
+ ;; This test appears to be missing permissions.
+ ;; Very sus ?
+ (delete-file "tests/qemu-iotests/tests/copy-before-write")))
#$@(if (target-riscv64?)
'((add-after 'unpack 'disable-some-tests
(lambda _
--
2.41.0
M
M
Maxim Cournoyer wrote on 15 May 03:29 +0200
Re: [bug#70936] [PATCH gnome-team 1/3] gnu: gst-plugins-bad: Ignore elements_netsim test.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
875xvfzwtn.fsf@gmail.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (3 lines)
> * gnu/packages/gstreamer.scm (gst-plugins-bad)[adjust-tests]: Add
> “elements/netsim.c” to the list of ignored test files.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 15 May 03:33 +0200
Re: [bug#70936] [PATCH gnome-team 2/3] gnu: qtbase: Ignore tst_qsqlthread.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
871q63zwna.fsf@gmail.com
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (18 lines)
> * gnu/packages/qt.scm (qtbase)[check]: Add “tst_qsqlthread” to the list of
> ignored tests.
> ---
> gnu/packages/qt.scm | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 13f54fcc5d..1416c3a36c 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -899,6 +899,9 @@ (define-public qtbase
> ;; TODO: when core-updates is merged, check again.
> "tst_selftests"
>
> + ;; The 'tst_qsqlthread' test sometimes fails.
> + "tst_qsqlthread"
> +

This was reported by myself [0] and is currently skipped only for
target-ppc64le?. We should probably skip it for every architecture if
you've encountered it on x86_64 (I'm assuming).

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 15 May 03:34 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87zfsryi1u.fsf@gmail.com
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (18 lines)
> * gnu/packages/qt.scm (qtbase)[check]: Add “tst_qsqlthread” to the list of
> ignored tests.
> ---
> gnu/packages/qt.scm | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 13f54fcc5d..1416c3a36c 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -899,6 +899,9 @@ (define-public qtbase
> ;; TODO: when core-updates is merged, check again.
> "tst_selftests"
>
> + ;; The 'tst_qsqlthread' test sometimes fails.
> + "tst_qsqlthread"
> +

This was reported by myself [0] and is currently skipped only for
target-ppc64le?. We should probably skip it for every architecture if
you've encountered it on x86_64 (I'm assuming).


Could you adjust and send a v2?

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 15 May 03:40 +0200
Re: [bug#70936] [PATCH gnome-team 3/3] gnu: qemu: Disable more tests.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87v83fyhrb.fsf@gmail.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (18 lines)
> * gnu/packages/virtualization.scm (qemu)[disable-unusable-tests]: Also disable
> qtest/ahci-test and qemu-iotests/copy-before-write.
> ---
> gnu/packages/virtualization.scm | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
> index 34cccd6550..5389af62f0 100644
> --- a/gnu/packages/virtualization.scm
> +++ b/gnu/packages/virtualization.scm
> @@ -305,7 +305,12 @@ (define-public qemu
> (substitute* "tests/qtest/meson.build"
> ;; These tests fail to get the expected number of tests
> ;; on arm platforms.
> - (("'arm-cpu-features',") ""))))
> + (("'arm-cpu-features',") "")
> + ;; XXX: Why does this (sometimes) fail?

Someone reported it already upstream:
reference to it.

Toggle quote (4 lines)
> + (("\\['ahci-test'\\]") "[]"))
> + ;; This test appears to be missing permissions.
> + ;; Very sus ?

How can it be missing permissions if it is sometimes working? Perhaps
more something racy where the file hasn't been created yet. I'd
personally rather not see emojis or comments of dubious utility ("Very
suspect") in the source. Perhaps add a short excerpt of the error for
the next curious person.

Toggle quote (5 lines)
> + (delete-file "tests/qemu-iotests/tests/copy-before-write")))
> #$@(if (target-riscv64?)
> '((add-after 'unpack 'disable-some-tests
> (lambda _

Otherwise, LGTM!

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 15 May 03:41 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87ttizyhpp.fsf@gmail.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (18 lines)
> * gnu/packages/virtualization.scm (qemu)[disable-unusable-tests]: Also disable
> qtest/ahci-test and qemu-iotests/copy-before-write.
> ---
> gnu/packages/virtualization.scm | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
> index 34cccd6550..5389af62f0 100644
> --- a/gnu/packages/virtualization.scm
> +++ b/gnu/packages/virtualization.scm
> @@ -305,7 +305,12 @@ (define-public qemu
> (substitute* "tests/qtest/meson.build"
> ;; These tests fail to get the expected number of tests
> ;; on arm platforms.
> - (("'arm-cpu-features',") ""))))
> + (("'arm-cpu-features',") "")
> + ;; XXX: Why does this (sometimes) fail?

Someone reported it already upstream:
reference to it.

Toggle quote (4 lines)
> + (("\\['ahci-test'\\]") "[]"))
> + ;; This test appears to be missing permissions.
> + ;; Very sus ?

How can it be missing permissions if it is sometimes working? Perhaps
more something racy where the file hasn't been created yet. I'd
personally rather not see emojis or comments of dubious utility ("Very
suspect") in the source. Perhaps add a short excerpt of the error for
the next curious person.

Toggle quote (5 lines)
> + (delete-file "tests/qemu-iotests/tests/copy-before-write")))
> #$@(if (target-riscv64?)
> '((add-after 'unpack 'disable-some-tests
> (lambda _

Otherwise, LGTM, with the added reference to the upstream issue. Thanks
for taking the time to address flaky tests! They are a real drag when
left unchecked.

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 16 May 07:13 +0200
Re: [bug#70936] [PATCH gnome-team 2/3] gnu: qtbase: Ignore tst_qsqlthread.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
1ebd2af7edb1e0862d676b7177ba4987b322b9db.camel@gmail.com
Am Dienstag, dem 14.05.2024 um 21:34 -0400 schrieb Maxim Cournoyer:
Toggle quote (31 lines)
> Hi Liliana,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > * gnu/packages/qt.scm (qtbase)[check]: Add “tst_qsqlthread” to the
> > list of
> > ignored tests.
> > ---
> >  gnu/packages/qt.scm | 3 +++
> >  1 file changed, 3 insertions(+)
> >
> > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> > index 13f54fcc5d..1416c3a36c 100644
> > --- a/gnu/packages/qt.scm
> > +++ b/gnu/packages/qt.scm
> > @@ -899,6 +899,9 @@ (define-public qtbase
> >                         ;; TODO: when core-updates is merged, check
> > again.
> >                         "tst_selftests"
> >  
> > +                       ;; The 'tst_qsqlthread' test sometimes
> > fails.
> > +                       "tst_qsqlthread"
> > +
>
> This was reported by myself [0] and is currently skipped only for
> target-ppc64le?.  We should probably skip it for every architecture
> if you've encountered it on x86_64 (I'm assuming).
>
> [0] 
> https://bugreports.qt.io/browse/QTBUG-117114?jql=text%20~%20%22tst_qsqlthread%22
Should I rebase gnome-team on master again, so that I can drop the
condition?

Cheers
M
M
Maxim Cournoyer wrote on 16 May 14:44 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87msoqvsc4.fsf@gmail.com
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (35 lines)
> Am Dienstag, dem 14.05.2024 um 21:34 -0400 schrieb Maxim Cournoyer:
>> Hi Liliana,
>>
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>>
>> > * gnu/packages/qt.scm (qtbase)[check]: Add “tst_qsqlthread” to the
>> > list of
>> > ignored tests.
>> > ---
>> >  gnu/packages/qt.scm | 3 +++
>> >  1 file changed, 3 insertions(+)
>> >
>> > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
>> > index 13f54fcc5d..1416c3a36c 100644
>> > --- a/gnu/packages/qt.scm
>> > +++ b/gnu/packages/qt.scm
>> > @@ -899,6 +899,9 @@ (define-public qtbase
>> >                         ;; TODO: when core-updates is merged, check
>> > again.
>> >                         "tst_selftests"
>> >  
>> > +                       ;; The 'tst_qsqlthread' test sometimes
>> > fails.
>> > +                       "tst_qsqlthread"
>> > +
>>
>> This was reported by myself [0] and is currently skipped only for
>> target-ppc64le?.  We should probably skip it for every architecture
>> if you've encountered it on x86_64 (I'm assuming).
>>
>> [0] 
>> https://bugreports.qt.io/browse/QTBUG-117114?jql=text%20~%20%22tst_qsqlthread%22
> Should I rebase gnome-team on master again, so that I can drop the
> condition?

Sounds reasonable, if you didn't have that conditional skip on
gnome-team already.

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 16 May 15:15 +0200
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
9f466f3d75169f236aa54f33c5f76a0db0e5fac7.camel@gmail.com
Am Donnerstag, dem 16.05.2024 um 08:44 -0400 schrieb Maxim Cournoyer:
Toggle quote (44 lines)
> Hi Liliana,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > Am Dienstag, dem 14.05.2024 um 21:34 -0400 schrieb Maxim Cournoyer:
> > > Hi Liliana,
> > >
> > > Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> > >
> > > > * gnu/packages/qt.scm (qtbase)[check]: Add “tst_qsqlthread” to
> > > > the
> > > > list of
> > > > ignored tests.
> > > > ---
> > > >  gnu/packages/qt.scm | 3 +++
> > > >  1 file changed, 3 insertions(+)
> > > >
> > > > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> > > > index 13f54fcc5d..1416c3a36c 100644
> > > > --- a/gnu/packages/qt.scm
> > > > +++ b/gnu/packages/qt.scm
> > > > @@ -899,6 +899,9 @@ (define-public qtbase
> > > >                         ;; TODO: when core-updates is merged,
> > > > check
> > > > again.
> > > >                         "tst_selftests"
> > > >  
> > > > +                       ;; The 'tst_qsqlthread' test sometimes
> > > > fails.
> > > > +                       "tst_qsqlthread"
> > > > +
> > >
> > > This was reported by myself [0] and is currently skipped only for
> > > target-ppc64le?.  We should probably skip it for every
> > > architecture
> > > if you've encountered it on x86_64 (I'm assuming).
> > >
> > > [0] 
> > > https://bugreports.qt.io/browse/QTBUG-117114?jql=text%20~%20%22tst_qsqlthread%22
> > Should I rebase gnome-team on master again, so that I can drop the
> > condition?
>
> Sounds reasonable, if you didn't have that conditional skip on
> gnome-team already.
I don't see it even after the rebase… is that on master yet or
elsewhere?

Anyhow, I think I forgot to link the bug report appropriately before
pushing, will do so when CI lights green.

Cheers
M
M
Maxim Cournoyer wrote on 16 May 18:06 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87ikzdwxkf.fsf@gmail.com
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (51 lines)
> Am Donnerstag, dem 16.05.2024 um 08:44 -0400 schrieb Maxim Cournoyer:
>> Hi Liliana,
>>
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>>
>> > Am Dienstag, dem 14.05.2024 um 21:34 -0400 schrieb Maxim Cournoyer:
>> > > Hi Liliana,
>> > >
>> > > Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> > >
>> > > > * gnu/packages/qt.scm (qtbase)[check]: Add “tst_qsqlthread” to
>> > > > the
>> > > > list of
>> > > > ignored tests.
>> > > > ---
>> > > >  gnu/packages/qt.scm | 3 +++
>> > > >  1 file changed, 3 insertions(+)
>> > > >
>> > > > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
>> > > > index 13f54fcc5d..1416c3a36c 100644
>> > > > --- a/gnu/packages/qt.scm
>> > > > +++ b/gnu/packages/qt.scm
>> > > > @@ -899,6 +899,9 @@ (define-public qtbase
>> > > >                         ;; TODO: when core-updates is merged,
>> > > > check
>> > > > again.
>> > > >                         "tst_selftests"
>> > > >  
>> > > > +                       ;; The 'tst_qsqlthread' test sometimes
>> > > > fails.
>> > > > +                       "tst_qsqlthread"
>> > > > +
>> > >
>> > > This was reported by myself [0] and is currently skipped only for
>> > > target-ppc64le?.  We should probably skip it for every
>> > > architecture
>> > > if you've encountered it on x86_64 (I'm assuming).
>> > >
>> > > [0] 
>> > > https://bugreports.qt.io/browse/QTBUG-117114?jql=text%20~%20%22tst_qsqlthread%22
>> > Should I rebase gnome-team on master again, so that I can drop the
>> > condition?
>>
>> Sounds reasonable, if you didn't have that conditional skip on
>> gnome-team already.
> I don't see it even after the rebase… is that on master yet or
> elsewhere?
>
> Anyhow, I think I forgot to link the bug report appropriately before
> pushing, will do so when CI lights green.

It's from commit 625fa5745e3, dated 26th of March 2024.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 24 Jun 05:14 +0200
Re: [bug#70936] [PATCH gnome-team 3/3] gnu: qemu: Disable more tests.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
878qyv3uc0.fsf@gmail.com
Hello!

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (43 lines)
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
>> * gnu/packages/virtualization.scm (qemu)[disable-unusable-tests]: Also disable
>> qtest/ahci-test and qemu-iotests/copy-before-write.
>> ---
>> gnu/packages/virtualization.scm | 7 ++++++-
>> 1 file changed, 6 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
>> index 34cccd6550..5389af62f0 100644
>> --- a/gnu/packages/virtualization.scm
>> +++ b/gnu/packages/virtualization.scm
>> @@ -305,7 +305,12 @@ (define-public qemu
>> (substitute* "tests/qtest/meson.build"
>> ;; These tests fail to get the expected number of tests
>> ;; on arm platforms.
>> - (("'arm-cpu-features',") ""))))
>> + (("'arm-cpu-features',") "")
>> + ;; XXX: Why does this (sometimes) fail?
>
> Someone reported it already upstream:
> <https://gitlab.com/qemu-project/qemu/-/issues/2121>. Please add a
> reference to it.
>
>> + (("\\['ahci-test'\\]") "[]"))
>> + ;; This test appears to be missing permissions.
>> + ;; Very sus ?
>
> How can it be missing permissions if it is sometimes working? Perhaps
> more something racy where the file hasn't been created yet. I'd
> personally rather not see emojis or comments of dubious utility ("Very
> suspect") in the source. Perhaps add a short excerpt of the error for
> the next curious person.
>
>> + (delete-file "tests/qemu-iotests/tests/copy-before-write")))
>> #$@(if (target-riscv64?)
>> '((add-after 'unpack 'disable-some-tests
>> (lambda _
>
> Otherwise, LGTM, with the added reference to the upstream issue. Thanks
> for taking the time to address flaky tests! They are a real drag when
> left unchecked.

Ping, in case it had fallen in cracks :-).

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 24 Jun 06:11 +0200
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
cb24b1334512af32f4847afa052af458283d7ae4.camel@gmail.com
Am Sonntag, dem 23.06.2024 um 23:14 -0400 schrieb Maxim Cournoyer:
Toggle quote (1 lines)
> Ping, in case it had fallen in cracks :-).
It hasn't, I just forgot to mark it as pushed.

Cheers
Closed
M
M
Maxim Cournoyer wrote on 24 Jun 06:50 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87zfrbymdq.fsf@gmail.com
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (4 lines)
> Am Sonntag, dem 23.06.2024 um 23:14 -0400 schrieb Maxim Cournoyer:
>> Ping, in case it had fallen in cracks :-).
> It hasn't, I just forgot to mark it as pushed.

Excellent.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70936@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70936
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch