FAIL tests/guix-shell.sh

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 14 May 13:14 +0200
(address . bug-guix@gnu.org)
87ikzgzlvl.fsf@cbaines.net
When attempting to update the guix package, I got this failure. The test
log makes no sense though, as it's trying to test for errors, so I have
no idea where to start in working out what is wrong.

I thought maybe the issue was here:

guix shell: error: package intelmetool@4.7 does not support armhf-linux

But apparently that's expected? There's nothing in the log to indicate
that it's going to try something that should fail though.



FAIL: tests/guix-shell
======================

+ guix shell --version
guix shell (GNU Guix) 1.4.0-20.37719d3
Copyright (C) 2024 the Guix authors
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
+ configdir=t-guix-shell-config-19847
+ tmpdir=t-guix-shell-19847
+ trap 'rm -r "$tmpdir" "$configdir"' EXIT
+ mkdir t-guix-shell-19847 t-guix-shell-config-19847 t-guix-shell-config-19847/guix
++ realpath t-guix-shell-config-19847
+ XDG_CONFIG_HOME=/tmp/guix-build-guix-1.4.0-20.37719d3.drv-0/source/t-guix-shell-config-19847
+ export XDG_CONFIG_HOME
+ guix shell --bootstrap --pure guile-bootstrap -- guile --version
accepted connection from pid 19864, user nixbld
guile (GNU Guile) 2.0.9
Copyright (C) 2013 Free Software Foundation, Inc.

License LGPLv3+: GNU LGPL 3 or later http://gnu.org/licenses/lgpl.html.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
+ guix shell --bootstrap guile-bootstrap -S /dummy=bin/guile
hint: Consider passing the `--check' option once to make sure your shell does not
clobber environment variables.

guix shell: error: '--symlink' cannot be used without '--container'
+ guix shell --ad-hoc guile-bootstrap
guix shell: error: ad-hoc: unrecognized option
+ guix shell -s armhf-linux intelmetool -n
hint: Consider passing the `--check' option once to make sure your shell does not
clobber environment variables.

accepted connection from pid 19896, user nixbld
guix shell: error: package intelmetool@4.7 does not support armhf-linux
++ echo /proc/19847/fd/0 /proc/19847/fd/1 /proc/19847/fd/2 /proc/19847/fd/255 /proc/19847/fd/3
+ initial_fd_list='/proc/19847/fd/0 /proc/19847/fd/1 /proc/19847/fd/2 /proc/19847/fd/255 /proc/19847/fd/3'
++ guix shell --bootstrap guile-bootstrap -- bash -c 'echo /proc/$$/fd/*'
+ fd_list='/proc/19918/fd/0 /proc/19918/fd/1 /proc/19918/fd/2 /proc/19918/fd/3'
++ echo /proc/19918/fd/0 /proc/19918/fd/1 /proc/19918/fd/2 /proc/19918/fd/3
++ wc -w
++ echo /proc/19847/fd/0 /proc/19847/fd/1 /proc/19847/fd/2 /proc/19847/fd/255 /proc/19847/fd/3
++ wc -w
+ test 4 -le 5
+ cat
+ cd t-guix-shell-19847
++ type -P true
+ SHELL=/gnu/store/a5i8avx826brw5grn3n4qv40g514505c-coreutils-9.1/bin/true
+ guix shell --bootstrap
+ grep 'not authorized' t-guix-shell-19847/stderr
guix shell: error: not loading '/tmp/guix-build-guix-1.4.0-20.37719d3.drv-0/source/t-guix-shell-19847/guix.scm' because not authorized to do so
+ rm t-guix-shell-19847/stderr
++ realpath t-guix-shell-19847
+ echo /tmp/guix-build-guix-1.4.0-20.37719d3.drv-0/source/t-guix-shell-19847
+ cd t-guix-shell-19847
+ guix shell --bootstrap -- true
accepted connection from pid 19942, user nixbld
guix shell: warning: no packages specified; creating an empty environment
+ mv t-guix-shell-19847/guix.scm t-guix-shell-19847/manifest.scm
+ cd t-guix-shell-19847
+ guix shell --bootstrap -- true
guix shell: warning: no packages specified; creating an empty environment
+ rm t-guix-shell-19847/manifest.scm
+ cat
+ cat
+ chmod +x t-guix-shell-19847/fake-shell.sh
++ cd t-guix-shell-19847
+++ realpath fake-shell.sh
++ SHELL=/tmp/guix-build-guix-1.4.0-20.37719d3.drv-0/source/t-guix-shell-19847/fake-shell.sh
++ guix shell --bootstrap
guix shell: loading environment from '/tmp/guix-build-guix-1.4.0-20.37719d3.drv-0/source/t-guix-shell-19847/manifest.scm'...
hint: Consider passing the `--check' option once to make sure your shell does not
clobber environment variables.

accepted connection from pid 19971, user nixbld
+ profile1=/tmp/guix-tests/store/vqrwmdf81v9wb4gb70g6v8b4xnm8l5ih-profile
++ guix shell --bootstrap guile-bootstrap -- /gnu/store/rib9g2ig1xf3kclyl076w28parmncg4k-bash-minimal-5.1.16/bin/sh -c 'echo $GUIX_ENVIRONMENT'
+ profile2=/tmp/guix-tests/store/vqrwmdf81v9wb4gb70g6v8b4xnm8l5ih-profile
+ test -n /tmp/guix-tests/store/vqrwmdf81v9wb4gb70g6v8b4xnm8l5ih-profile
+ test /tmp/guix-tests/store/vqrwmdf81v9wb4gb70g6v8b4xnm8l5ih-profile = /tmp/guix-tests/store/vqrwmdf81v9wb4gb70g6v8b4xnm8l5ih-profile
+ rm t-guix-shell-19847/manifest.scm
+ echo 'Broken manifest.'
+ cd t-guix-shell-19847
++ realpath fake-shell.sh
+ SHELL=/tmp/guix-build-guix-1.4.0-20.37719d3.drv-0/source/t-guix-shell-19847/fake-shell.sh
+ guix shell --bootstrap -q
hint: Consider passing the `--check' option once to make sure your shell does not
clobber environment variables.

guix shell: warning: no packages specified; creating an empty environment
/tmp/guix-tests/store/j5bh45fk0nc7zxs74lv3ninf23plpsvm-profile
+ rm t-guix-shell-19847/manifest.scm
+ cat
+ guix shell --bootstrap --pure -D -f t-guix-shell-19847/empty-package.scm guile-bootstrap -- guile --version
accepted connection from pid 20011, user nixbld
guile (GNU Guile) 2.0.9
Copyright (C) 2013 Free Software Foundation, Inc.

License LGPLv3+: GNU LGPL 3 or later http://gnu.org/licenses/lgpl.html.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
+ rm t-guix-shell-19847/empty-package.scm
++ guile -c '(use-modules (guix utils))
(display (%current-system))'
+ this_system=x86_64-linux
++ guile -c '(use-modules (guix utils))
(display (if (string=? "riscv64-linux" (%current-system))
"x86_64-linux"
"riscv64-linux"))'
+ other_system=riscv64-linux
+ cat
+ guix shell -D -f t-guix-shell-19847/some-package.scm -n
hint: Consider passing the `--check' option once to make sure your shell does not
clobber environment variables.

+ false
+ rm -r t-guix-shell-19847 t-guix-shell-config-19847
FAIL tests/guix-shell.sh (exit status: 1)
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZDR35fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcJWRAApPbzIf3t2AJ6S15hPtlrClHkehIQ8SMu
BTwwVoCrIXQPyFXidcghoZfK1N3V66dmx25CLnl15ncBtdiB2zyRDGNIROG5iHcA
9jwC6ZVnv1suDYX0ar7O5X6gIqGMFLgUMM5VeabBvx1Ht0uRlTti1e9HDrQdqOfw
SC9PHC+McCJ49iCmUP3Ddyu53g+ivmvNLsa4Ebwy2ZLvg2InvDQr0iA33pwAGOjr
cazimxIj57Brs4ZPwJh46l8B4MSZD3wVLYj3akUJoc1aGSDhowR52EwL/S1/IK/J
AhdVreiOXIJlR7xyqkX+nV8/1glvHAk7lLQ6Qw2w/rhOqgYzEKldkYi0c9Cifx9D
PmZRmxpcxyqoGhqE+7lYzA53jtKXMe/BM56kSkR4m7xO+3cMiYMSNjSSzKZa1BC1
b+AdTvsu++Gg/xGkBdiUOD9BMUA31vU9oeVbRHffEFiqj2mnv1zNm12hQV5irbTQ
ftKjKGuCxHrKgeEJ3Teg94f881IEV9cnXx4/fadxvmM1ivHQ8UCCc34fXzzG43ev
cfytQNLaHLJHmfmz4PrqzTcWoU2LeBDTx7fbAjpqxfBBun5rz6IpsO5nnXM7pmi0
TwysAWGt9wnPufc2XxMPPgxDy8+jn5yvBEVoGCGjLWjbYvuZ9Q9ui/1Sh6b9mroS
tfRMPARHed0=
=oI4p
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 25 May 11:58 +0200
(name . Christopher Baines)(address . mail@cbaines.net)(address . 70932@debbugs.gnu.org)
87cypa2oxr.fsf@gnu.org
Hi,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (15 lines)
> ++ guile -c '(use-modules (guix utils))
> (display (%current-system))'
> + this_system=x86_64-linux
> ++ guile -c '(use-modules (guix utils))
> (display (if (string=? "riscv64-linux" (%current-system))
> "x86_64-linux"
> "riscv64-linux"))'
> + other_system=riscv64-linux
> + cat
> + guix shell -D -f t-guix-shell-19847/some-package.scm -n
> hint: Consider passing the `--check' option once to make sure your shell does not
> clobber environment variables.
>
> + false

This is in ‘tests/guix-shell.sh’ a test that checks that unsupported
packages are rejected. The ‘guix shell -D -f -t …’ command above is
supposed to fail (non-zero exit code), but in your case it succeeded,
hence the test failure.

“make check TESTS=tests/guix-shell.sh” passes for me though with
9c3a8a380bcfebdb77af61532e7bfec523d7bde8.

Ludo’.
C
C
Christopher Baines wrote on 25 May 13:53 +0200
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 70932@debbugs.gnu.org)
874jamglaw.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (25 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> ++ guile -c '(use-modules (guix utils))
>> (display (%current-system))'
>> + this_system=x86_64-linux
>> ++ guile -c '(use-modules (guix utils))
>> (display (if (string=? "riscv64-linux" (%current-system))
>> "x86_64-linux"
>> "riscv64-linux"))'
>> + other_system=riscv64-linux
>> + cat
>> + guix shell -D -f t-guix-shell-19847/some-package.scm -n
>> hint: Consider passing the `--check' option once to make sure your shell does not
>> clobber environment variables.
>>
>> + false
>
> This is in ‘tests/guix-shell.sh’ a test that checks that unsupported
> packages are rejected. The ‘guix shell -D -f -t …’ command above is
> supposed to fail (non-zero exit code), but in your case it succeeded,
> hence the test failure.
>
> “make check TESTS=tests/guix-shell.sh” passes for me though with
> 9c3a8a380bcfebdb77af61532e7bfec523d7bde8.

I can just about see what's happening on this line now, I'm still not
sure why the exit status means the test fails.

I think I knew when I submitted the issue that the test was flaky as it
passed on the second attempt.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZR0SdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf3sw//T+JZZ1BUxtDdan0og571Gzzk3R267Cks
HFmWeKe/HOW5o/HjX5XcXhqCMQtPmhh0NXuFYDhlbjsJ2xJZDZugw2SrTojNlWqC
Xb8uyUOKZZcfZRxY4i9cTIjm4Vj+/A8yER2fdZNKfD/gcBOsQla+YT14BH+GFj7p
fqrBPZnGOgtnKYB5LDr2Ttcis80RIJiX7FtGibFkTt2ZgWJ2jUZ5zJB2mU8kSQ8o
3Pj/KnZ6Y6gpYbt0w6829UFIvPAFZ9nY/wKyc2ggsfFmpjNOKj5VlbmBfdFbdlvT
cPhHwlFGOOmh+aoibbmTsR8F/S8tpiAMFzaqJicyAD3xzLvqE7adTjMaWdqhB+5+
Jxjt1z1IlAeQg83IagAqgGqoIVj75ZkuxoJK9HzYf5Hv7mnOyJFtr1FamdoVxA1N
WHZc9faWrhudsBVXd6tNCNjLA61N+wn1PBAGYzea5NsK3zYFjvNUx9/5EBcXL6nM
UCjzLyzlTDJAs+GZ9d1yw6z8BKlTf6RlVXUVXLIw1xgHCMAozTC3N5c7J0IFamfm
6s3lYkaUmj+mTySHswZIoDQkNd3VJ082DCTBc/dtzWytPX+wvgqy0LlwbV1ex2XK
E2cmCi6Tl2DY3p+BvRPT9tmA88FiL92yCNossgb73bZ6YsaRDalP8jqkNOPpncwj
hsz2QsMzr/s=
=qOPf
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 25 May 15:00 +0200
(name . Christopher Baines)(address . mail@cbaines.net)(address . 70932@debbugs.gnu.org)
871q5q2ghj.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (9 lines)
>> “make check TESTS=tests/guix-shell.sh” passes for me though with
>> 9c3a8a380bcfebdb77af61532e7bfec523d7bde8.
>
> I can just about see what's happening on this line now, I'm still not
> sure why the exit status means the test fails.
>
> I think I knew when I submitted the issue that the test was flaky as it
> passed on the second attempt.

I don’t think how this particular test is flaky: checking whether a
package’s ‘supported-systems’ matches the current system is fully
deterministic AFAICS.

But, who knows, it would be interesting to see if it eventually fails
when ran in a loop.

Closing?

Ludo’.
L
L
Ludovic Courtès wrote on 11 Jun 20:07 +0200
control message for bug #70932
(address . control@debbugs.gnu.org)
87y17bl5e6.fsf@gnu.org
tags 70932 notabug
close 70932
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70932@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70932
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch