[PATCH 00/10] Add some SageMath standard packages.

  • Open
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 13 May 22:50 +0200
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
cover.1715632275.git.monego@posteo.net
I was looking at https://doc.sagemath.org/html/en/reference/spkg/and made a list of the missing packages. There are around 45 packages missing in the Standard Packages, and 77 in the Optional Packages.

I will submit what can be packaged in various patch series of 10 packages to ease the review. Some of the packages can't be included because they depend on recent versions of core packages (python-referencing apparently needs a newer version of hatchling).

Some of these have been packaged in https://issues.guix.gnu.org/56729while others are new.

Vinicius Monego (10):
gnu: Add python-memory-allocator.
gnu: Add python-calver.
gnu: Add python-async-lru.
gnu: Add python-isoduration.
gnu: Add python-uri-template.
gnu: Add python-pyproject-api.
gnu: Add primecount.
gnu: Add python-primecountpy.
gnu: Add python-types-dateutil.
gnu: Add python-pplpy.

gnu/packages/maths.scm | 47 ++++++++++++
gnu/packages/python-xyz.scm | 143 ++++++++++++++++++++++++++++++++++++
gnu/packages/sagemath.scm | 52 +++++++++++++
3 files changed, 242 insertions(+)


base-commit: 89cd778f6a45cd9b43a4dc1f236dcd0a87af955c
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 02/10] gnu: Add python-calver.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
f2eb991e9c4bd9b90a2171f072b9cab251713894.1715633288.git.monego@posteo.net
* gnu/packages/python-build.scm (python-calver): New variable.

Change-Id: Icaf6d09519f792b42a5e0992b2e4fed4131b67f5
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 557c6d5815..901b0b25c5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25872,6 +25872,27 @@ (define-public python-send2trash
user's @file{~/Trash} directory.")
(license license:bsd-3)))
+(define-public python-calver
+ (package
+ (name "python-calver")
+ (version "2022.06.26")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/di/calver")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14l9kv9igcmp5k6d2ahnx6z4dn6zy5kykz95hkh0rkqswn8x79b1"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pretend python-pytest))
+ (home-page "https://github.com/di/calver")
+ (synopsis "Setuptools extension for CalVer package versions")
+ (description "The calver package is a setuptools extension for
+automatically defining your Python package version as a calendar version.")
+ (license license:asl2.0)))
+
(define-public python-pyfavicon
(package
(name "python-pyfavicon")
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 03/10] gnu: Add python-async-lru.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
4954ddcec07219ed0110f8fa5f038de716703092.1715633288.git.monego@posteo.net
* gnu/packages/python-xyz.scm (python-async-lru): New variable.

Change-Id: I980f53542ae44c6a2127677171d16b29aa4a3d64
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 901b0b25c5..73b2753dc3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22326,6 +22326,31 @@ (define-public python-kivymd
Design spec without sacrificing ease of use or application performance.")
(license license:expat)))
+(define-public python-async-lru
+ (package
+ (name "python-async-lru")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "async-lru" version))
+ (sha256
+ (base32 "09sn3bc3gc2flijm9k8kn4hmbnlkaddhqahb49izy188yrfrm9dq"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest
+ python-pytest-asyncio
+ python-pytest-cov
+ python-pytest-timeout))
+ (propagated-inputs (list python-typing-extensions))
+ (home-page "https://github.com/aio-libs/async-lru")
+ (synopsis "Simple LRU cache for asyncio")
+ (description
+ "This package is a port of Python's built-in @code{functools.lru_cache}
+function for @code{asyncio}. To better handle async behaviour, it also
+ensures multiple concurrent calls will only result in 1 call to the wrapped
+function, with all awaits receiving the result of that call when it completes.")
+ (license license:expat)))
+
(define-public python-asyncinject
(package
(name "python-asyncinject")
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 01/10] gnu: Add python-memory-allocator.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
676c926b816fad99606d7803b3b43156fe4696a1.1715633288.git.monego@posteo.net
* gnu/packages/sagemath.scm (python-memory-allocator): New variable.

Change-Id: Ib914cc736fa16c2a7bb2919d94aaf102e3513a60
---
gnu/packages/sagemath.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 8d5d04ee93..9ccb7eb055 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2024 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,6 +24,7 @@
(define-module (gnu packages sagemath)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -94,6 +96,35 @@ (define-public python-gmpy2
libraries GMO, MPFR and MPC.")
(license license:lgpl3+)))
+(define-public python-memory-allocator
+ (package
+ (name "python-memory-allocator")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "memory_allocator" version))
+ (sha256
+ (base32 "1r7g175ddbpn5kjgs6f09s7mfachzw94p02snki6f6830dmj22fn"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-cython))
+ (home-page "https://github.com/sagemath/memory_allocator")
+ (synopsis "Extension class to allocate memory easily with Cython")
+ (description "This package provides a single extension class
+ @code{MemoryAllocator} with @{cdef} methods
+
+@itemize
+@item @code{malloc}
+@item @code{calloc}
+@item @code{allocarray}
+@item @code{realloc}
+@item @code{reallocarray}
+@item @code{aligned_malloc}
+@item @code{aligned_malloc}
+@item @code{aligned_calloc}
+@item @code{aligned_allocarray}")
+ (license license:gpl3+)))
+
(define-public cliquer
(package
(name "cliquer")

base-commit: 89cd778f6a45cd9b43a4dc1f236dcd0a87af955c
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 04/10] gnu: Add python-isoduration.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
ac922ea4f71426e78f3be97e249da776e6c9b292.1715633288.git.monego@posteo.net
* gnu/packages/python-xyz.scm (python-isoduration): New variable.

Change-Id: Ifc56c0405ec865f9f5c7f404248e02fe108d867d
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 73b2753dc3..1bb08ecb9b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23639,6 +23639,31 @@ (define-public python-invoke
instead of servers and network commands.")
(license license:bsd-3)))
+(define-public python-isoduration
+ (package
+ (name "python-isoduration")
+ (version "20.11.0")
+ (source (origin
+ (method git-fetch) ; no tests in PyPI
+ (uri (git-reference
+ (url "https://github.com/bolsote/isoduration")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1naml13qa1inr6k0j25jgw49r3wnkvwq5xc0v4navz6mxlgsrfp8"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-isodate
+ python-pytest
+ python-pytest-benchmark))
+ (propagated-inputs (list python-arrow))
+ (home-page "https://github.com/bolsote/isoduration")
+ (synopsis "Operations with ISO 8601 durations")
+ (description "This package provides operations with ISO 8601 durations.
+It addresses the shortcomings of @code{isodate} (as described in their own
+Limitations section).")
+ (license license:isc)))
+
(define-public python-automat
(package
(name "python-automat")
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 05/10] gnu: Add python-uri-template.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
acdbf268e728f200c2d628c59a42d44846246d9a.1715633288.git.monego@posteo.net
* gnu/packages/python-xyz.scm (python-uri-template): New variable.

Change-Id: I31c110ca1581298f5648213c4247d30b156c5f77
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1bb08ecb9b..79c7b310d4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24249,6 +24249,24 @@ (define-public python-icdiff
parts of the lines that were modified.")
(license license:psfl)))
+(define-public python-uri-template
+ (package
+ (name "python-uri-template")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "uri-template" version))
+ (sha256
+ (base32 "1ixczlgnsjv2850r6w0cb2npwcwzdqri8njr1pi7v371cpmzh00f"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ; there are no Python test scripts
+ (home-page "https://gitlab.linss.com/open-source/python/uri-template")
+ (synopsis "RFC 6570 URI Template Processor")
+ (description "This packages implements URI Template expansion in strict
+adherence to RFC 6570, but adds a few extensions.")
+ (license license:expat)))
+
(define-public python-dirsync
(package
(name "python-dirsync")
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 06/10] gnu: Add python-pyproject-api.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
80a138c1893532ec9188fd0905cbaaa583a6c609.1715633288.git.monego@posteo.net
* gnu/packages/python-xyz.scm (python-pyproject-api): New variable.

Change-Id: I4bef06ecebcf3c5df99196b75017a4d97c7f2dda
---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 79c7b310d4..521005174e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17179,6 +17179,41 @@ (define-public python-forex-python
@end itemize")
(license license:expat)))
+(define-public python-pyproject-api
+ (package
+ (name "python-pyproject-api")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyproject_api" version))
+ (sha256
+ (base32 "0f75rajzk72ay4x9ajw1835amm932q7cdn0yrbwiy3fwi80xq5qq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; This test fails with AssertionError.
+ #~(list "-k" "not test_setuptools_prepare_metadata_for_build_wheel")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-packaging
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; We have packaging 21.3.
+ (("packaging>=23.1") "packaging>=21.3")))))))
+ (propagated-inputs (list python-packaging python-tomli))
+ (native-inputs (list python-covdefaults
+ python-hatch-vcs
+ python-hatchling
+ python-pytest
+ python-pytest-cov
+ python-pytest-mock))
+ (home-page "https://pyproject-api.readthedocs.io/en/latest/")
+ (synopsis "API to interact with the Python pyproject.toml based projects")
+ (description "@code{pyproject-api} aims to abstract away interaction with
+@code{pyproject.toml} style projects in a flexible way.")
+ (license license:expat)))
+
(define-public python-simpleeval
(package
(name "python-simpleeval")
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 07/10] gnu: Add primecount.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
d7bd4f084396a0c24db5468c42c5a31c316f63b0.1715633288.git.monego@posteo.net
* gnu/packages/maths.scm (primecount): New variable.

Change-Id: I03692a1be46cc4d0f3eabe95a3f76719a5c63d83
---
gnu/packages/maths.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b7ebb2019c..1740a55cf4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1335,6 +1335,31 @@ (define-public feedgnuplot
in the terminal or with an external viewer.")
(license license:gpl1+))) ;any version
+(define-public primecount
+ (package
+ (name "primecount")
+ (version "7.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kimwalisch/primecount")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v3zm6mw4fb6a33zi542x94w1nd54rvn7r8dav670jm9dn60jfsn"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON"
+ "-DBUILD_STATIC_LIBS=OFF"
+ "-DBUILD_TESTS=ON")))
+ (home-page "https://github.com/kimwalisch/primecount")
+ (synopsis "Fast prime counting function implementations")
+ (description "@code{primecount} is a command-line program and C/C++
+library that counts the number of primes ≤ x (maximum 1031) using highly
+optimized implementations of the combinatorial prime counting algorithms.")
+ (license license:bsd-2)))
+
(define-public giza
(package
(name "giza")
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 08/10] gnu: Add python-primecountpy.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
ca3f9049e9957d08a0f0c5e89cc3ece31d68e50d.1715633288.git.monego@posteo.net
* gnu/packages/maths.scm (python-primecountpy): New variable.

Change-Id: Id775a672c104162965825d8d44e599df0c26f11a
---
gnu/packages/maths.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1740a55cf4..8792f9df06 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1360,6 +1360,28 @@ (define-public primecount
optimized implementations of the combinatorial prime counting algorithms.")
(license license:bsd-2)))
+(define-public python-primecountpy
+ (package
+ (name "python-primecountpy")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "primecountpy" version))
+ (sha256
+ (base32 "0xh6zx5zw5scy7jygqirks9y6z4zyfm0zjfp8nd6dw0m471przkq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; there are no tests
+ (native-inputs (list python-cysignals python-cython))
+ (inputs (list pari-gp primecount))
+ (home-page "https://github.com/dimpase/primecountpy")
+ (synopsis "Cython interface for C++ primecount library")
+ (description "This package provides a Cython interface to the C++ library
+@code{primecount}.")
+ ;; pyproject.toml says gpl3 but file headers say gpl2+.
+ (license license:gpl2+)))
+
(define-public giza
(package
(name "giza")
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 09/10] gnu: Add python-types-dateutil.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
fca7842dfaeecdb9d4421b4dbd38516330e0e702.1715633288.git.monego@posteo.net
* gnu/packages/python-xyz.scm (python-types-dateutil): New variable.

Change-Id: I2b60be63a0dc6eae1f4cd7be11fc38e1bb8acc3c
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 521005174e..22b09dfcc7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -35144,6 +35144,26 @@ (define-public python-ansicolors
"This package adds ANSI colors and decorations to your strings.")
(license license:isc)))
+(define-public python-types-dateutil
+ (package
+ (name "python-types-dateutil")
+ (version "2.9.0.20240316")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-python-dateutil" version))
+ (sha256
+ (base32 "00h2xi8p6ygdv9nhgwdyx86ky9m9dpdqgmsdji05x4461cj2wbsx"))))
+ (native-inputs (list python-pytest))
+ (arguments (list #:tests? #f)) ; no tests
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for python-dateutil")
+ (description
+ "This is a PEP 561 type stub package for the @code{python-dateutil}
+package.")
+ (license license:asl2.0)))
+
(define-public python-types-freezegun
(package
(name "python-types-freezegun")
--
2.39.2
V
V
Vinicius Monego wrote on 13 May 22:52 +0200
[PATCH 10/10] gnu: Add python-pplpy.
(address . 70924@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
6264215cfd17efe1a12b728b0cecc915963cfab5.1715633288.git.monego@posteo.net
* gnu/packages/sagemath.scm (python-pplpy): New variable.

Change-Id: I24d436a03462fd7eb176d34a15683a88814238ea
---
gnu/packages/sagemath.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 9ccb7eb055..3373885614 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -35,6 +35,7 @@ (define-module (gnu packages sagemath)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages image)
#:use-module (gnu packages lisp)
@@ -258,6 +259,26 @@ (define-public zn-poly
(license (list license:gpl2 license:gpl3)) ; dual licensed
(home-page "https://gitlab.com/sagemath/zn_poly")))
+(define-public python-pplpy
+ (package
+ (name "python-pplpy")
+ (version "0.8.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pplpy" version))
+ (sha256
+ (base32 "1zggfj09zkfcabcsasq27vwbhdmkig4yn380gi6wykcih9n22anl"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-cython-3 python-pytest))
+ (inputs (list gmp mpc mpfr pari-gp ppl))
+ (propagated-inputs (list python-cysignals python-gmpy2))
+ (home-page "https://github.com/sagemath/pplpy")
+ (synopsis "Python PPL wrapper")
+ (description "This Python package provides a wrapper to the C++ Parma
+Polyhedra Library (PPL).")
+ (license license:gpl3+)))
+
(define-public brial
(package
(name "brial")
--
2.39.2
V
V
Vinicius Monego wrote on 14 May 17:11 +0200
Re: [PATCH 00/10] Add some SageMath standard packages.
(address . 70924@debbugs.gnu.org)
4f5420ec-ff70-4f15-ab21-f48d29f7094d@posteo.net
Em 13/05/2024 17:50, Vinicius Monego escreveu:
Toggle quote (25 lines)
> I was looking at https://doc.sagemath.org/html/en/reference/spkg/and made a list of the missing packages. There are around 45 packages missing in the Standard Packages, and 77 in the Optional Packages.
>
> I will submit what can be packaged in various patch series of 10 packages to ease the review. Some of the packages can't be included because they depend on recent versions of core packages (python-referencing apparently needs a newer version of hatchling).
>
> Some of these have been packaged in https://issues.guix.gnu.org/56729 while others are new.
>
> Vinicius Monego (10):
> gnu: Add python-memory-allocator.
> gnu: Add python-calver.
> gnu: Add python-async-lru.
> gnu: Add python-isoduration.
> gnu: Add python-uri-template.
> gnu: Add python-pyproject-api.
> gnu: Add primecount.
> gnu: Add python-primecountpy.
> gnu: Add python-types-dateutil.
> gnu: Add python-pplpy.
>
> gnu/packages/maths.scm | 47 ++++++++++++
> gnu/packages/python-xyz.scm | 143 ++++++++++++++++++++++++++++++++++++
> gnu/packages/sagemath.scm | 52 +++++++++++++
> 3 files changed, 242 insertions(+)
>
>
> base-commit: 89cd778f6a45cd9b43a4dc1f236dcd0a87af955c
I just saw that python-isoduration and python-uri-template are in the
python-team branch already, and also a few other standard packages not
in this series.
A
A
Andreas Enge wrote on 22 May 17:10 +0200
Re: SageMath packaging work
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
Zk4KzOqvEwcm_8oi@jurong
Am Wed, May 22, 2024 at 03:50:43PM +0100 schrieb Sharlatan Hellseher:
Toggle quote (5 lines)
> 56729 patch[RFC PATCH 00/10] Add sagemath.
> 70924 patch[PATCH 00/10] Add some SageMath standard packages.
> Maybe it needs some love to bring to the master branch.

Indeed that would be welcome. Concerning #70924, we would need to check
with the python-team branch to not duplicate the patches. I will not be
available for the next two weeks, but will be happy to take part in patch
reviewing after that.

Andreas
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70924@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70924
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch