[PATCH] Look at DEBBUGS_DATA for Debbugs data.

  • Open
  • quality assurance status badge
Details
One participant
  • Felix Lechner
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 13 May 21:54 +0200
(address . bug-mumi@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
20240513195444.29074-1-felix.lechner@lease-up.com
Maintaining symbolic links to Debbugs data is not reasonable burden
for co-existing installations of various versions of Debbugs and Mumi.

This change further allows the location to be configured in an
operating-system declaration that syncronizes the data from
debbugs.gnu.org via a Shepherd timer. A patch with a 'configuration'
record is available but has not been submitted.
---
mumi/config.scm.in | 21 +++++++++++----------
1 file changed, 11 insertions(+), 10 deletions(-)

Toggle diff (36 lines)
diff --git a/mumi/config.scm.in b/mumi/config.scm.in
index eda815b..cf916fb 100644
--- a/mumi/config.scm.in
+++ b/mumi/config.scm.in
@@ -62,16 +62,17 @@
(string-replace dir "@prefix@"
0 (string-length "${prefix}"))
dir)))))
- (data-dir . ,(let ((maybe-dir
- (string-append (getcwd) "/data")))
- (if (and (getenv "MUMI_UNINSTALLED")
- (file-exists? maybe-dir))
- maybe-dir
- (let ((dir "@localstatedir@/mumi/data"))
- (if (string-prefix? "${prefix}" dir)
- (string-replace dir "@prefix@"
- 0 (string-length "${prefix}"))
- dir)))))
+ (data-dir . ,(or (getenv "DEBBUGS_DATA")
+ (let ((maybe-dir
+ (string-append (getcwd) "/data")))
+ (if (and (getenv "MUMI_UNINSTALLED")
+ (file-exists? maybe-dir))
+ maybe-dir
+ (let ((dir "@localstatedir@/mumi/data"))
+ (if (string-prefix? "${prefix}" dir)
+ (string-replace dir "@prefix@"
+ 0 (string-length "${prefix}"))
+ dir))))))
(host . "localhost")
(port . 1234)
(cache-ttl . 120)

base-commit: 99416ed5c7d950eaf54d52023a2efd975bccac92
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70922@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70922
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch