[PATCH] gnu: Add emacs-helm-org-ql.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 13 May 12:49 +0200
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20240513104938.13078-1-ngraves@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-helm-org-ql): New variable.
(emacs-org-ql)[phases]: Add phase 'remove-helm-org-ql.
[propagated-inputs]: Remove emacs-helm, emacs-helm-org.

The author didn't mean to make the package depend on helm :
"Note that Helm is not declared as a package dependency, so this does
not cause Helm to be installed.", but the way we packaged it in Guix
did. Split the extension into a separate dependency instead, this
avoids 3 Mo to be propagated in a profile where it's not meant.

Change-Id: I3537c0b08cfffac3d66b761173761a3806497358
---
gnu/packages/emacs-xyz.scm | 36 +++++++++++++++++++++++++++++++++---
1 file changed, 33 insertions(+), 3 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9e3bd5ae647..861402f9f52 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23860,15 +23860,18 @@ (define-public emacs-org-ql
(arguments
(list
#:tests? #f ;FIXME: check phase freezes
- #:test-command #~(list "buttercup" "-L" ".")))
+ #:test-command #~(list "buttercup" "-L" ".")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-helm-org-ql
+ (lambda _
+ (delete-file "helm-org-ql.el"))))))
(native-inputs
(list emacs-buttercup emacs-with-simulated-input emacs-xr))
(propagated-inputs
(list emacs-compat
emacs-dash
emacs-f
- emacs-helm
- emacs-helm-org
emacs-org
emacs-org-super-agenda
emacs-ov
@@ -23881,6 +23884,33 @@ (define-public emacs-org-ql
files, allowing for actions to be performed based on search criteria.")
(license license:gpl3+)))
+(define-public emacs-helm-org-ql
+ (package/inherit emacs-org-ql
+ (name "emacs-helm-org-ql")
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-emacs-org-ql
+ (lambda _
+ (install-file "helm-org-ql.el" "..")
+ (let ((cwd (getcwd)))
+ (with-directory-excursion ".."
+ (delete-file-recursively cwd)
+ (mkdir cwd)
+ (install-file "helm-org-ql.el" cwd))))))))
+ (propagated-inputs
+ (list emacs-dash
+ emacs-helm
+ emacs-helm-org
+ emacs-org-ql
+ emacs-s))
+ (synopsis "Helm commands for @code{emacs-org-ql}")
+ (description "This package provides @code{emacs-helm} commands for
+@{emacs-org-ql}, a Lispy query language for Org files, allowing for actions to
+be performed based on search criteria.")))
+
(define-public emacs-bing-dict
(package
(name "emacs-bing-dict")
--
2.41.0
A
A
Andrew Tropin wrote on 14 May 13:08 +0200
(address . ngraves@ngraves.fr)
87fruky7kj.fsf@trop.in
On 2024-05-13 12:49, Nicolas Graves via Guix-patches via wrote:

Toggle quote (48 lines)
> * gnu/packages/emacs-xyz.scm (emacs-helm-org-ql): New variable.
> (emacs-org-ql)[phases]: Add phase 'remove-helm-org-ql.
> [propagated-inputs]: Remove emacs-helm, emacs-helm-org.
>
> The author didn't mean to make the package depend on helm :
> "Note that Helm is not declared as a package dependency, so this does
> not cause Helm to be installed.", but the way we packaged it in Guix
> did. Split the extension into a separate dependency instead, this
> avoids 3 Mo to be propagated in a profile where it's not meant.
>
> Change-Id: I3537c0b08cfffac3d66b761173761a3806497358
> ---
> gnu/packages/emacs-xyz.scm | 36 +++++++++++++++++++++++++++++++++---
> 1 file changed, 33 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 9e3bd5ae647..861402f9f52 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -23860,15 +23860,18 @@ (define-public emacs-org-ql
> (arguments
> (list
> #:tests? #f ;FIXME: check phase freezes
> - #:test-command #~(list "buttercup" "-L" ".")))
> + #:test-command #~(list "buttercup" "-L" ".")
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'remove-helm-org-ql
> + (lambda _
> + (delete-file "helm-org-ql.el"))))))
> (native-inputs
> (list emacs-buttercup emacs-with-simulated-input emacs-xr))
> (propagated-inputs
> (list emacs-compat
> emacs-dash
> emacs-f
> - emacs-helm
> - emacs-helm-org
> emacs-org
> emacs-org-super-agenda
> emacs-ov
> @@ -23881,6 +23884,33 @@ (define-public emacs-org-ql
> files, allowing for actions to be performed based on search criteria.")
> (license license:gpl3+)))
>
> +(define-public emacs-helm-org-ql
> + (package/inherit emacs-org-ql

Changed package/inherit macro to (package (inherit emacs-org-ql).

Toggle quote (29 lines)
> + (name "emacs-helm-org-ql")
> + (arguments
> + (list
> + #:tests? #f ;no tests
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'remove-emacs-org-ql
> + (lambda _
> + (install-file "helm-org-ql.el" "..")
> + (let ((cwd (getcwd)))
> + (with-directory-excursion ".."
> + (delete-file-recursively cwd)
> + (mkdir cwd)
> + (install-file "helm-org-ql.el" cwd))))))))
> + (propagated-inputs
> + (list emacs-dash
> + emacs-helm
> + emacs-helm-org
> + emacs-org-ql
> + emacs-s))
> + (synopsis "Helm commands for @code{emacs-org-ql}")
> + (description "This package provides @code{emacs-helm} commands for
> +@{emacs-org-ql}, a Lispy query language for Org files, allowing for actions to
> +be performed based on search criteria.")))
> +
> (define-public emacs-bing-dict
> (package
> (name "emacs-bing-dict")

Applied, pushed as
you!

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmZDRiwACgkQIgjSCVjB
3rB1Yg//eyU4ql++P/EKUS2qIr0uGAGQOt9VR59CM5KYsUMXLmzj5xNOaYI5AOiO
En/KvutFyo3AKlEK/F8M1AYszaA2jnOiKkw7eQiqG4TwfhmRoOKIVrrodULHAgAC
SuxV4PEkbdAp9h8FWIhYSPQomRE5i8JVRwNLf6T8OGYr3G05xK75DyBUffcUy5hx
mDCNUfbexYIbK2x4oIw1tdw2R85RSyW5H8OwbnhE4RCgwOfrXK/EhU9FgRr4DVwi
G8kVV9qqpr+4OUC4audAEt+TaH6RWudu+IETaVDPZeej9kcl5oYn4o2yFZG3GEUl
gGKaZ2D4UwGXXi6hMG4Zt/AKG4ehy6UXgQFhU/sT52xtMOSaA5Qa/URnx8Ol6mOz
rpxJz0vpJkLYJdteR1UIFebjLNBfCLQggWgLxEe/cdBt6J0dE7TwtIHSrqUAGRE4
4NDALFaQyxjF+LMdhAbAHg9sUYoq9mMfcqxYgj+EM+XzWgvHgUiG85cGwjgnqnSu
q2/kqCZtMqlvI8vpbJ9Rdj+3syPJcweDo85k2HsoiLqjVB6RLb7kmN+jI4EsITQP
evU7dyw7eVQtzqVOCu5SnZd73NN5745JshtX4jmYGlTkylIVFCnmVPcn0HsptLiU
jZ+yYyxaXqqEO0WPTLJ8e10uOcLn71laYS80nlK/5tUYma/rcUc=
=QlYw
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 70917@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70917
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch