[PATCH] Use lowercase utf-8 for charset in Content-Type.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Felix Lechner
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal

Debbugs page

Felix Lechner wrote 10 months ago
(address . bug-mumi@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
20240513043741.6731-1-felix.lechner@lease-up.com
The standard is case-insensitive, but the world is moving to
lowercase. See comments here:


A preview of this code is live at patchwise.org.
---
mumi/web/view/html.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/mumi/web/view/html.scm b/mumi/web/view/html.scm
index 2275799..3172af6 100644
--- a/mumi/web/view/html.scm
+++ b/mumi/web/view/html.scm
@@ -56,7 +56,7 @@
(html (@ (lang "en"))
(head
(title ,title)
- (meta (@ (http-equiv "Content-Type") (content "text/html; charset=UTF-8")))
+ (meta (@ (http-equiv "Content-Type") (content "text/html; charset=utf-8")))
(meta (@ (name "author") (content "Ricardo Wurmus")))
(meta (@ (name "viewport")
(content "width=device-width, initial-scale=1")))

base-commit: 99416ed5c7d950eaf54d52023a2efd975bccac92
--
2.41.0
Arun Isaac wrote 9 months ago
(address . 70905-done@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
87ttia2af4.fsf@systemreboot.net
Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70905@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70905
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help