[PATCH] Don't ship nested duplicates of web assets; no $(wildcard ...).

  • Open
  • quality assurance status badge
Details
One participant
  • Felix Lechner
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 13 May 06:19 +0200
(address . bug-mumi@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
20240513041905.4777-1-felix.lechner@lease-up.com
This was possibly the result of an incorrect understanding of Automake
variable prefixes like "base".

Also, Automake does not support wildcards:

---
Makefile.am | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)

Toggle diff (47 lines)
diff --git a/Makefile.am b/Makefile.am
index 3e57e63..70f7f85 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,15 +24,6 @@ bin_SCRIPTS = \
moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
godir = $(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
-assetsdir = $(pkgdatadir)/assets
-assetscssdir = $(assetsdir)/css
-assetsimgdir = $(assetsdir)/img
-assetsjsdir = $(assetsdir)/js
-
-assetscss_DATA = $(wildcard assets/css/*)
-assetsimg_DATA = $(wildcard assets/img/*)
-assetsjs_DATA = $(wildcard assets/js/*)
-
dist_pkgdata_DATA = etc/schema.sql
SOURCES = \
@@ -80,9 +71,19 @@ PICO_SCSS = $(wildcard assets/pico/scss/*.scss)
assets/css/mumi.css: assets/mumi.scss assets/_theme-switcher.scss $(PICO_SCSS)
$(SASSC) $< $@
-nobase_dist_assets_DATA = \
- assets/css/mumi.css \
- $(assetsjs_DATA) $(assetsimg_DATA)
+nobase_nodist_pkgdata_DATA = \
+ assets/css/mumi.css
+
+nobase_dist_pkgdata_DATA = \
+ assets/css/reset.css \
+ assets/css/screen.css \
+ assets/img/file.svg \
+ assets/img/logo.png \
+ assets/img/spin.gif \
+ assets/js/mumi.js \
+ assets/js/sort-table.js \
+ assets/js/theme-switcher.js \
+ assets/js/tokeninput.js
EXTRA_DIST += \
pre-inst-env.in \

base-commit: 99416ed5c7d950eaf54d52023a2efd975bccac92
--
2.41.0
F
F
Felix Lechner wrote on 13 May 06:45 +0200
Preview available
(address . 70904@debbugs.gnu.org)
8734qmxqug.fsf@lease-up.com
A preview of this code is live at patchwise.org.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70904@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70904
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch