[PATCH] Drop two invocations of 'apply'.

  • Open
  • quality assurance status badge
Details
One participant
  • Felix Lechner
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 13 May 06:20 +0200
(address . bug-mumi@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
20240513042012.5053-1-felix.lechner@lease-up.com
They stood out among other nearby calls to render-html, and do not
appear to be needed.
---
mumi/web/download.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/mumi/web/download.scm b/mumi/web/download.scm
index 5c12fca..d4eb09e 100644
--- a/mumi/web/download.scm
+++ b/mumi/web/download.scm
@@ -56,7 +56,7 @@ PATH."
(html-response (email-headers entry)
(email-body entry)))
(_
- (apply render-html (unknown id)))))
+ (render-html (unknown id)))))
(define (download-raw id msg-num)
"Handle download of an attachment for bug ID, message number
@@ -77,4 +77,4 @@ PATH."
(content-disposition text/plain
(filename . ,(format #f "~a-~a.mbox" id msg-num))))
(list-ref emails msg-num))
- (apply render-html (unknown id))))
+ (render-html (unknown id))))

base-commit: 99416ed5c7d950eaf54d52023a2efd975bccac92
--
2.41.0
F
F
Felix Lechner wrote on 13 May 06:46 +0200
Preview available
(address . 70902@patchwise.org)
87wmnywc7m.fsf@lease-up.com
A preview of this code is live at patchwise.org.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70902@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70902
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch