[PATCH] gnu: Add guile-avatar.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Felix Lechner
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 11 May 05:11 +0200
(address . guix-patches@patchwise.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
064439faf1749cdb7176f1ed2db7f675d31a3e98.1715397071.git.felix.lechner@lease-up.com
* gnu/packages/guile-xyz.scm (guile-avatar): New variable.

For avatars in Mumi.

Change-Id: Ib255842ff8b59b7743c8d7be728a7ca7370024fe
---
gnu/packages/guile-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index dd56bffed9..8251493349 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -558,6 +558,34 @@ (define-public guile-aspell
dictionary and suggesting spelling corrections.")
(license license:gpl3+)))
+(define-public guile-avatar
+ (let ((commit "c2860952fd09ecc878c3d4f1ee2f1678668fbb7a")
+ (revision "0"))
+ (package
+ (name "guile-avatar")
+ (version (git-version "0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/lechner/guile-avatar")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dq9zcx4q3m5s3cpixq4zvlmdrlcc626mpqb7nmmj7vnda8k717f"))))
+ (build-system guile-build-system)
+ (arguments
+ (list
+ #:source-directory "scm"))
+ (inputs (list guile-3.0))
+ (propagated-inputs (list guile-hashing))
+ (home-page "https://codeberg.org/lechner/guile-avatar")
+ (synopsis "Get URLs for free avatar services from an email address")
+ (description
+ "Guile-Avatar helps you to determine URLs for free avatar services
+from the provided email address.")
+ (license license:agpl3+))))
+
(define-public guile2.0-bash
;; This project is currently retired. It was initially announced here:
;; <https://lists.gnu.org/archive/html/guile-user/2015-02/msg00003.html>.

base-commit: 703ae431f4ad28658e34675310b4fdf58685ccdd
--
2.41.0
A
A
Arun Isaac wrote on 11 May 18:13 +0200
(address . 70870-done@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
87ttj45nt3.fsf@systemreboot.net
Hi Felix,

I have pushed this patch with small edits.

Thanks!
Arun
Closed
F
F
Felix Lechner wrote on 12 May 17:47 +0200
(no subject)
(address . control@patchwise.org)
87wmnzvxp7.fsf@lease-up.com
reassign 70870 guix-patches
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70870@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70870
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch