[PATCH] gnu: Add emacs-casual-dired.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Nicolas Graves
  • Wilko Meyer
Owner
unassigned
Submitted by
Wilko Meyer
Severity
normal
W
W
Wilko Meyer wrote on 11 May 02:05 +0200
(address . guix-patches@gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
35b2207e2fd04676a2cc94e53571f6184a76e89d.1715385956.git.w@wmeyer.eu
* gnu/packages/emacs-xyz.scm (emacs-casual-dired): New variable.

Change-Id: Idd6a0e49b740c72dabe2e069cc4fc67f4909b7e9
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 310c4e1587..54b2132251 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -138,6 +138,7 @@
;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32693,6 +32694,31 @@ (define-public emacs-cascading-dir-locals
all of your projects, then override or add variables on a per-project basis.")
(license license:gpl3+))))
+(define-public emacs-casual-dired
+ (package
+ (name "emacs-casual-dired")
+ (version "20240509.108")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kickingvegas/casual-dired.git")
+ (commit "9f65992e362c65a3023e4e2bc4853df9e92fa2d4")))
+ (sha256
+ (base32 "19h5m0nwhvbcfr5xsndin4hgqsqpj4jvdbpx8g4iyv79jdx7jvcf"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "lisp"))))))
+ (home-page "https://github.com/kickingvegas/casual-dired")
+ (synopsis "Transient-based porcelain for dired")
+ (description
+ "Casual Dired is an opinionated Transient-based porcelain for Emacs Dired.")
+ (license license:gpl3)))
+
(define-public emacs-calibredb
(package
(name "emacs-calibredb")

base-commit: da9f509b0300f1b6b979c68a52d8669f9bcb89a7
prerequisite-patch-id: 486a565e86a4b3205f40f0b708108271ee9274c3
--
2.41.0
N
N
Nicolas Graves wrote on 30 May 23:35 +0200
878qzrc7ap.fsf@ngraves.fr
Hi Wilko,

guix lint complains about two warnings :

Toggle quote (3 lines)
> gnu/packages/emacs-xyz.scm:32831:5: emacs-casual-dired@20240509.108: the
> source file name should contain the package name

Here you have to add
(file-name (git-file-name name version))
after the uri field for it to stop complaining.

Toggle quote (4 lines)
> gnu/packages/emacs-xyz.scm:32831:5: emacs-casual-dired@20240509.108:
> permanent redirect from https://github.com/kickingvegas/casual-dired.git
> to https://github.com/kickingvegas/casual-dired

Here you can remove the .git suffix at the end of the url.

Moreover, there are releases on the github page available as tags, we
should probably rely on these rather than the melpa version you
provided, unless we have good reasons to do otherwise.

Can you make these changes and resend a patch? Thanks!

--
Best regards,
Nicolas Graves
W
W
Wilko Meyer wrote on 6 Jun 21:22 +0200
[PATCH v2] gnu: Add emacs-casual-dired.
(address . 70869@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
20240606192217.491-2-w@wmeyer.eu
* gnu/packages/emacs-xyz.scm (emacs-casual-dired): New variable.

Change-Id: I5208b1699baa94a610d27d2d04d5f54015d9905d
---
Hi Nicolas,

Thanks for reviewing my patch and the suggestions on how to improve
the package quality!

I've added the file-name to the package definition, removed the .git
suffix from the packages URL and changed the versioning to using tags
instead of the melpa version. As guix lint doesn't complain and the
package still successfully builds locally, I hope that everything's
alright now.

Cheers!

gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bef0afc99f..a3e54d6ca8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -139,6 +139,7 @@
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32843,6 +32844,32 @@ (define-public emacs-cascading-dir-locals
all of your projects, then override or add variables on a per-project basis.")
(license license:gpl3+))))
+(define-public emacs-casual-dired
+ (package
+ (name "emacs-casual-dired")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kickingvegas/casual-dired")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07dn2nfjvg348qy7kfn1kywclw9g71x8j85ilwz26pp9hv64qhmc"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "lisp"))))))
+ (home-page "https://github.com/kickingvegas/casual-dired")
+ (synopsis "Transient-based porcelain for dired")
+ (description
+ "Casual Dired is an opinionated Transient-based porcelain for Emacs Dired.")
+ (license license:gpl3)))
+
(define-public emacs-calibredb
(package
(name "emacs-calibredb")
--
2.41.0
L
L
Ludovic Courtès wrote on 13 Jun 22:48 +0200
(name . Wilko Meyer)(address . w@wmeyer.eu)
87wmmsh8md.fsf@gnu.org
Hi,

Wilko Meyer <w@wmeyer.eu> skribis:

Toggle quote (4 lines)
> * gnu/packages/emacs-xyz.scm (emacs-casual-dired): New variable.
>
> Change-Id: I5208b1699baa94a610d27d2d04d5f54015d9905d

[...]

Toggle quote (2 lines)
> + (license license:gpl3)))

I changed this to ‘license:gpl3+’ because the code explicitly says “or
any later version”.

Thank you, and thanks Nicolas for reviewing!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70869@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70869
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch