[PATCH] guix-install.sh: Relax check for OpenRC.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal
T
T
Tomas Volf wrote on 9 May 12:14 +0200
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
10938d4d6fa68f33bf4cbf877ca2462e2547542e.1715249659.git.~@wolfsden.cz
On my virtual private servers running Alpine, the install script failed to
identify the init system. The virtual server is LXC based, and OpenRC
identifies itself like this:

# openrc --version
openrc (OpenRC [LXC]) 0.52.1

The regular expression failed to match it. After relaxing the check (by
removing the trailing `)' requirement) the installation went fine and I got
functional Guix installation.

* etc/guix-install.sh (chk_init_sys): Drop trailing \) from the regular
expression.

Change-Id: I5f951226341e631fb34cc6c26cfbb87656dab77a
---
etc/guix-install.sh | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index 82accfd5d5..c5a04bb1f4 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -217,7 +217,7 @@ chk_init_sys()
_msg "${INF}init system is: sysv-init"
INIT_SYS="sysv-init"
return 0
- elif [[ $(openrc --version 2>/dev/null) =~ \(OpenRC\) ]]; then
+ elif [[ $(openrc --version 2>/dev/null) =~ \(OpenRC ]]; then
_msg "${INF}init system is: OpenRC"
INIT_SYS="openrc"
return 0
--
2.41.0
L
L
Ludovic Courtès wrote on 2 Jun 11:41 +0200
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 70843-done@debbugs.gnu.org)
87ed9fn0lt.fsf@gnu.org
Tomas Volf <~@wolfsden.cz> skribis:

Toggle quote (16 lines)
> On my virtual private servers running Alpine, the install script failed to
> identify the init system. The virtual server is LXC based, and OpenRC
> identifies itself like this:
>
> # openrc --version
> openrc (OpenRC [LXC]) 0.52.1
>
> The regular expression failed to match it. After relaxing the check (by
> removing the trailing `)' requirement) the installation went fine and I got
> functional Guix installation.
>
> * etc/guix-install.sh (chk_init_sys): Drop trailing \) from the regular
> expression.
>
> Change-Id: I5f951226341e631fb34cc6c26cfbb87656dab77a

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70843@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70843
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch