[PATCH] gnu: Add decker.

  • Open
  • quality assurance status badge
Details
2 participants
  • Jorge Acereda
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Jorge Acereda
Severity
normal
J
J
Jorge Acereda wrote on 9 May 00:06 +0200
(address . guix-patches@gnu.org)(name . Jorge Acereda)(address . jacereda@gmail.com)
73c76565b8a5cedbf8646fc2695220d72f514bef.1715206015.git.jacereda@gmail.com
Change-Id: Id0879002f9ce0928051dda40ba0dc7bc233ea439
---
gnu/packages/decker.scm | 72 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 72 insertions(+)
create mode 100644 gnu/packages/decker.scm

Toggle diff (82 lines)
diff --git a/gnu/packages/decker.scm b/gnu/packages/decker.scm
new file mode 100644
index 0000000000..c5c317f770
--- /dev/null
+++ b/gnu/packages/decker.scm
@@ -0,0 +1,72 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Jorge Acereda <jacereda@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+(define-module (gnu packages decker)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages sdl)
+ #:use-module (gnu packages vim)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages))
+
+(define-public decker
+ (package
+ (name "decker")
+ (version "1.41")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JohnEarnest/Decker")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nmhqgqxcgaw6yyxn0xn9zqwjb4kqqqmgrlfnswm7zksmw0qax82"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list
+ (sdl-union
+ (list
+ sdl2-image
+ sdl2))))
+ (native-inputs
+ (list
+ xxd))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (invoke "make" "lilt" "decker")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (lambda _
+ (invoke "test")))))
+ (replace 'install
+ (lambda _
+ (invoke "make" "install" (string-append "PREFIX=" #$output)))))))
+ (home-page "http://beyondloom.com/decker/")
+ (synopsis "Multimedia sketchpad")
+ (description "Decker is a multimedia platform for creating and sharing interactive
+documents, with sound, images, hypertext, and scripted behavior.")
+ (license license:expat)))

base-commit: 014875b29e68da6357a5323e6dd1eaa74a05b753
--
2.41.0
J
J
Jorge Acereda wrote on 9 May 12:10 +0200
[PATCH v2] gnu: Add decker.
(address . 70837@debbugs.gnu.org)(name . Jorge Acereda)(address . jacereda@gmail.com)
55eb6179eeef0680cc35441be90544b1767df1ba.1715249425.git.jacereda@gmail.com
Change-Id: Id0879002f9ce0928051dda40ba0dc7bc233ea439
---
gnu/local.mk | 1 +
gnu/packages/decker.scm | 72 +++++++++++++++++++++++++++++++++++++++++
2 files changed, 73 insertions(+)
create mode 100644 gnu/packages/decker.scm

Toggle diff (94 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index edd546f81d..f5d3785f5f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -232,6 +232,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/debug.scm \
%D%/packages/dejagnu.scm \
%D%/packages/dezyne.scm \
+ %D%/packages/decker.scm \
%D%/packages/dhall.scm \
%D%/packages/dico.scm \
%D%/packages/dictionaries.scm \
diff --git a/gnu/packages/decker.scm b/gnu/packages/decker.scm
new file mode 100644
index 0000000000..c5c317f770
--- /dev/null
+++ b/gnu/packages/decker.scm
@@ -0,0 +1,72 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Jorge Acereda <jacereda@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+(define-module (gnu packages decker)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages sdl)
+ #:use-module (gnu packages vim)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages))
+
+(define-public decker
+ (package
+ (name "decker")
+ (version "1.41")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JohnEarnest/Decker")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nmhqgqxcgaw6yyxn0xn9zqwjb4kqqqmgrlfnswm7zksmw0qax82"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list
+ (sdl-union
+ (list
+ sdl2-image
+ sdl2))))
+ (native-inputs
+ (list
+ xxd))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (invoke "make" "lilt" "decker")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (lambda _
+ (invoke "test")))))
+ (replace 'install
+ (lambda _
+ (invoke "make" "install" (string-append "PREFIX=" #$output)))))))
+ (home-page "http://beyondloom.com/decker/")
+ (synopsis "Multimedia sketchpad")
+ (description "Decker is a multimedia platform for creating and sharing interactive
+documents, with sound, images, hypertext, and scripted behavior.")
+ (license license:expat)))

base-commit: 014875b29e68da6357a5323e6dd1eaa74a05b753
--
2.41.0
M
M
Maxim Cournoyer wrote on 24 Jun 05:55 +0200
Re: [bug#70837] [PATCH] gnu: Add decker.
(name . Jorge Acereda)(address . jacereda@gmail.com)(address . 70837@debbugs.gnu.org)
8734p32dvd.fsf@gmail.com
Hi!

Jorge Acereda <jacereda@gmail.com> writes:

Toggle quote (2 lines)
> Change-Id: Id0879002f9ce0928051dda40ba0dc7bc233ea439

[...]

Toggle quote (21 lines)
> +(define-public decker
> + (package
> + (name "decker")
> + (version "1.41")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/JohnEarnest/Decker")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0nmhqgqxcgaw6yyxn0xn9zqwjb4kqqqmgrlfnswm7zksmw0qax82"))))
> + (build-system gnu-build-system)
> + (inputs
> + (list
> + (sdl-union
> + (list
> + sdl2-image
> + sdl2))))

Is a union necessary here? I'm not familiar with the use of
'sdl-union'. What happens if it's not used?

Toggle quote (9 lines)
> + (native-inputs
> + (list
> + xxd))
> + (arguments
> + (list
> + #:phases
> + #~(modify-phases %standard-phases
> + (delete 'configure)

Configure-less packages often have compiler Make variables (flags) to
set for cross-compilation, e.g 'CC', which should be set to
#$(cc-for-target).

Toggle quote (4 lines)
> + (replace 'build
> + (lambda _
> + (invoke "make" "lilt" "decker")))

This looses the parallel build. Grep the source to see how "-j" and
(parallel-job-count) are typically used, along the #:parallel-build?
phase argument.

Toggle quote (6 lines)
> + (replace 'check
> + (lambda* (#:key tests? #:allow-other-keys)
> + (when tests?
> + (lambda _
> + (invoke "test")))))

This check phase override can be replaced by using the #:test-target
"test" argument instead.

Toggle quote (4 lines)
> + (replace 'install
> + (lambda _
> + (invoke "make" "install" (string-append "PREFIX=" #$output)))))))

This phase override can be replaced by specifying PREFIX in the
#:make-flags argument.

Toggle quote (8 lines)
> + (synopsis "Multimedia sketchpad")
> + (description "Decker is a multimedia platform for creating and sharing interactive
> +documents, with sound, images, hypertext, and scripted behavior.")
> + (license license:expat)))
>
> base-commit: 014875b29e68da6357a5323e6dd1eaa74a05b753

Could you please send a v2?

--
Thanks,
Maxim
J
J
Jorge Acereda wrote on 29 Jun 19:52 +0200
[PATCH v2] gnu: Add decker.
(address . 70837@debbugs.gnu.org)(name . Jorge Acereda)(address . jacereda@gmail.com)
698abda4e1a7fbde9dfb1a54738c497151ef076a.1719683564.git.jacereda@gmail.com
Change-Id: Id0879002f9ce0928051dda40ba0dc7bc233ea439
---
gnu/local.mk | 1 +
gnu/packages/decker.scm | 67 +++++++++++++++++++++++++++++++++++++++++
2 files changed, 68 insertions(+)
create mode 100644 gnu/packages/decker.scm

Toggle diff (89 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index edd546f81d..f5d3785f5f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -232,6 +232,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/debug.scm \
%D%/packages/dejagnu.scm \
%D%/packages/dezyne.scm \
+ %D%/packages/decker.scm \
%D%/packages/dhall.scm \
%D%/packages/dico.scm \
%D%/packages/dictionaries.scm \
diff --git a/gnu/packages/decker.scm b/gnu/packages/decker.scm
new file mode 100644
index 0000000000..eb30e1dde9
--- /dev/null
+++ b/gnu/packages/decker.scm
@@ -0,0 +1,67 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Jorge Acereda <jacereda@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+(define-module (gnu packages decker)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages sdl)
+ #:use-module (gnu packages vim)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (guix utils)
+ #:use-module (guix git-download)
+ #:use-module (guix packages))
+
+(define-public decker
+ (package
+ (name "decker")
+ (version "1.45")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JohnEarnest/Decker")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j247c8swmcyd30j82l7094430ynlgy007648lp2knyixzp9xjh0"))))
+ (build-system gnu-build-system)
+ (inputs (list (sdl-union (list sdl2-image sdl2))))
+ (native-inputs (list xxd))
+ (arguments
+ (list
+ #:test-target "test"
+ #:make-flags #~(list (string-append "PREFIX="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "Makefile"
+ (("COMPILER=.*")
+ (string-append "COMPILER="
+ #$(cc-for-target))))))
+ (replace 'build
+ (lambda _
+ (invoke "make" "lilt" "decker" "-j"
+ (number->string (parallel-job-count))))))))
+ (home-page "http://beyondloom.com/decker/")
+ (synopsis "Multimedia sketchpad")
+ (description
+ "Decker is a multimedia platform for creating and sharing interactive
+documents, with sound, images, hypertext, and scripted behavior.")
+ (license license:expat)))

base-commit: 014875b29e68da6357a5323e6dd1eaa74a05b753
--
2.41.0
M
M
Maxim Cournoyer wrote on 10 Jul 04:48 +0200
(name . Jorge Acereda)(address . jacereda@gmail.com)(address . 70837@debbugs.gnu.org)
87frsiufln.fsf@gmail.com
Hi,

Jorge Acereda <jacereda@gmail.com> writes:

Toggle quote (2 lines)
> Change-Id: Id0879002f9ce0928051dda40ba0dc7bc233ea439

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

Thanks for the v2 and the provided explanations.

--
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70837@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70837
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch