[PATCH 0/2] Update gnome-maps to 46.10

  • Done
  • quality assurance status badge
Details
3 participants
  • Jonathan Brielmaier
  • Christopher Baines
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal
J
J
Jonathan Brielmaier wrote on 8 May 14:48 +0200
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
cover.1715172318.git.jonathan.brielmaier@web.de
gnome-maps is running fine.
Remarks:
* I filed an issue to make the libportal dependency optional: https://gitlab.gnome.org/GNOME/gnome-maps/-/issues/696
* should we use `#:disallowed-references (,tzdata-for-tests)` for
gnome-maps?

Jonathan Brielmaier (2):
gnu: libshumate: Update to 1.2.1.
gnu: gnome-maps: Update to 46.10.

gnu/packages/geo.scm | 16 +++++++++++++---
gnu/packages/gnome.scm | 12 +++++++-----
2 files changed, 20 insertions(+), 8 deletions(-)


base-commit: aa9ac252206615713ab988d7068da9e14a9bccc0
--
2.41.0
J
J
Jonathan Brielmaier wrote on 8 May 14:51 +0200
[PATCH 1/2] gnu: libshumate: Update to 1.2.1.
(address . 70831@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
3e8fe9608b5176c1b1bdabd614904cf49b6eb8fc.1715172318.git.jonathan.brielmaier@web.de
* gnu/packages/gnome.scm (libshumate): Update to 1.2.1.
[arguments]: Drop `-Dlibsoup3=true` configure flag as it got removed
upstream. It only supports libsoup3 now.
[native-inputs]: Add gperf.
[propagated-inputs]: Add json-glib and protobuf-c.

Change-Id: Ibe63b6f2060f6684f8f68f44c2221ba9d6ad5a45
---
gnu/packages/gnome.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 489f23865b..ab76f9c019 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -43,7 +43,7 @@
;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019, 2020 Raghav Gururajan <raghavgururajan@disroot.org>
-;;; Copyright © 2019, 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2019, 2020, 2024 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2019-2022 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -5030,7 +5030,7 @@ (define-public rest-next
(define-public libshumate
(package
(name "libshumate")
- (version "1.0.5")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5038,11 +5038,10 @@ (define-public libshumate
name "-" version ".tar.xz"))
(sha256
(base32
- "0v4m07vxm3m4a2vqkp2wfsc3zsf92fpigc1k8yq49vkpj7gxikx8"))))
+ "04cwakbdr68nw4kh956xhf447fawz8badpyd76hg4ir1gq3yw18i"))))
(build-system meson-build-system)
(arguments
- (list #:configure-flags #~(list "-Dlibsoup3=true")
- #:phases
+ (list #:phases
#~(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? test-options #:allow-other-keys)
@@ -5062,6 +5061,7 @@ (define-public libshumate
(list gi-docgen
`(,glib "bin")
gobject-introspection
+ gperf
pkg-config
;; For tests:
xorg-server-for-tests
@@ -5072,7 +5072,9 @@ (define-public libshumate
(list cairo
glib
gtk
+ json-glib
libsoup
+ protobuf-c
sqlite))
(home-page "https://wiki.gnome.org/Projects/libshumate")
(synopsis "GtkWidget C library for displaying maps")
--
2.41.0
J
J
Jonathan Brielmaier wrote on 8 May 14:51 +0200
[PATCH 2/2] gnu: gnome-maps: Update to 46.10.
(address . 70831@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
28c88e7db49fbe56d7348d45a7efd2e7c85d3577.1715172318.git.jonathan.brielmaier@web.de
* gnu/packages/geo.scm (gnome-maps): Update to 46.10.
[arguments]: Add phase to setup time zones for a new test.
[native-inputs]: Add libportal and tzdata-for-tests.

Change-Id: Ife9b17eda68662d2adb289acfeacf1dc8f179a46
---
gnu/packages/geo.scm | 16 +++++++++++++---
1 file changed, 13 insertions(+), 3 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 985fa77231..1dd0c7ba92 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2022 Roman Scherer <roman.scherer@burningswell.com>
;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2024 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -83,6 +84,7 @@ (define-module (gnu packages geo)
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
@@ -472,7 +474,7 @@ (define-public geos
(define-public gnome-maps
(package
(name "gnome-maps")
- (version "44.5")
+ (version "46.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -480,7 +482,7 @@ (define-public gnome-maps
name "-" version ".tar.xz"))
(sha256
(base32
- "026488yb6azwb2sm0yy0iaipk914l3agvb7d8azks4kyjqlslyb8"))))
+ "1br1ak0cwvvv8rszj9ffyvir7qcbxys940ygy22dzzn2l2byw9az"))))
(build-system meson-build-system)
(arguments
(list
@@ -496,6 +498,12 @@ (define-public gnome-maps
"update_desktop_database"))
(string-append option ": false"))
(else all))))))
+ (add-before 'check 'check-setup
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ ;; for timeTest
+ (setenv "TZDIR"
+ (search-input-directory (or native-inputs inputs)
+ "share/zoneinfo"))))
(add-after 'install 'wrap
(lambda _
(let ((gi-typelib-path (getenv "GI_TYPELIB_PATH")))
@@ -510,7 +518,9 @@ (define-public gnome-maps
(list gettext-minimal
`(,glib "bin")
gobject-introspection
- pkg-config))
+ libportal
+ pkg-config
+ tzdata-for-tests))
(inputs
(list folks
evolution-data-server
--
2.41.0
M
M
Maxim Cournoyer wrote on 8 May 21:45 +0200
Re: [bug#70831] [PATCH 1/2] gnu: libshumate: Update to 1.2.1.
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
87jzk46qaq.fsf@gmail.com
Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

Toggle quote (8 lines)
> * gnu/packages/gnome.scm (libshumate): Update to 1.2.1.
> [arguments]: Drop `-Dlibsoup3=true` configure flag as it got removed
> upstream. It only supports libsoup3 now.
> [native-inputs]: Add gperf.
> [propagated-inputs]: Add json-glib and protobuf-c.
>
> Change-Id: Ibe63b6f2060f6684f8f68f44c2221ba9d6ad5a45

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
C
C
Christopher Baines wrote on 13 May 11:12 +0200
Re: [bug#70831] [PATCH 0/2] Update gnome-maps to 46.10
(name . Jonathan Brielmaier via Guix-patches via)(address . guix-patches@gnu.org)
87ikzi3wk6.fsf@cbaines.net
Jonathan Brielmaier via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (6 lines)
> gnome-maps is running fine.
> Remarks:
> * I filed an issue to make the libportal dependency optional: https://gitlab.gnome.org/GNOME/gnome-maps/-/issues/696
> * should we use `#:disallowed-references (,tzdata-for-tests)` for
> gnome-maps?

That seems fine to me.

Toggle quote (11 lines)
> Jonathan Brielmaier (2):
> gnu: libshumate: Update to 1.2.1.
> gnu: gnome-maps: Update to 46.10.
>
> gnu/packages/geo.scm | 16 +++++++++++++---
> gnu/packages/gnome.scm | 12 +++++++-----
> 2 files changed, 20 insertions(+), 8 deletions(-)
>
>
> base-commit: aa9ac252206615713ab988d7068da9e14a9bccc0

These changes look good though, so I've pushed them to master as
173420d73c5df7b1b5efe1dd186c57dcdb2ae6ae.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZB2WlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdCAxAAl3yifzZyXtsJIpq9u8pQWI0Dbg2Hzjlt
udcliyFIFqXPAqm7+1ZX5pqvVLUWZcBfKxrX6uMCT6+b25dzdm4xD8OocrUlbXD/
tjLIuBvYOQ3nAonny1xTLJGKH5BoJmcj9ofWfEZNS+boq2hrIfYH15XmSFWsd+y7
ikowqpG25cAx1MPyfo9jJSZSB/qytf4qY6WJj9QWWGbCWFyp4q8+TIkWXcK3ED2p
2CmGyLYTFl4jn04hHDCvHiC3rO1bkKR+YuA6DXfeSU+SrenQ3AL/D69cF6vgSgXy
OQn+QMEDEf2EYaC40s+3HjMTPLbUnimu15zpCJBELrnlFcQ70zh2LhgSD51L1bJC
PZkBRfnT/NUjdmFQPx7CXgtwuZWGktYn+JZHL36fg/t9pUKkA9oWdG9x09CymOu2
78Oj3dv8W1l7Rbd75bww2fnLT9DDXIJIFlZORdjfOHVbtdgpcaZSLb7qwOLn1Vd4
N6BnhgoIbwCPUNACW8GdgsSFPLI0Qo+Kyd9YqgN1zs/5IfFnIsGNA99ixq+0HS2+
F2yUm0J2LBgKugi/oc1YqcJnfxXKk9nBvE/JEt52B9KkWDofAx3WvaqhwecHk6vQ
tf7vswmZ88RGrJLMMM/1OhHhAjHHXUhiePw6K/tSsgDw57hzqB6Gj+LSkbYcZqkn
uaux+yjzizI=
=/JgB
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 70831@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70831
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch