[PATCH] gnu: Add r-mlr3cluster r-mlr3data r-mlr3filters r-mlr3fselect r-mlr3hyperband r-mlr3mbo, r-mlr3tuningspaces r-mlr3viz and r-mlr3verse.

  • Done
  • quality assurance status badge
Details
2 participants
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
M?d?lin Ionel Patra?cu
Severity
normal
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 01:50 +0200
(address . guix-patches@gnu.org)
68e858c9-cd7a-46c5-8c75-8cda71321e4c@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3cluster r-mlr3data r-mlr3filters
r-mlr3fselect
r-mlr3hyperband r-mlr3mbo r-mlr3tuningspaces r-mlr3viz, r-mlr3verse): New
variables.
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 03:02 +0200
[PATCH 3/9] gnu: Add r-mlr3filters.
(address . 70827@debbugs.gnu.org)
89d3aa1246d02f741011e3e9f1d2daf270d71501.1715130172.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3filters): New variable.

Change-Id: I94bd79843f5f35eeacb1ea788a76b63e9028f548
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 26ee9bca3e..123d792da7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37799,6 +37799,33 @@ (define-public r-mlr3data
mlr3 is loaded.")
(license license:lgpl3)))
+(define-public r-mlr3filters
+ (package
+ (name "r-mlr3filters")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3filters" version))
+ (sha256
+ (base32 "16z359bc2li7f35xk4g08np3r2a3127avv0ak6bn9bywcs13z6bl"))))
+ (properties `((upstream-name . "mlr3filters")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-backports
+ r-checkmate
+ r-data-table
+ r-mlr3
+ r-mlr3misc
+ r-paradox
+ r-r6))
+ (home-page "https://mlr3filters.mlr-org.com")
+ (synopsis "Filter based feature selection for mlr3")
+ (description
+ "This package extends mlr3 with filter methods for feature selection. Besides
+standalone filter methods built-in methods of any machine-learning algorithm are
+supported. Partial scoring of multivariate filter methods is supported.")
+ (license license:lgpl3)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 03:02 +0200
[PATCH 2/9] gnu: Add r-mlr3data.
(address . 70827@debbugs.gnu.org)
3698e5b69fe46e0431f35acf8e0d2420583e3bf4.1715130172.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3data): New variable.

Change-Id: I93bee828d1ac26da1146c853b4d88fbdec42905f
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0fd94e8cf1..26ee9bca3e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37775,6 +37775,30 @@ (define-public r-mlr3cluster
"This package extends the mlr3 package with cluster analysis.")
(license license:lgpl3)))
+(define-public r-mlr3data
+ (package
+ (name "r-mlr3data")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3data" version))
+ (sha256
+ (base32 "04hwmj8cdszwgd845va26pgzdw0k4cm025zjrmp3fr7ypp73mirg"))))
+ (properties `((upstream-name . "mlr3data")))
+ (build-system r-build-system)
+ (home-page "https://github.com/mlr-org/mlr3data")
+ (synopsis "Collection of machine learning data Sets for mlr3")
+ (description
+ "This package provides a small collection of interesting and educational
+machine learning data sets which are used as examples in the mlr3 book Applied
+machine learning using mlr3 in R @url{https://mlr3book.mlr-org.com}, the use case
+gallery @url{https://mlr3gallery.mlr-org.com}, or in other examples. All data
+sets are properly preprocessed and ready to be analyzed by most machine learning
+algorithms. Data sets are automatically added to the dictionary of tasks if
+mlr3 is loaded.")
+ (license license:lgpl3)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 03:02 +0200
[PATCH 4/9] gnu: Add r-mlr3fselect.
(address . 70827@debbugs.gnu.org)
84bd31ab9f9c2175bba8d667c60f84b4a1f92d68.1715130172.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3fselect): New variable.

Change-Id: I28ced76c34d99c864c09cbf7b92658fb7676b22c
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 123d792da7..459ad63c23 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37826,6 +37826,36 @@ (define-public r-mlr3filters
supported. Partial scoring of multivariate filter methods is supported.")
(license license:lgpl3)))
+(define-public r-mlr3fselect
+ (package
+ (name "r-mlr3fselect")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3fselect" version))
+ (sha256
+ (base32 "1f18y4ahnjzlwk9pfs87i80kb6z84hgyc5cdlj3mafawq790hg1h"))))
+ (properties `((upstream-name . "mlr3fselect")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bbotk
+ r-checkmate
+ r-data-table
+ r-lgr
+ r-mlr3
+ r-mlr3misc
+ r-paradox
+ r-r6))
+ (home-page "https://mlr3fselect.mlr-org.com")
+ (synopsis "Feature selection for mlr3")
+ (description
+ "This package is a feature selection package of the mlr3 ecosystem. It
+selects the optimal feature set for any mlr3 learner. The package works with
+several optimization algorithms e.g. random search, Recursive feature elimination,
+and genetic search. Moreover, it can automatically optimize learners and estimate
+the performance of optimized feature sets with nested resampling.")
+ (license license:lgpl3)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 03:02 +0200
[PATCH 5/9] gnu: Add r-mlr3hyperband.
(address . 70827@debbugs.gnu.org)
4be2d0771f4fd6410a8510a2ff71ba1af0d2bf19.1715130172.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3hyperband): New variable.

Change-Id: I3e7a829da1f7687ef0bb201f6333bdd519cfa025
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 459ad63c23..399225445b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37856,6 +37856,37 @@ (define-public r-mlr3fselect
the performance of optimized feature sets with nested resampling.")
(license license:lgpl3)))
+(define-public r-mlr3hyperband
+ (package
+ (name "r-mlr3hyperband")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3hyperband" version))
+ (sha256
+ (base32 "1x6vfhadxlb4c9q61d5qv957mkyfwdwchzbg3flfd0j28b4bck1p"))))
+ (properties `((upstream-name . "mlr3hyperband")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bbotk
+ r-checkmate
+ r-data-table
+ r-lgr
+ r-mlr3
+ r-mlr3misc
+ r-mlr3tuning
+ r-paradox
+ r-r6))
+ (home-page "https://mlr3hyperband.mlr-org.com")
+ (synopsis "Hyperband for mlr3")
+ (description
+ "This package implements a successive halving and hyperband optimization
+algorithm for the mlr3 ecosystem. The implementation in mlr3hyperband features
+improved scheduling and parallelizes the evaluation of configurations. The package
+includes tuners for hyperparameter optimization in mlr3tuning and optimizers for
+black-box optimization in bbotk.")
+ (license license:lgpl3)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 03:02 +0200
[PATCH 1/9] gnu: Add r-mlr3cluster.
(address . 70827@debbugs.gnu.org)
b63173056e8d0cee3560f18f95d1ee7ad3edeccb.1715130172.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3cluster): New variable.

Change-Id: I3d970afeeaf4de1793974177bcf5abf64c957d6b
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 65e48e3445..0fd94e8cf1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37747,6 +37747,34 @@ (define-public r-mlrmbo
customization by the user.")
(license license:bsd-2)))
+(define-public r-mlr3cluster
+ (package
+ (name "r-mlr3cluster")
+ (version "0.1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3cluster" version))
+ (sha256
+ (base32 "09fsw2b43f9m7clv1qwylimyz622snhn9ykq3xwbiric7zr4ca91"))))
+ (properties `((upstream-name . "mlr3cluster")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-backports
+ r-checkmate
+ r-clue
+ r-cluster
+ r-data-table
+ r-fpc
+ r-mlr3
+ r-mlr3misc
+ r-paradox
+ r-r6))
+ (home-page "https://mlr3cluster.mlr-org.com")
+ (synopsis "Cluster extension for mlr3")
+ (description
+ "This package extends the mlr3 package with cluster analysis.")
+ (license license:lgpl3)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")

base-commit: 00aa6b5a3c1505b033d19c6d3a3021d6d6ecb31b
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 03:02 +0200
[PATCH 6/9] gnu: Add r-mlr3mbo.
(address . 70827@debbugs.gnu.org)
a1621e9fc3303207d2b0ca2f5bdb651e07e73cd3.1715130172.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3mbo): New variable.

Change-Id: I23d7af239f7ab55599faf99d5136621cc45c973f
---
gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 399225445b..d1fc4cbb2f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37887,6 +37887,42 @@ (define-public r-mlr3hyperband
black-box optimization in bbotk.")
(license license:lgpl3)))
+(define-public r-mlr3mbo
+ (package
+ (name "r-mlr3mbo")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3mbo" version))
+ (sha256
+ (base32 "0jdj5dx6jb7n0g950h0j8jhafdj5mcalv5vxfiyf07myr6mjipri"))))
+ (properties `((upstream-name . "mlr3mbo")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bbotk
+ r-checkmate
+ r-data-table
+ r-lgr
+ r-mlr3
+ r-mlr3misc
+ r-mlr3tuning
+ r-paradox
+ r-r6
+ r-spacefillr))
+ (native-inputs (list r-knitr))
+ (home-page "https://mlr3mbo.mlr-org.com")
+ (synopsis "Flexible Bayesian optimization")
+ (description
+ "This package provides a flexible approach to Bayesian optimization / model
+based optimization building on the bbotk package. The mlr3mbo is a toolbox
+providing both ready-to-use optimization algorithms as well as their fundamental
+building blocks allowing for straightforward implementation of custom algorithms.
+Single- and multi-objective optimization is supported as well as mixed continuous,
+categorical and conditional search spaces. Moreover, using mlr3mbo for
+hyperparameter optimization of machine learning models within the mlr3 ecosystem
+is straightforward via mlr3tuning.")
+ (license license:lgpl3)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 03:02 +0200
[PATCH 7/9] gnu: Add r-mlr3tuningspaces.
(address . 70827@debbugs.gnu.org)
3a9b2dc2ba0d9693958cb79b6561d06828529dc2.1715130172.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3tuningspaces): New variable.

Change-Id: Ifb35e78dab862921f000b055d3fa1eee3ef79309
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d1fc4cbb2f..6fcf0eb10d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38031,6 +38031,34 @@ (define-public r-mlr3ordinal
performing ordinal regression.")
(license license:expat))))
+(define-public r-mlr3tuningspaces
+ (package
+ (name "r-mlr3tuningspaces")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3tuningspaces" version))
+ (sha256
+ (base32 "1snrd7xq388mvqh0ydaxvx8k9iwp40g06c3irp0m718jw3wsz5vm"))))
+ (properties `((upstream-name . "mlr3tuningspaces")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate
+ r-data-table
+ r-mlr3
+ r-mlr3misc
+ r-mlr3tuning
+ r-paradox
+ r-r6))
+ (home-page "https://mlr3tuningspaces.mlr-org.com")
+ (synopsis "Search spaces for mlr3")
+ (description
+ "This package is a collection of search spaces for hyperparameter optimization
+in the mlr3 ecosystem. It features ready-to-use search spaces for many popular
+machine learning algorithms. The search spaces are from scientific articles and
+work for a wide range of data sets.")
+ (license license:lgpl3)))
+
(define-public r-paradox
(package
(name "r-paradox")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 03:02 +0200
[PATCH 8/9] gnu: Add r-mlr3viz.
(address . 70827@debbugs.gnu.org)
23421585e25455a72fb83e2e48bdbbed1efda140.1715130172.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3viz): New variable.

Change-Id: Iedca442886ebeb09d26cfa44290192c582aeeef3
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6fcf0eb10d..74c741d754 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38059,6 +38059,34 @@ (define-public r-mlr3tuningspaces
work for a wide range of data sets.")
(license license:lgpl3)))
+(define-public r-mlr3viz
+ (package
+ (name "r-mlr3viz")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3viz" version))
+ (sha256
+ (base32 "1m2f54yqhk1bd4c30vd1z509yblz6y4i8qkwhg73aa1sflnsycvf"))))
+ (properties `((upstream-name . "mlr3viz")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate
+ r-data-table
+ r-ggplot2
+ r-mlr3misc
+ r-scales
+ r-viridis))
+ (home-page "https://mlr3viz.mlr-org.com")
+ (synopsis "Visualizations for mlr3")
+ (description
+ "This package offers features plots for mlr3 objects such as tasks, learners,
+predictions, benchmark results, tuning instances and filters via the
+@code{autoplot()} generic of ggplot2. The mlr3viz package draws plots with
+the viridis color palette and applies the minimal theme. Visualizations include
+barplots, boxplots, histograms, ROC curves, and precision-recall curves.")
+ (license license:lgpl3)))
+
(define-public r-paradox
(package
(name "r-paradox")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 8 May 03:02 +0200
[PATCH 9/9] gnu: Add r-mlr3verse.
(address . 70827@debbugs.gnu.org)
d4c5a2bd77f3baf068ee0e5e952bcc49228a16ed.1715130172.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr3verse): New variable.

Change-Id: I52c01fffd13c72b599ae5bc9ff809daea11eaa59
---
gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 74c741d754..a9db22589a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38059,6 +38059,42 @@ (define-public r-mlr3tuningspaces
work for a wide range of data sets.")
(license license:lgpl3)))
+(define-public r-mlr3verse
+ (package
+ (name "r-mlr3verse")
+ (version "0.2.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3verse" version))
+ (sha256
+ (base32 "0ld4vch1qdq3gh8vhj38s2wz7acn5z7f8hxmnwnrq22g44gckd8s"))))
+ (properties `((upstream-name . "mlr3verse")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bbotk
+ r-data-table
+ r-mlr3
+ r-mlr3cluster
+ r-mlr3data
+ r-mlr3filters
+ r-mlr3fselect
+ r-mlr3hyperband
+ r-mlr3learners
+ r-mlr3mbo
+ r-mlr3misc
+ r-mlr3pipelines
+ r-mlr3tuning
+ r-mlr3tuningspaces
+ r-mlr3viz
+ r-paradox))
+ (home-page "https://mlr3verse.mlr-org.com")
+ (synopsis "Easily install and load of the mlr3 package family")
+ (description
+ "The mlr3 package family is a set of packages for machine-learning purposes
+built in a modular fashion. This wrapper package is aimed to simplify the
+installation and loading of the core mlr3 packages.")
+ (license license:lgpl3)))
+
(define-public r-mlr3viz
(package
(name "r-mlr3viz")
--
2.41.0
R
R
Ricardo Wurmus wrote on 8 May 15:30 +0200
Re: [bug#70827] [PATCH 1/9] gnu: Add r-mlr3cluster.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 70827-done@debbugs.gnu.org)
87frusig7t.fsf@elephly.net
Applied all, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70827@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70827
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch