[PATCH] .dir-locals: Configure indentation for swap-space.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 10 months ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
77b7fb29f722dbec5c06dd02b5db4ef248e2c48d.1715006435.git.~@wolfsden.cz
* .dir-locals.el (scheme-mode): Indent swap-space same as file-system.

Change-Id: Id9f2cbd3c81343b479ab1e4df29c65f8b5bd739f
---
This should ensure that swap-space has same indentation as file-system records.

.dir-locals.el | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/.dir-locals.el b/.dir-locals.el
index 2d1a03c313..d2f6037afe 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -83,6 +83,7 @@
(eval . (put 'graft 'scheme-indent-function 0))
(eval . (put 'operating-system 'scheme-indent-function 0))
(eval . (put 'file-system 'scheme-indent-function 0))
+ (eval . (put 'swap-space 'scheme-indent-function 0))
(eval . (put 'manifest-entry 'scheme-indent-function 0))
(eval . (put 'manifest-pattern 'scheme-indent-function 0))
(eval . (put 'substitute-keyword-arguments 'scheme-indent-function 1))

base-commit: 609576391928c3b497fb4c17b2d2e1448715aa94
--
2.41.0
Ludovic Courtès wrote 10 months ago
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 70802-done@debbugs.gnu.org)
87frulanc8.fsf@gnu.org
Tomas Volf <~@wolfsden.cz> skribis:

Toggle quote (6 lines)
> * .dir-locals.el (scheme-mode): Indent swap-space same as file-system.
>
> Change-Id: Id9f2cbd3c81343b479ab1e4df29c65f8b5bd739f
> ---
> This should ensure that swap-space has same indentation as file-system records.

Applied, thanks!

(guix read-print) already had it.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70802@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70802
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help